Cannot find the meld binary

I tried to use Meld first time.

First I installed Meld from Manjaro repo.
Then gave a command at a Terminal sudo DIFFPROG=meld pacdiff
Nothing happens, just empty line in Terminal.

Then I tried Meld installed from Flatpak.
Same command sudo DIFFPROG=meld pacdiff
Result is ==> ERROR: Cannot find the meld binary required for viewing differences.

Not a good start to trying to compare pacnew-files.
What shall I do to execute Meld?

I try. Like this?

Okay. So that mr. pacman is there again? This time it is not pacnew-files in question, but package versions?

Is this reply related what omano said?

Do you even have a *.pacnew or *.pacsave file to diff on?

I believe so, because I made pacman hook script.
Then I ran sudo pacman -Syu

Result :: Synchronizing package databases... core is up to date extra is up to date community is up to date multilib is up to date :: Starting full system upgrade... warning: gnome-shell-extension-unite: local (57-1) is newer than community (56-1) warning: zsh-theme-powerlevel10k: local (1.15.0+66+g3e515a7-1) is newer than community (1.15.0-2) there is nothing to do

Those warning are related to pacnew-files, I think.

If you want get rid those warnings, you can run sudo pacman -Syyuu. This command downgrade packages to same version as in repository.

The following command works here:

sudo -H DIFFPROG=meld pacdiff

The binary should be found in /usr/bin/meld

change to directory and run ./meld

No they don’t.

Because you have no .pacnew or .pacsave file.

What is output of pacdiff -o?

1 Like

I am not sure if I want to get rid of those. First I want to understand a reason for what happened.

Packages can get reverted to previous version in the repositories.

There is not meld in that directory.



Just empty line.

Not understand what you mean, sorry.
Actually I understand the words, but I don’t understand it really.

Probably, it’s not installed:
pamac install meld

I tried again. Command still not working.

You have no pacnew then.

A package can get to a new version, then because of X reason (it can be a problem in this version, or the update got pushed by mistake, or whatever reason), they decide to get back to a previous version, and if you got the updated version before the package get reverted to previous version, you then have a version newer than what is in the repositories, and pacman throws a warning message about it.

Also please don’t make lot of replies, edit your post instead, select what you want to reply to, click quote, and continue the message. Multi posting in a row is generally not accepted in forums.

He meant the successive posts he highlighted in his screenshot. Now this thread is getting confusing.


1 Like

That means there aren’t any pacnew or pacsave files to view


…especially when @philm makes a snapshot and doesn’t notice I pushed newer packages ahead of it. :wink:

None of the packages @anon75791628 mentioned were purposely downgraded.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.