Cannot find the kbuildsycoca4 executable

I am new to KDE and to Manjaro / Arch. I downloaded a couple of Plasmoids but could not figure out how to actually use or find them. Searching the net I found reference to an executable named “kbuildsycoca4” which is supposed to refresh the known Plasmoids. However I cannot seem to find that executable. I’ve tried all the normal “Unix” methods for locating files, IE find, locate, whereis, which, etc… all to o avail. This isn’t the 1st time I have been unable to locate a file. At 1st there wasn’t a “locate” installed so I installed a package named, mlocate I believe" which did indeed proide the locate function. doesn’t really locate anything but it’s there once you figure out that installing mlocate doesn’t give you an mlocate command but rather a locate command… I guess I just got sidetracked on not being able to simply find a file… which is so odd to have trouble with someting so…Standard maybe. donno. but…

If someone could point me in the direction of that kbuildsycoca4 executable OR some other solution for employing a “Plasmoid” (A pretty cool monicker Plasmoid, I love it! ) I would be grateful. ( and while this isn’t the correct list for it but if there is some secret or big change in the newer Linux’s that did away with all the normal methods for finding a file. I’d appreciate a hint there as well)

Thank you very much.

And it will only show you results after running updatedb (as root). Normally this will be taken care of once a day by way of a systemd timer, or if the machine was powered off when the command was scheduled to run, it will be run at boot. But it has to be run manually if you’ve just installed mlocate. :wink:

Two things here…

  1. kbuildsycoca4 was for Plasma 4. Plasma 5 uses kbuildsycoca5.

  2. It is always possible that the plasmoids you’ve installed aren’t compatible. There’s a lot of stuff at that was designed to work with Plasma 4 and/or with the first releases of Plasma 5 ─ i.e. earlier than Plasma 5.12 ─ but that won’t work anymore (or have become redundant) in all releases from Plasma 5.12 onward.

Thank you very much. The “4” at the end and not a “5” … kinda makes a difference :slight_smile: but I see the rhythm of it… That said I believe it made a difference as I was able to see the ones I’d “Installed” from the add widget… I did check each of the four I installed for Plasma 5 and it would appear from either the details or the KDE store selecting the “Home Page” for the app takes you to. That said… I don’t think any of the four actually function. least ways not out of the box… One of them may have worked but was simply so bad it was better if it didn’t… but I found another which was likely there in the beginning I probably missed. Unfortunately the main one I was interested in called Time Keeper… errors out about somethings not being there or something along those lines. I’ll probably see if I can follow the bread crumbs to see if they take me anywhere with it. donno but hell it did look cool in the advertisements for it :slight_smile:

As long as I’ve got you attention… the animated wallpaper…I got a Plasmoid for that and it may even work if I can find an animated file or whatever it requires to display… but the question is whether or not I should be seeing any animated wallpapers in the “Get New Wallpapers” when Wallpaper type is set to animated?

Again thank you for your help… I’ve been stuck in the Red Hat world for so long it’s going to take me a bit to catch up with the modern stuff… first impressions are, KDE is really, really cool and Manjaro / Arch is pretty cool itself…

Thank You

No, I don’t think so. It’ll probably just take you to the list of wallpapers submitted to But I could be wrong, of course ─ I have no experience with animated wallpapers. :man_shrugging:

Note: If you want additional plasmoids, then it pays to just look around in the Manjaro repositories and the AUR. There’s a greater chance you’ll find something in there that works. :wink:

Thank You

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.