Cannot disable System Sounds

New installation of Manjaro on new hardware. Previous installations on other hardware disables ok. They were using VGA displays and cables with a phone jack plugged in; this one is using hdmi, if it makes a difference.

The new installation persistently beeps whenever something hits a limit - eg an attempt by thunar to go beyond the start or end of a list or by mousepad to go beyond a page boundary. I have found half a dozen places where I could turn it off, including the volume control and dconf, and have disabled sound there but nothing stops it. All the reports I’ve found searching here are to do with turning ON sound.

I still want the headphones to receive sound from audio and video players, just not the system beeps.

This might be the PC Speaker making those sounds.
You can try disabling the pcspkr module as mentioned in the Arch Wiki:

In a terminal window run:

sudo nano /etc/modprobe.d/nobeep.conf

Then type blacklist pcspkr, press Ctrl+o and Enter to save the file and Ctrl+x to exit.

When finished, reboot your system and see if the beep sounds are gone.

1 Like

Thanks, but I know it’s the hardware speaker making the noise. Previously it has been sufficient to tell apps not to make a noise. That way, I still get the helpful beeps when the (sometimes headless) computer is booting up. There should still be a way of inhibiting the noise from the apps.

Can you define previously? And in which apps?

I don’t think this is possible, unless an individual application has a setting for this. In this case you’re the one who has to find it out.

In general, you can disable the beep sound for “groups” of applications - like Gtk-based apps - or DEs (see the Arch Wiki link in my previous post).

That sounds odd. By previously I mean the computer that has just had a tantrum but which I’ve been using for a few years.

The PulseAudio volume control panel had two settings in the Playback section: system and the sound card. By reducing the system volume to zero, that muted the system sounds.

The panel I have on the new OS has, in Playback, a single setting labelled System Sounds. I have reduced the volume on that to zero but still get sounds. There is also a Mute button but all that does is reduce the volume to zero but no change.

There are two settings on the Output Devices section: one for headphones (working fine) and one for HDMI, again set to zero but with no effect. In fact, on turning it off in the Configuration section, the settings disappear from this panel.

On the Configuration section there are another two sections: HDMI and HD. I have set the HDMI one to Off (see above) but again no effect.

I have tracked down a couple of other places, which I can no longer remember, plus one in dconf which again made no difference.