Cannot delete or modify any files in my other partitions

I followed the post
which explained how to remove read only form partition and as per its post 2 I found the mount point and executed

sudo chown your user name:your user name /run/media/your username/drive mount name

and still I get error saying
chown: changing ownership of '/run/media/ankit/downloads/': Read-only file system
and nothing changes in my partition.
Is there anything i can do?

Have you tried modifying the partitions with a live USB?

From the live USB you can use gparted or other software.

The issue may be that, by modifying other partitions, the one you are using is also inadvertently being modified, thus the OS won’t let it happen.

I am sure you already know, but I feel the need to say that messing with partitions is a risky business.

yes I have tried and it doesnot allow modification that way too.

The forum wont let me post links yet, but have you tried changing the file permissions with chmod?

In case this was not in error …
Did you actually enter that as a command?
It is not one.

1 Like

Where is this?

And in particular: We need to know exactly what you did.

This is certainly not a working command.

When exactly are you getting this error? The chown command you showed earlier has not relationship to the ankit/downloads directory.

Show us what ls -l is saying about the directories.
Show us what mount is saying.

I figured it out but it all goes off after a restart.

first i remounted my partition by:
sudo mount -o rw,remount /run/media/ankit/F4549FF2549FB638/
and then I ran the chown command:
sudo chown -R ankit:ankit /run/media/ankit/F4549FF2549FB638/

then it worked for the time being but when i restarted my system and mounted the drive normally by clicking in other locations in dolphin then it did not mount as rw and again I have to run the above command. Is this some kind of dolphin specific thing or something else?

I think you need to modify your /etc/fstab file so that, upon boot, Majaro sets it up as read/write.

1 Like

The run tree is a volatile structure populated at runtime and as such any changes will be lost on reboot.

exFAT filesystems does implement permissions nor does NTFS on Linux.

You partition label/UUID indicates a foreign filesystem.

If the device is NTFS it can be due to an error in the filesystem or you are dual booting a Windows system with Windows fast boot and or hybrid sleep enabled.

Fix this by booting into Windows and use Windows to check the file system - also use power management to disable the mentioned features.

Please use this guide to create a permanent mount point for your device.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.