Cannot create build ISO from ISO profiles

I would like to create iso from iso-profiles. When try few desktop environments i see always suddenly error: “cp: cannot stat ‘/var/lib/manjaro-tools/buildiso/architect/x86_64/bootfs/usr/share/licenses/common/GPL2/license.txt’: No such file or directory” When I try deepin also appear this error. What missing in iso-profiles?

add the package licenses to the Packages-Desktop file

You can find an a recent architect ISO on my server.

https://iso.uex.dk/nix-architect/

3 Likes

The problem is that memtest doesn’t ship the license as file anymore.
You need to do as in this commit - [util-iso-boot] GPL2 licence got removed (55b596da) · Commits · Tools / development-tools / manjaro-tools · GitLab
Or wait for this fix to appear in the official package.
I think we will soon see the official iso image for manjaro-architect.

This solution worked for me. I ran into the same issue while trying to build Manjaro KDE Full ISO (following the buildiso guide on the wiki). Added ‘licenses’ to the ~/iso-profiles/manjaro/kde/Desktop-Packages file and was able to complete the build.

In architect missing environments xfce and clean mate. But architect works generally good.