Cannot Connect to Database Server

Issue: I have an assignment that has become past due trying to solve this on my own. I still want to complete the assignment because I want to know what I am doing before jumping into a job that might require just this (who knows). The assignment requires me to download a script and then run a script and upon opening, go to query and execute all. However, this is all faded so I am assuming it is because I am not connected to a server in which I cannot seem to connect to. Please help!!!

Your connection attempt failed for user ‘root’ to the MySQL server at …: NULL
The name org.freedesktop.secrets was not provided by any service files.


  1. Check that MySQL is running on address …
  2. Check that MySQL is reachable on port NULL
  3. Check the user root has rights to connect to … from your address
  4. Make sure you are both providing a password if needed and using the correct password to … connecting from the host address you’re connecting from.

Now, prior to this I installed MySQL Workbench using ADD/REMOVE Sofware
Then I tried to add a connection. I received the same message as above.

I then tried manually installing MySQL Workbench using:
sudo pacman -Syu
sudo pacman -S mysql-workbench
sudo pacman -Syu mysql-workbench

I did not receive any errors when doing this. I again tried to establish a connection.

How I tried to establish a connection:
In the workbench under Manage Sever Connections

  1. Named the server
  2. In Connection Method, I chose Local Socket/Pipe
  3. In Socket/Pipe Path: /var/run/mysqld/mysqld.sock

I do know how to look up my local ip add and used that prior in the Hostname but did not have a port and was not sure if I should use/change the username
However, I do have my internet security pass and used that to try to connect, nothing worked and received error messages as well.

You are asking an impossible question - it is an xyproblem - and it is likely an assignment given by a tutor or teacher - so you should do some more research and don’t ask for solution to your problem.

As a matter of principle, do not ask for homework answers, nor post answers to such requests. Homework assignments are designed to encourage a student to learn by their own personal research. Topics deemed to be about homework will be closed.

I think mysql-workbench only provides the Workbench client, not the database server. Install mariadb for the latter.

I have Manjaro KDE I did check and update the keyring database which came with a ton of errors as I read through the many many lines of code? Also, for the local database, I only tried that when the other option did not work, mind you, I have been having problems with other things not working such as DisplayLink. I had to reinstall the OS when coffee spilled on my wireless keyboard and caused issues with the computer running properly. There is a default port (same as yours 3306) in the connection application, and left that alone. Aside from these issues, the computer works just fine so I doubt the coffee spill had any major permanent effects.

I am not asking for anyone to do my homework. You mis-understand me. I have to install and run certain files in order to do my homework. The problem is, the files are not allowing me to do the job. This is why I was asking for TECHNICAL help to figure out why I cannot run my files. I assume it is because I am not connected to a server which is why I was asking for help for that, not the homework itself! I am not that type of person that would have others do their homework for them! Not everyone including instructors have experience working with Manjaro KDE. I feel this is strictly a Linux problem!

Ok, will try that out.

Added gnome-keyring, I now have a server set up with MySQL Workbench thank-you~


That’s OK.

If you are uncertain how to achieve the necessary setup for your homework - rest assured that is also a part of your homework :slight_smile:

1 Like

Ok, so that was only part of the solution. I did talk to my professor and he said that installing this tool is not part of my grade and therefor not a part of my homework. I have done extensive research and discovered the main problem with this working is the permissions. I have tried to manually change the root permissions but keep getting blocked by the same error code I get when trying to set up my server.

“Access denied for user ‘root’@‘localhost’ (using password: YES)”

and without password which I checked, I did input the password right but without password I get the same message only difference is the last word:

“Access denied for user ‘root’@‘localhost’ (using password: NO)”

I have looked up and tried different ways of changing the password permissions, but nothing is working. Can anyone help?

The guide i linked you above should already give you all the clues for setting a server.

Maycne.sonahoz, I actually already installed mariadb per your solution suggestion yesterday. I did check and it did install properly, but I am still having the issue of the permissions in creating the server. I will provide screen shots.

By default the only system root can log in as database root as long as no password is set. The default password is just enter.
This section shows how you can change that, if you really want to log in as root with a password form your normal user account. Otherwise create a user in your database.

If you stuck, stop the MariaDB service, remove the contend in /var/lib/mysql (not the folder) and start over. Make sure you read the complete ArchWiki article properly.

1 Like

Please do not post screenshots of text. Use copy+paste and propper formatting.


Sorry, none of these things worked. The problem does not just reside within the MySQL Workbench tool, it also causes the same problem in Terminal/Konsole. I did some more research and found out that Manjaro is not one of the versions of Linux that is supported by MySQL Workbench so that might be part of the issue right there. I am just going to install another version of Linux that is supported such as Ubuntu. I hate to have to change OS, but this is not the first item that has not worked properly with Manjaro.

MySQL Workbench works on Manjaro without a problem. You just did not correctly set up MariaDB. That is all.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.