Cannot connect gsconnect to android smartphone (kdeconnect)

Hello,

I have only been using Manjaro/ Linux for a short time. First the KDE version and now Manjaro with Gnome. With the KDE version I was able to connect the computer and my android smartphone with kdeconnect. I wanted to do this on Manjaro-Gnome with gsconnect. Unfortunately I can’t connect the PC and the smartphone (device is not displayed although they are in the same network). Which steps do I have to take to get gsconnect working if a simple activation in the extensions is not enough?

Thanks in advance for your help

Personally - if I need to connect my device I do it using a cable - but I don’t have advanced requirements such as message sync - it is the occassional installation or update of an APK.

Gnome shell extensions are prone to breakage with the rapid changes the Gnome developers make.

It is the standard answer as it is well known fact that Gnome developers only care for their own work and only have a shrug if a third-party extension stops working.

And the gsconnect extension is AUR and therefore not officially supported - so you would have to raise the issue with the developer.

Manjaro makes no changes to upstream Gnome so besides the theming and those extensions the Gnome maintainers work with actively - it is pretty much vanilla Gnome - if I remember correct there is an option to revert everything to vanilla Gnome with the press of a button.

But let’s ask @Chrysostomus and @Ste74 - they would probably know as their are the primary forces behind the Gnome edition.


Connecting your Android phone can be done using

  • USB cable ( gvfs-mtp package )
  • Android Messages ( AUR android-messages-desktop{-bin} PKGBUILD )
  • Android Filetransfer ( android-file-transfer package )
  • DroidCam ( AUR droidcam PKGBUILD )

We actually package and ship gsconnect by default, it comes pre-installed on gnome iso.

In my experience gsconnect works like this:

  1. Enable extension
  2. Install the android app kde connect
  3. Connect both devices to same wifi
  4. Open gsconnect settings and pair your devices
  5. In the android app settings, enable all the modules you want to use
  6. In gsconnect settings enable the integrations you want to use.
1 Like

I am about to check what the Manjaro Gnome has become :slight_smile:

EDIT: I feel enlightend

But if the phone doesn’t show up in the network, you might have to press some button in kde connect settings to make it advertise itself to otherwise. Reinstalling the Android app should also achieve this maybe.

If the phone is invisible to your PC (and the other way around) the first thing to check is the firewall. At least Manjaro Gnome has Gufw installed by default, you might want to manually open the recommended ports KDE Connect (and GSconnect) is using.

In terminal do:

sudo ufw allow 1714:1764/udp
sudo ufw allow 1714:1764/tcp
sudo ufw reload

Does your devices appear now?

3 Likes

Thank you very much for your answers.
In the end it seems to have been due to the firewall.
The tip from @Scytale brought the solution.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.