Cannot configure XP-Pen Artist 15.6 pen display tablet

Hi all,

I’ve been setting up Manjaro recently trying to switch away from Windows. I’m familiar with Linux from the past having done a few setups before, but this is my first time in 10 years making a serious attempt at switching away.

I’ve spent the past 2 weeks crawling through forum posts trying to find a solution to this issue with no luck.

My XP-Pen Artist 15.6 pen display tablet appears to be correctly recognized by Manjaro out of the box. Pressure and the display work as expected. lsusb shows it as a line item “Bus 001 Device 006: ID 28bd:000c XP-Pen ARTIST 15.6”.

I have two issues however:

  • The pen is tracking across both my main monitor and the pen display, so the input does not line up with the pen. I cannot find any way to change this.
  • I see no way to configure the hotkeys.

I have tried the following:

  • installing the official driver from XP-Pen.
    • The setup application installs and runs, but cannot detect my tablet no matter how many times I reinstall or restart my computer, or unplug the device.
  • installing the xp-pen-tablet driver from AUR
    • exact same issue as above
  • installing Wacom Tablet Tools in the KDE tablet settings menu
    • Does not detect my tablet even with the manual search option.
  • installing xinput_calibrator
    • Does not detect my tablet
  • installing PTXConf
    • does not appear to work on KDE, or may just be outdated.

So obviously I’m stuck. I’ve exhausted all possible avenues on my own, and any assistance is appreciated.



Please take a look at this topics

1 Like

From XP-Pen star03 drivers and configuration - #6 by bogdancovaciu with some slight variations:

This is the solution that has worked for me so far:

  • install digimend drivers through AUR:
    pamac build digimend-kernel-drivers-dkms-git

  • install wacom control module:
    pacman -Syu xf86-input-wacom

  • find serial USB info (in my case it was “28bd:000c”

  • configure /usr/share/X11/xorg.conf.d/50-digimend.conf  :heavy_check_mark:
    kate /usr/share/X11/xorg.conf.d/50-digimend.conf

  • Update this section to add the above serial USB info if it’s not already present. I have no idea if this will work for anyone else, but it worked for me.

Section "InputClass"
Identifier "Ugee/XP-Pen tablets with Wacom driver"
	MatchUSBID "28bd:007[1458]|28bd:0094|28bd:0042|5543:004[57]|5543:0081|5543:0004|5543:3031|28bd:000c"
	MatchDevicePath "/dev/input/event*"
	Driver "wacom"
  • restart computer
  • open “Wacom Tablet Settings”
  • it will say no tablet detected and ask you to load it manually.
  • go to the next screen, update any info as needed to match your tablet, then hit Save. Application doesn’t say anything when you hit save but supposedly it did something in the background…
  • restart computer again
  • open “Wacom Tablet Settings” again
  • this time it should now detect your tablet correctly and give you the options to set it up.

I then set it to be locked to my tablet screen with the “Map to Screen 2” option. Other tabs let me set up the express keys, but some of them were out of order, I assume because it’s not an actual wacom tablet.

Anyways, that’s it. Good luck.

I have read those particular ones many times and they did not help but thanks. The drivers from XP-Pen are broken presumably, and I could not find any older version.

You did what i suggested here

More or less, but if you would edit your solution and properly format the code from here one

would be even better …

You chose the proper way to do it by adding the MatchUSBID as i mentioned here, and you could have find by searching the forum …


I am no stranger to trying to help myself with existing information. I only posted here as a last resort after running out of options. I appreciate your expertise regardless.

I have updated the formatting as requested for anyone else with a similar issue.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.