Cannot choose which kernel I want to boot via Manjaro Settings Manager

Problem

The UI for managing kernels does not display any buttons for switching to the installed kernels. I can only install/remove kernels.

$ mhwd-kernel -li                                                                                                                                                                                                    

Currently running: 6.6.19-1-MANJARO (linux66)
The following kernels are installed in your system:
   * linux61
   * linux66
   * linux67

$ pacman -Q linux                                                                                                                                                                                                    

linux61 6.1.80-1

Is there any other UI way of triggering the kernel version change?

No, there is no such functionality as far as i am aware.
Hit ESC early in the boot to show grub and switch from there. I think the default is that it remembers what was booted. Otherwise you can change the options in /etc/default/grub and update with update-grub

1 Like

My memory must be making stuff up then.

For my previous upgrades I never had to do any terminal commands, so I’m guessing it was done as part of the updates.

But I assume then I need to go through these instructions then?

If so, my system doesn’t show the grub view upon startup, so I’m not sure I’ll be able to select any kernel.

As i said, if you cannot hit ESC fast enough, you can edit the grub file and regenerate. I personally use micro as default console editor, you can install it if you do not have it. Then
sudo micro /etc/default/grub and make sure you edit the lines to show

GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
.............
GRUB_TIMEOUT_STYLE=menu
..........
GRUB_SAVEDEFAULT=true

Save, exit, sudo update-grub and reboot.

Topic title edited to reflect what you actually want to do. :wink:

FYI, choosing 6.1 LTS, 6.6 LTS or 6.X stable is neither upgrading nor downgrading. They’re all different kernel series. See https://www.kernel.org/

p.s. and inexperienced users should really stick to the recommended LTS kernels, that is 6.1. or 6.6 in your case.

1 Like

By the way, I just remembered I added a useful program that can help with dual-booting and/or switching kernels called grub-reboot-picker to the AUR awhile back. It worked fine the last I tested it.

2 Likes

you need to boot grub > select advanced > select kernel to boot and nothing else
MSM only installs kernels

by default ,
grub boot on high version Kernel , or last choice ‘*’ boot confirmed

Thanks for all the responses all, I’ll give it a go.