Cannot change rendering backend /Screen recording problems

Hey there.
I’m back in the Forum with another problem I have and I don’t know where else to ask for help.

TL;DR: Basically I’m trying to change the Rendering Backend of my Manjaro KDE - Installation due to problems it may cause with my OBS replay buffer.
However: This option simply does not exist.

I can’t change it in my system settings under the compositor nor is the option even a thing it the the config file in .config/kwinrc.

The situation is that I’d like to use OBS as an Instant Replay tool. I know that Replay Sourcery exists. But this only clips the last 30 seconds. And I’d like to have a little more.
Besides, I can clip the sound from each channel (5.1 configuration) with OBS. And of course OBS can use NVENC.
( To be fair, I haven’t spend any time trying Replay Sourcery at all so all of this may not even be true.
But I think that I shouldn’t have to use a different programm just because the one I’d like to use doesn’t work because of… I don’t know, magic maybe?)

The underlying issue is that the video file that gets recorded has what I assume is the Vsync blanking intervall as a black line visible in the top of the screen. If it’s happy I just have tearing where the upper part of the video is behind by an average of about .5 seconds.
(I may add a link to a clip that I upload to YouTube later here if I didn’t delete them)
I’ve tried a lot to fix that. Even distro hopped with different DE’s I liked. But I’d like to stay with Manjaro KDE because it’s the only one with the very specific function I’d like to have, at least KDE Plasma has. But that’s off topic.

These are the worarounds that I’ve tried and that did more or less nothing:

  • disabled flipping. Didn’t do anything.
  • enabled the “force composition pipeline” as well as the “force full composition pipeline” setting. That somewhat fixed it in DOOM 2016, it’s still there just hard to notice. But for nothing else as far as my testing vent.
  • installed the older versions of the NVidia drivers. WIth the 390xx, games refuse to start and the 470xx works but has the exact same problem.

During this testing, it clicked that this must be an issue with Vsync.
I use it in games because I hate the tearing effect in games. Disabling that as well does help somewhat, it’s still noticable in the recording because now the game itself is tearing.

In the system settings I’ve played a little with the options I have for the Compositor. The only thing that also seemed to fix it was the box “allow applications to block Compositor”.
The issue with it is that part of the Desktop “blinks” through the game screen.

Basically it’s an issue that could be resolved with just either not using OBS, not having an NVIdia graphics card or just knowing what the issue is and what to do…

I didn’t want to make a new post about a topic that exists already numerous times about this issue with OBS so I just added all of the infos I could.

The latest change from me was the installation of the “video-nvidia” that was installed originally.

Here is my system info:

Operating System: Manjaro Linux
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Kernel Version: 5.15.32-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 3600 6-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2

Here’s a screenshot from the Compositor. (keep in mind that it’s in German):

Sidenote: I’ve changed the Vsync setting back to Automatic since the set option likely causes weird performance issues.

And here is the output of cat .config/kwinrc:

cat kwinrc                                                                                                                           ✔ 







Either there’s something I’m missing or I ended up breaking something again… Wouldn’t be the first time :sweat_smile:

Anyways: If you need anything, just ask. I’ll provide everything I can.

I didn’t know where else to put it, but the reason why I’d wanted to try this in the first place is because of some comment about how there might be a performance improvement when using XRender instead of OpenGL, howver I cannot find the page I’ve got it from

Right now it’s working-ish so I thought of posting it and maybe resolving it later, I’m not yet depended on Manjaro as my daily driver… Not yet anywas.

And as one last question: What about the open source drivers? Would they be any good for playing games and recording them at te same time? I doubt it and with my luck I brick the OS, that’s why I didn’t touch them yet.

provide output from:
inxi -Fazy
mhwd -l
mhwd -li
and the xrender was removed completely from plasma…

gets me

  Kernel: 5.15.32-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=ec912af4-1215-4a52-8320-2ef34db7f018 rw quiet apparmor=1
    security=apparmor resume=UUID=a8d3f2d3-9fd0-4eee-b363-31f630825035
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: B450 GAMING PLUS (MS-7B86) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 1.D0
    date: 11/08/2019
  Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 2652 high: 3580 min/max: 2200/4208 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3580 2: 3280
    3: 3329 4: 2200 5: 2200 6: 2200 7: 3246 8: 2268 9: 2930 10: 2200 11: 2200
    12: 2200 bogomips: 86440
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTeK driver: nvidia
    v: 510.60.02 alternate: nouveau,nvidia_drm pcie: gen: 3 speed: 8 GT/s
    lanes: 16 bus-ID: 26:00.0 chip-ID: 10de:1c03 class-ID: 0300
  Display: x11 server: X.Org v: with: Xwayland v: 22.1.1
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x272mm (19.02x10.71")
    s-diag: 554mm (21.82")
  Monitor-1: HDMI-1 res: 1920x1080 hz: 60 dpi: 102
    size: 476x268mm (18.74x10.55") diag: 546mm (21.51") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.60.02 direct render: Yes
  Device-1: NVIDIA GP106 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 26:00.1 chip-ID: 10de:10f1 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 28:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: C-Media Blue Snowball type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-9:4 chip-ID: 0d8c:0005
    class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.15.32-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.20 running: no
  Sound Server-4: PulseAudio v: 15.0 running: yes
  Sound Server-5: PipeWire v: 0.3.49 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 1-8:3 chip-ID: 0a12:0001 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 2.15 TiB used: 737.75 GiB (33.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000MX500SSD1
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 033 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3360320AS
    size: 335.35 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: N/A serial: <filter> rev: M scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Crucial model: CT1000MX500SSD1
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 043 scheme: GPT
  ID-1: / raw-size: 914.02 GiB size: 898.6 GiB (98.31%)
    used: 473.39 GiB (52.7%) fs: ext4 dev: /dev/sdc2 maj-min: 8:34
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sdc1 maj-min: 8:33
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 17.2 GiB used: 43.8 MiB (0.2%)
    priority: -2 dev: /dev/sdc3 maj-min: 8:35
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 53 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 30%
  Processes: 340 Uptime: 1h 9m wakeups: 0 Memory: 15.63 GiB
  used: 4.82 GiB (30.8%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: 1466 pacman: 1438 lib: 424 flatpak: 16
  snap: 12 Shell: Zsh v: 5.8.1 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.15

gets me

> 0000:26:00.0 (0300:10de:1c03) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.12.18               false            PCI
    video-nvidia-470xx            2021.12.18               false            PCI
    video-nvidia-390xx            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:22:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

gets me

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.12.18               false            PCI

Warning: No installed USB configs!

you could try before playing a game disable the compositor alt + shift + f12 and check… you can enable it again by pressing the key combination again

So, I’ve tried this just now.

TL;DR: disabling shows weird behaviour in games and the effects of turning it off seem to have varying effects on a per-game base.

Based on my observations it seems that it works sometimes and sometimes it makes no difference at all, albeit with worse performance and visible tearing on the Desktop when not turned back on.

First off, when I disabled the compositor with the mentioned shortcut, my game got an insane amount of input lag. I’d say it was about a second behind in menus as well as in the game itself. However, after activating and deactivating the compositor in-game again, it just went away and for this paticular game (The Long Dark) it worked. I compared it by turning it on and off, clipping and checking later.

When the compositor is enabled, ALL games seem to get this weird bug, where part of the desktop “shines through” the game itself. This is the state that this system is now in for some reason, because I don’t know what I did to get here.

It looks like this:

This effect is flickering, not static. And not repeatable, just randomly appears in the exact same place [*] every time.

In Splitgate for example, turning it off seems to do nothing. The recording has similar tearing effects like before.
Doom 2016 via Proton also seems better without the compositor.
Half Life 2 didn’t care for either. However I didn’t exactly play for very long…
Both TLD and Splitgate running in the native Linux version and I’m assuming Vulkan.

  • Couldn’t it be possible that it’s an issue with the GPU itself? On Windows I don’t have this problem. But I do the clipping there with ShadowPlay so I couldn’t rule out it being a problem with OBS.
  • Or maybe it’s because of my “special setup”. I’ve connected the GPU out to my AVR which outputs video to my display. Not a TV, just a monitor. And even WIndows and other Distributions hate this setup (that’s a whole story by itself).

I forgot to add as well that this problem with OBS was my initial reason why I abandoned Manjaro when I first tried it on my machine. Since then I wanted to get back in and I’m (mostly) determined to solve the issue. But I’m still unsure whether this issue is solvable at all, given how seemingly random my testing and results were. And inconsistent as well.

I could test more thoroughly next week but that’d be a bit to wait.
I’m sure it’s just some conifuration problem somewhere. Maybe because I use Vsync on all of my games and the compositor Vsyncs everything again? But then I’d see the tearing and artifacts too, not just the OBS recording… right?

Anyways, before I’m writing even more to comb through I’ll just not touch anything again.
I could provide you with the clips I’ve recorded, just so you could see for yourself and my nvidia-config if that’d be of any use…

[*]: I’ve had a secondary bar up top with the time and network activity.

you can try ‘tweaks’ from this link and see
if you still have issues, try creating a new user and check playing games with it

Wow, I don’t know how… But following this seemed to work.

I didn’t even get to do that yet, however I doubt it would’ve even helped, considering how I’ve had the exact problems on two different installs of Manjaro on the same machine (around Febuary and the first install of my current one which I reinstalled after wanting to switch back to Mint and it refused to boot).

My guess, which has been around for a while now, is that simply my GPU is either broken or just… hates me.

However I do NOT have enough understanding of how Linux works to just claim that it does nothing for me, so if l have problems in the future, this’ll be one of the first things I’ll try now.

Anyways, before it get’s even more boring:
Thank you for your time and dedication to my problem :smiling_face:

I hope this can help somebody else, otherwise I’d be the only person with theese weird problems… again :smiling_face_with_tear:

1 Like

glad the link worked

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.