Cannot boot to Windows after installing Manjaro

Hey there,
I know there have been a lot of threads about this, but yesterday I tried to get a successful Manjaro and Grub dual boot installation for many hours, and unfortunately I haven’t found anything that fixes my problem or matches my exact issue. So here goes:

Originally, I installed Manjaro via auto-partitioning and (accidentally) in legacy mode, which enabled me to get both to Windows and Manjaro, but not via grub. After trying lots of different things, I deleted the efi and Manjaro partitions and reinstalled, this time in UEFI mode and with manual partitioning. But now, for some reason, neither grub nor my BIOS detect the Windows boot option.

I’ve seen many times that you could add a grub entry yourself, but they always expect that there is a Windows directory in /boot/efi/EFI, which for me, there isn’t (only boot and Manjaro).

Here’s the output of a few commands that I figure might be relevant:

$ sudo parted -l
Model: ATA ST6000DM003-2CY1 (scsi)
Disk /dev/sda: 6001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
 2      16.8MB  6001GB  6001GB  ntfs         Basic data partition  msftdata

Model: KINGSTON SA2000M81000G (nvme)
Disk /dev/nvme0n1: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 2      106MB   123MB   16.8MB                  Microsoft reserved partition  msftres
 3      123MB   500GB   500GB   ntfs            Basic data partition          msftdata
 1      500GB   500GB   537MB   fat32                                         boot, esp
 5      500GB   505GB   4295MB  linux-swap(v1)                                swap, legacy_boot
 6      505GB   625GB   120GB   ext4                                          legacy_boot
 7      625GB   1000GB  375GB   ext4
 4      1000GB  1000GB  538MB   ntfs                                          hidden, diag
$ lsblk
sda           8:0    0   5.5T  0 disk 
└─sda2        8:2    0   5.5T  0 part 
nvme0n1     259:0    0 931.5G  0 disk 
├─nvme0n1p1 259:1    0 512.2M  0 part /boot/efi
├─nvme0n1p2 259:2    0    16M  0 part 
├─nvme0n1p3 259:3    0 465.4G  0 part 
├─nvme0n1p4 259:4    0   513M  0 part 
├─nvme0n1p5 259:5    0     4G  0 part [SWAP]
├─nvme0n1p6 259:6    0 111.8G  0 part /
└─nvme0n1p7 259:7    0 349.2G  0 part /home
$ efibootmgr
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,0002,0003,0004,0005,0006,0007,0000
Boot0000* Windows Boot Manager
Boot0001* manjaro
Boot0002* UEFI OS
Boot0003* UEFI: Intenso Alu Line
Boot0004* UEFI: Intenso Alu Line, Partition 2
Boot0005* ST6000DM003-2CY186
Boot0006* KINGSTON SA2000M81000G
Boot0007* Intenso Alu Line
Boot0008* Intenso Alu Line
Boot0009* KINGSTON SA2000M81000G
Boot000A* Intenso Alu Line

As you can see efibootmgr even knows Windows. But when I change the boot order to 0000,0001 (using efibootmgr -o 0000,0001) and restart, I get back to Manjaro and the boot order is reset.

$ sudo update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.10-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.10-x86_64.img
Found initrd fallback image: /boot/initramfs-5.10-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
It's output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

Thanks in advance.

see this

I’m assuming you’re referencing this:

If you need dual-boot you can reactivate os-prober the easiest with the following command combination in a terminal:

However this did not change anything for me.

why there is legacy_boot then ?

I don’t know. The flags were set by the Manjaro installer. The only thing I touched is the efi partition, where I set boot, esp instead of legacy_boot, msftres in an attempt to solve another problem.

I ended up wiping all partitions and reinstalling both Windows and Manjaro entirely. Now everything works as expected.

I was going to tell you that you’re in for a complete re-install because of this:

so I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

P.P.S. Please also read this:

as you have a tick in the first box already: Had to wipe everything and start from scratch…

:wink: :grin:

Thanks! I do feel pretty comfortable with Linux though, it’s just the first time I’m setting up a dual boot and the first time I’ve had to dive deeper into partitioning and the boot process :grinning:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.