Cannot boot (TLP System Shutdown) Owing to Nvidia Drivers

NVM: I think I just needed to update the rest of the system. Pacman -Syyu solved the problem.
Also, I eventually switched branches to the new 5.10LTS and tested the drivers with some Vulkan based games and was really impressed. Overall, perhaps this setback was what I needed to update my system anyway.

Linux 5.4.64-1 Manjaro
Manjaro Linux 20.1 (Mikah)
Video card: Nvidia 1650

Hello. I’ve been struggling to solve the problem of my disappearing video drivers. I updated a package and it removed my functioning video card drivers. Now if I try to boot, I get the message “Finished TLP Startup/Shutdown”.

I worked my way to the terminal to avoid the problem with the gui hanging the boot.

mhwd -l shows:
video-nvidia 2020.11.30 false PCI
video-linux 2018.5.04 true PCI
video-modestetting 2020.01.13 true PCI
video-vesa 2017.03.12 true PCI

mhwd -li shows:
video-modesetting 2020.01.13 true PCI
video-linux 2018.05.04 true PCI
Warning: No installed USB configs!

I tried rebuilding the mhwd database with sudo pacman -S mhwd-db but I still do not see any driver information. Nothing that says video-nvidia-450xx or the like.

I use Blender for art projects, so I am sure CUDA was installed at some point.

Anyway, I’m stuck at a blinking terminal and I’ve scoured the internet but found no solutions yet.

Thanks for your help.