Cannot boot on Yoga 7I ITL5

I recently purchases a Lenovo Yoga 7i ITL5 (intel version). Great and beautiful machine but i cannot boot on Manjaro but I searched some help and see that there is an Arch post about it :

i tried the solutions explained but I’m blocked after ‘mkinitcpio -p linux’ :

[root@manjaro-gnome /]# nano /etc/mkinitcpio.conf               
[root@manjaro-gnome /]# mkinitcpio -p linux
'$/usr/bin/mkinitcpio: line 268: /etc/mkinitcpio.d/linux.preset: No such file or directory'
==> ERROR: Failed to load preset: `/etc/mkinitcpio.d/linux.preset'`

Maybe i started the solution the wrong way or the problem is not there. don’t know.
I use a bootable Manjaro USB stick to work on a solution

:+1: Welcome to Manjaro! :+1:

Instead of mkinitcpio -p linux, try:

mkinitcpio --preset


Is this running inside a chroot environment or directly from the live USB?

Just do sudo mkinitcpio -P aka mkinitcpio --allpresets. It will run for all installed kernels.

Arch has linux and linux-lts while we have multiple kernels; i.e., linux513, linux510, etc.

1 Like

it’s running directly from live USB

The -P argument worked so i finished the tuto and reboot but any bootable options was shown
I precise that i didn’t do the 2 comands

mount -L SYSTEM_DRV /mnt/boot
swapon -L swap_p

because i don’t have windows partition.

Any new idea ? Do i need a chroot environment ?

Yes, you have to build the initramfs (running mkinitcpio -P) inside the chroot environment.

just to be sure, on the thread linked (from arch forum) the guy is just using one single partition because he wants to dual boot.
In my case i want only Manjaro on thee computer, so :

  • where do i put

with all the content on it ?
there is my partitions (very simple from installer) :
/dev/nvme0n1p1 fat32 300Mo boot, esp
/dev/nvme0n1p2 ext4 476G [NO–FLAG]

The computer is for my sister and she needs it tomorrow, she is used to linux and loves it but i don’t have time to install it properly, si i will (sadly reinstall windows) and retry in some months. Maybe Lenovo will give a new BIOS or someone will explain it on a simplier way for my little knowledge and competences.

Hope this thread helped :slight_smile: