Cannot boot Manjaro without using the GRUB on Live USB

Hey everyone. I am fairly new to Linux and Manjaro especially. I recently completed the installation of Manjaro XFCE on my laptop, switching from Fedora 32. The problem is that I cannot boot into Manjaro directly. Whenever I start my machine, I can never boot into Manjaro. Either I face “no bootable device”, or I enter a boot loop. I have tried fixing this in UEFI settings by adding manjaro’s efi file to the boot order, but to no avail.

I have found a “fix” for this, because whenever I plug in my Live USB, the same one I installed Manjaro from, it gives me the option to search for EFI bootloaders. There, I can access my Manjaro efi file and boot from there, and I am able to boot into my installation perfectly fine. But as you may think, this is very inconvenient. I am very new to this kind of stuff, so please bear with me!

I hope I can find a solution to this here. Thank you very much!

:+1: Welcome to Manjaro! :+1:

Please read this:

and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

  1. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
  2. The output to parted --list and efibootmgr --verbose would be helpful as well.
1 Like

Can you check the boot sequence in the UEFI Bios ?

I have the exact same problem. I have done clean install many times and regardless of formatting options (erase disk / manual partitioning, …), I cannot boot without USB live-image stick inserted in PC.

When doing sudo fdisk -l

the asterisk mark on “Boot” column ** is on external USB drive ** and not on nvme disk:

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 64 4700087 4700024 2,2G 0 Empty
/dev/sda2 4700088 4708279 8192 4M ef EFI (FAT-12/16/32)

Please follow this advice because now we know the symptom of the disease, but we need some more probing to know where the origin lies…

  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/vmlinuz-5.8-x86_64 
  root=UUID=9ba63ddd-4ac5-43cf-a248-1f55f3d88923 rw quiet udev.log_priority=3 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: HP product: HP ZBook Studio G5 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 8427 v: KBC Version 16.3E.01 serial: <filter> UEFI: HP 
  v: Q71 Ver. 01.09.02 date: 11/29/2019 
  ID-1: BAT0 charge: 90.6 Wh condition: 90.6/90.6 Wh (100%) volts: 13.1/11.6 
  model: Hewlett-Packard Primary type: Li-ion serial: <filter> status: Full 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  RAM: total: 62.67 GiB used: 1.40 GiB (2.2%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Topology: 6-Core model: Intel Xeon E-2176M bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) microcode: D6 
  L2 cache: 12.0 MiB bogomips: 64821 
  Speed: 900 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 900 2: 870 3: 900 
  4: 900 5: 900 6: 900 7: 900 8: 900 9: 889 10: 901 11: 900 12: 900 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep smx ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
  Device-1: NVIDIA GP107GLM [Quadro P1000 Mobile] vendor: Hewlett-Packard 
  driver: nvidia v: 450.66 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1cbb 
  Device-2: Chicony HP HD Camera type: USB driver: uvcvideo bus ID: 1-7:3 
  chip ID: 04f2:b5e7 serial: <filter> 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nvidia 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 143 s-size: 341x191mm (13.4x7.5") 
  s-diag: 391mm (15.4") 
  OpenGL: renderer: Quadro P1000/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus ID: 00:1f.3 chip ID: 8086:a348 
  Device-2: NVIDIA GP107GL High Definition Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fb9 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel 
  bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlp0s20f3 state: down mac: <filter> 
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
  bus ID: 4-1.4:3 chip ID: 0bda:8153 serial: <filter> 
  IF: ens4u1u4 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Local Storage: total: 961.33 GiB used: 6.30 GiB (0.7%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Gigabyte model: GP-GSM2NE3100TNTD 
  size: 953.87 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: EDFM00.2 scheme: GPT 
  ID-2: /dev/sda type: USB vendor: Patriot model: N/A size: 7.46 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: PMAP 
  scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No Optical or Floppy data was found. 
  Message: No RAID data was found. 
  ID-1: / raw size: 70.00 GiB size: 68.40 GiB (97.72%) used: 6.24 GiB (9.1%) 
  fs: ext4 dev: /dev/nvme0n1p4 label: N/A 
  uuid: 9ba63ddd-4ac5-43cf-a248-1f55f3d88923 
  ID-2: /boot raw size: 1024.0 MiB size: 975.9 MiB (95.30%) 
  used: 60.8 MiB (6.2%) fs: ext4 dev: /dev/nvme0n1p2 label: N/A 
  uuid: d43b11cd-18cd-4c75-83ad-dc0d0696f749 
  ID-3: /boot/efi raw size: 600.0 MiB size: 598.8 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 label: N/A uuid: 6420-8B14 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 31.14 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 label: N/A uuid: 38207d68-79b9-447f-ae67-01d396024d4d 
  ID-1: /dev/nvme0n1p5 size: 851.14 GiB fs: <superuser/root required> 
  label: N/A uuid: N/A 
  ID-2: /dev/sda1 size: 2.24 GiB fs: iso9660 label: MANJARO_KDEM_2011 
  uuid: 2020-10-01-14-44-41-00 
  ID-3: /dev/sda2 size: 4.0 MiB fs: vfat label: MISO_EFI uuid: A7FA-F7E6 
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Device-1: 1-4:2 info: Kingston Kingston DataTraveler / Patriot Xporter 
  type: Mass Storage driver: usb-storage interfaces: 1 rev: 2.0 
  speed: 480 Mb/s chip ID: 13fe:1f00 serial: <filter> 
  Device-2: 1-7:3 info: Chicony HP HD Camera type: Video driver: uvcvideo 
  interfaces: 4 rev: 2.0 speed: 480 Mb/s chip ID: 04f2:b5e7 serial: <filter> 
  Hub: 1-11:4 info: Cypress CY4603 ports: 4 rev: 2.1 speed: 480 Mb/s 
  chip ID: 04b4:6506 
  Device-1: 1-11.1:5 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID 
  driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  chip ID: 046d:c52b 
  Device-2: 1-11.3:6 info: HP type: Billboard driver: N/A interfaces: 2 
  rev: 2.0 speed: 12 Mb/s chip ID: 03f0:0c67 serial: <filter> 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  Hub: 4-1:2 info: Cypress ports: 4 rev: 3.1 speed: 5 Gb/s chip ID: 04b4:6504 
  Device-1: 4-1.4:3 info: Realtek RTL8153 Gigabit Ethernet Adapter 
  type: Network driver: r8152 interfaces: 1 rev: 3.0 speed: 5 Gb/s 
  chip ID: 0bda:8153 serial: <filter> 
  System Temperatures: cpu: 49.0 C mobo: 47.0 C gpu: nvidia temp: 47 C 
  Fan Speeds (RPM): N/A 
  Processes: 268 Uptime: 8m Init: systemd v: 246 Compilers: gcc: N/A Packages: 
  pacman: 1004 lib: 278 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05 

Here is
inxi --admin --verbosity=7 --filter --no-host --width

parted --list

efibootmgr --verbose

/etc/fstab :

and fdisk -l

and blkid

When I perform
sudo update-grub

I get:

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.8-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.8-x86_64.img
Found initrd fallback image: /boot/initramfs-5.8-x86_64-fallback.img
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

So this is good:

  • From efibootmgr:

     Boot0001* Manjaro	HD(1,GPT,2d6b6fc7-0e35-4609-b08e-ecb1865b92a6,0x800,0x12c000)/File(\EFI\Manjaro\grubx64.efi)....ISPH
  • From blkid:

     /dev/nvme0n1p1: UUID="6420-8B14" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="2d6b6fc7-0e35-4609-b08e-ecb1865b92a6"

But this is not good:

 ID-3: /boot/efi raw size: 600.0 MiB size: 598.8 MiB (99.80%) 
 used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 label: N/A  

It only contains 312 KB!

2 options:

  • re-install and ensure that during installation /boot/efi is mounted on this:
    • uuid: 6420-8B14
    • Partition: /dev/nvme0n1p1
      (whichever is easier for you)
  • copy the /boot/efi/EFI/Manjaro from another working installation. (You might get lucky that the installation USB contains these files too. Don’t have one handy right now)


1 Like

In the meantime I have found out that I can boot without Live USB to runlevel 3.
I can log in and do what I want.

When I start xinit, it fails.

When I reboot in runlevel3 WITH Live USB, then xinit succeeds.

Here are some stderr log files:
2 successul attempts with Live USB
2 failed attempts without Live usb
2 failed attempts with random usb stick

file io

My ESP has “EFI” folder and
“boot” and “Manjaro” subfolders,
where bootx64.efi and grubx64.efi reside, respectively.

bootx64.efi is present on LiveUSB, but grubx64.efi is not.

But, since I am able to boot to Runlevel3 without Live USB, is the bootprocess really the problem?

Why is KDE (xinit) unable to start sucessfuly if I boot without Live USB? If I plug Live USB in later, after successful Runlevel 3 boot, xinit still fails.

Xinit Fails = means I get only blank screen. I am only able to use command line after switching with ctrl+alt+Fx (x <> 2)

Without hands-on access to your computer that is hard to say, so you’re left with this option:

It is getting now even more interesting.

My system now boots without Live USB even with successful xinit IF I connect external monitors.
Every external monitor is working except the laptop screen.

If I want the laptop screen to work, I have to attack Live USB to my laptop.

What do?

I solved the problem.

I had to reinstall the system without using the “non-free” drivers.

It seems that the video drivers were the reason for malfunctioning xinit.