Cannot boot Manjaro installation on Asus Laptop

Hello everyone.

I installed the latest release of Manjaro alongside Win 10 on my Asus laptop. I finished the installer and set it to restart. It restarted into Windows and now I have no way of booting into Manjaro.

The installation was successful and there were no error messages displayed. The Windows partition on my SSD is now around 100 GB smaller then before. This does correspond to the value I specified at installation.

But I do not get a boot menu at startup. Nor can I find an option to boot Manjaro via the advanced startup menu or EFI. There is no way to normally interrupt startup on this machine. I already had to do some tweaking in EFI to make sure the live image flash drive would be recognized and could be booted from. Now, that doesn’t work anymore either.

How can I boot into my Manjaro partition? Or, failing that, how do I remove the partition and merge it back into my Win 10 partition? All the answers I could find elsewhere assume I can access Manjaro or at least enter grub. And I cannot do either of those.

If anyone could offer me a solution to these problems, I would be very grateful.

Please see this.


Oh No - It boots directly to Windows - What do I do?

Just boot to Windows.

1 Like

Thank you. I tried the CMD entry and it did not do anything. I will look through the guide linked below and see if I’ll find a solution there.
Edit: The solution offered in the guide is not applicable for me because my laptop will not boot from the USB drive anymore. At this point I am inclined to give up and remove the Manjaro installation and the associated partition. I would be very happy if anyone could tell me how to accomplish that.

Make sure you have not installed Manjaro in BIOS mode - which is easy to do when the systems firmware is set to boot Legacy first or put another way - in dual-boot scenario you must install the operating system the same way as the existing.

BIOS/MBR or EFI/GPT never both

Thank you. How would I go about checking in which mode I installed it? And how would I reverse it if it was the wrong one?

Only reinstalling manjaro

I’m sorry, I’m not quite sure what you mean. Could you specify?

if you are in windows, can you see the partitions you made during install in the w10 disk management?
They will not properly display as windows does not play well with ext4 but u should be able to judge by looking at the sizes.

If i remember, to access disk management on w10 you Right click the start button and it should be an option there

I.E. There is no way to reverse a BIOS to an UEFI install: they use radically different technologies. The only way you can do that is to re-install Manjaro is what @visone was trying to tell you.

Once re-installed, please provide the output to efibootmgr --verbose (booted from USB or from disk) so we can have a look what went wrong: I have an Acer and I had to drop to an EFI shell and manipulate boot entries there as Acer didn’t accept any tampering to NVRAM from an unsigned application even when secure boot is turned off.


Yes, the Windows computer management lists the following partitions:

C: 370,64 GB NTFS, Starting Partition
Disk 0 Partition 1: 450 MB, Recovery Partition
Disk 0, Partition 2: 100 MB, EFI system partition
Disk 0, Partition 5: 801 MB, Recovery Partition
Disk 0, Partition 6: 93,79 GB, EFI system partition (this is the one where Manjaro is installed)

I have no idea whether this laptop uses EFI or BIOS. It is referred to as EFI/UEFI everywhere in the system, but it looks like a plain old BIOS to me.

I was under the impression that the Manjaro installer automatically detects whether the system is based on BIOS or EFI and installs accordingly. Maybe something went wrong here? At the very least, I do not recall a dialog where I could choose between the two.

Since the laptop refuses to boot from my flash drive, I will have to get a blank CD, burn the installer image onto that and try from there. So it may take me at least another day or two until I can report results.

Thanks to everyone for their support so far.

Usually, the decision legacy (BIOS) or UEFI boot is done at the firmware menu when you select a device to boot the iso from it. As long as you have not set-up the firmware in a way it only dletects or allows one mode (e.g. only legacy) you are offered two devices as Manjaro isos are made as hybrid iso having both options available, one for legacy boot and one for UEFI, the difference is just in the naming when you select it. In the UEFI version usually UEFI is given in the device name.

you boot under USB iso manjaro
open a terminal and check before

inxi -MCxxxa
test -d /sys/firmware/efi && echo efi || echo bios
sudo parted -l 
sudo efibootmgr -v

you have before 2 /boot/efi required boot&esp , only one is boot by disk
avoid creating more boot/efi

Great news, everybody. I fixed it and I think I figured out what the problem was.

I followed this official guide from in order to access the bootable USB drive. The guide includes launching the Compatibility Support Module. If the CSM is enabled, the Manjaro installer will falsely detect a BIOS-based system and install accordingly. And that’s what caused my problem.

If you want to install Manjaro on an Asus laptop that doesn’t normally allow booting from USB drive or disk, you should do the following:

A: Entering UEFI system settings

  1. On Windows 10, open Settings and go to the menu for Recovery.
  2. Go to the headline “Advanced Startup” and click the button “Restart Now”.
  3. The computer will now reboot into Advanced Startup. Select “Troubleshoot” -> “Advanced options” -> “UEFI Firmware settings”.

B: UEFI options

  1. Once you’re in UEFI, go to the header “Security” -> “Secure Boot Control” and disable “Secure Boot Control”.
  2. Go to the header “Boot” and disable “Fast Boot”.
  3. Make sure the option “Launch CSM” is DISabled. Do NOT enable “Launch CSM”
  4. Save changes and exit by pressing F10.

C: Manjaro installation DVD

  1. Prepare an installation-ready DVD with the Manjaro .iso file (guides how to do that can be found with a web search) and insert it into your Asus laptop.
  2. Repeat steps A1 and A2 to enter Advanced Startup.
  3. Select your optical disk drive in either this menu or BIOS -> Save and Exit -> Boot Override.
  4. Boot the Manjaro live version in the DVD menu.
  5. Enter the installer, advance to the Partitioning step and make sure it displays UEFI (not BIOS) in the upper left corner.
  6. Continue the installation according to your preferences.

As stated above, I was unable to boot from USB drive after the initial failed installation. However, your mileage may vary and you might be able to boot from USB drive instead of going through the process of burning a DVD.

I hope this is helpful for anybody who might run into the same problem on similar hardware. Again, a big thank you to everybody who replied to this thread. Couldn’t have solved this without all of you.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.