Cannot boot manjaro - hangs even in single user mode

Hi,

a newbie here. I messed up booting my laptop (Manajro Gnome that was installed 6 weeks ago or so, did not yet run system update).
It shows me this and hangs (just repeating the error message):
[FAILED]: Failed to start Authorization Manager (repeats every 30s or so)

If I boot in single user root mode (add single parameter in linux boot line) it shows me this and hangs:
You are in rescue mode. After logging in, type “journalctl -xb” …

Cannot open acces to console, the root account is locked.
See sulogin(8) man page for more details.

Press Enter to continue.

Reloading system manager configuration
Starting default target
Then it hangs

How I got into this:

  • i tried to install epson L120 drivers using this link ( :frowning: cannot add links), with these steps:
  1. cd /tmp
  2. git clone epson l120 link
  3. cd epson-inkjet-printer-201310w
  4. makepkg
  5. sudo pacman -U pkg.tar.xz
  • step 4 makepkg failed with two errors messages. From another post I figured that I could solve it with installing base-devel
  • during installing base-level I saw two error lines that my GLIB.c was out of date (I think 2.31 or so). This is possible because I did not update manjaro in the last weeks. I think that messed it up. After that I tried to run the graphical manjaro update manager, but it would not start. I restarted and ended up in the situation I am in now.

So I think It can be fixed by updating the GLIBC (by doing a system update with ‘sudo pacman -Syu’?)

  1. is that correct?
  2. if so, how do I do that if I cannot boot into my system ?

Please give explicit instructions, as you can see I am a newbie.

I don’t know how you can get to a working system again but what I can tell you is that the driver for the Epson printer that you need is available in the AUR. You can install it with the following command pamac build epson-inkjet-printer-201310w

1 Like

i recommend reinstalling your system and do a fresh install it sounds like you broke your system somewhere down nthe line

you said you’re a beginner i suggest if you’re using the "Rolling release version to instead use the LTS version and see how that goes :slight_smile:

1 Like

Thanks for the advice!

I am definitely a beginner in the sense that I do not know Manjaro very well (I used Linux Mint for a number of years now) and now since a few months Manjaro. I use it daily for my work (other laptop) but more on the application level. Since I do not have the time anymore, by basic philosophy is just get the distro to work and use it. Maybe a fresh install is the quickest way to fix it. Still odd though that installing something simple like base-devel (I assume) just crashes it.

you said you’re a beginner i suggest if you’re using the "Rolling release version to instead use the LTS version and see how that goes

I thought Manjaro is by definition a rolling release? Or do you mean to move back to Mint… :slight_smile: I like manjaro too much for that (despite this experience)

Thanks!
I tried I think that one first, but saw that the AUR package download required a GB or so, which I thought was a bit much for a printer driver. But I think I wlll take this road after re-installing…

no i mean that manjaro has an LTS version and a ROLLING release version. for newer users its recommended to use the LTS release kernel and not the Rolling one. i hope you were able to re install your system and get it running again though :slight_smile:

please remember there is huge and key differences between the LTS kernels and the Rolling release version

the way linux mint updates is !00 percent different over how Manjaro updates and they work totally different

it probably crashed due to how Rolling release development works… things are updated very frequently and you have to do things just a bit differently then LTS Kernels…

if you want your system to work without small bugs or issues then use LTS and not rolling because it sounds like rolling releases are not for you.

please see this link to see the differences between the two Linux Jargon Buster: What is a Rolling Release Distribution? - It's FOSS

''Since I do not have the time anymore, by basic philosophy is just get the distro to work and use it

^^^^ again see the difference between the two and you’ll see rolling is not for you. LTS sounds like your thing and you shouldn’t base the OS not working properly based off your lack of research on the OS :slight_smile: and not knowing nor understanding the differences :slight_smile:

i hope you got things working again though

and also you should remember that linux mint is based off of debian while Manjaro is based off 0f arch so you should already know theres huge differences between the 2 and how you need to doo things compared to how its done on debian

i dont know why you have to blame the OS when you cant look at your kernels and see the differences between the two and how it says it right on their wiki

Just do a fresh install :slight_smile: