Cannot boot Manjaro from Ventoy in UEFI mode, but Ubuntu can

My dual boot Manjaro / Windows 11 on Dell XPS 15 stopped working a while ago (~about 1 year I think). Now I’m trying to solve it by reinstalling grub from a live USB (GRUB/Restore the GRUB Bootloader - Manjaro).

Somehow I can’t manage to boot the live USB in UEFI mode, so I can’t do anything with efivars, so reinstalling grub fails.

I am using Ventoy with the following images:

  • manjaro-gnome-22.0.5-230316-linux61.iso
  • ubuntu-22.04.2-desktop-amd64.iso

Now Ubuntu boots in UEFI mode just fine (efivars -l prints stuff), but Manjaro doesn’t and I get (after successful modprobe efivarfs)

efivar: error listing variables: Function not implemented

Now, when booting the live USB I get

mount: /sys/firmware/efi/efivars: wrong fs type, bad option, bad superblock on efivarfs, missing codepage or helper program, or other error.

so probably that is related. Does anyone know how to solve/diagnose this issue?

Side note: I can still boot my manjaro installation on internal disk by selecting “Detect EFI bootloaders” from the live USB, and then selecting the right entry, but it also boots with the same mount error, and without efivars working.

1 Like

Then the Manjaro iso on Ventoy is defective.
Verify the checksum of that iso image.

If this doesn´t help, then the next:
Reinstall Ventoy on the stick and copy Manjaro on it.
Then try angain.

Just for reference. It worked fine for me, installed KDE/Plasma with no problem.

1 Like

Thanks for your reply,
I verified the checksum, it’s the same.
To be sure, I took a different USB stick, downloaded and installed Ventoy, copied the iso, verified checksum again, booted it → same problem

Exactly this. I just installed Manjaro for the first time in a long time with the latest ISO from Ventoy without issue. Make sure you are setting Ventoy for GPT under Options / Partition Style.

I did (with GPT), and I also tried with a nightly build (ttps:// → same issue

To follow up, I tested the USB with manjaro iso on my desktop PC, works flawlessly (efivar -l works).
Also, an old iso (from before I bought the laptop, manjaro-gnome-19.0.2-200312-linux54.iso) is not working, so my guess is that Dell has changed something with a BIOS/firmware update that affected Manjaro but not Ubuntu…

I much prefer Manjaro over Ubuntu, so I still would like to troubleshoot this and repair my Manjaro installation. Anyone any suggestions on why efivarfs won’t mount?

1 Like

Check fast boot and secure boot in UEFI settings, they should all be disabled.

Ubuntu works fine with secure boot, but not Manjaro.

Also check this:

1 Like

They were already setup correctly (I managed to install and run Manjaro 2 years ago, but somehow it stopped working). For completeness:

  • Disable CSM (Legacy) boot → XPS 15 9500 does not even support legacy boot

  • Disable Secure Boot → Disabled

  • Enable AHCI → done, (this disables RAID/RST automatically)

  • Use latest available firmware → check

  • Disable Optane Memory and Rapid Storage Technology (RST) → no Optane, for RST see AHCI entry

  • Disable RAID option → see AHCI entry

  • Disable Fast Boot (if unable to boot from USB) → set to Thorough (only options are Minimal (=fast)/Thorough/Auto)

Then you can try to restore Manjaro grub from Ubuntu:

1 Like

Thanks, that worked partially!
The good news is that my dual boot is working again: I have grub, and both Windows and Manjaro boot.
The bad news, still no efivars with the same mount error

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.