Cannot boot: LUKS partition, failed to open keyfile

Hello everyone,

Today my machine just completely froze while I was installing DigiKam from the AUR. It was in the process of compiling, and the mouse no longer worked. I tried change to a TTY with no success. I even tried to safely restart with REISUB, and that failed too. I was forced to do a hard reset.

When the machine booted, this is the error that I got:

mount: /openswap_keymount: can’t read superblock on /dev/mapper/luks-…
Failed to open key file.
umount: can’t unmount openswap_keymount: Invalid argument
ERROR: resume: hibernation device ‘/dev/mapper/luks-…’ not found
mount: /new_root: can’t read superblock on /dev/mapper/luks-…
You are now being dropped into an emergency shell.

I booted to a live image and did the following:
sudo cryptsetup open /dev/sda2 encryptedhome
sudo fsck -f /dev/mapper/encryptedhome

fsck reported some errors, apparently repaired them. I rebooted and received the same result.

Here is some info that I collected to try and troubleshoot:

inxi -dMopS
System:    Host: manjaro Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.20.4 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: M5A97 v: Rev 1.xx serial: <superuser required> UEFI: American Megatrends v: 1605 
           date: 10/25/2012 
Drives:    Local Storage: total: 28.88 GiB used: 190.3 MiB (0.6%) 
           ID-1: /dev/sdb type: USB vendor: Kingston model: DataTraveler 3.0 size: 28.88 GiB 
           Optical-1: /dev/sr0 vendor: ATAPI model: iHAS124 C dev-links: cdrom 
           Features: speed: 48 multisession: yes audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram 
Partition: ID-1: / size: 5.79 GiB used: 190.3 MiB (3.2%) fs: overlay source: ERR-102 
           ID-2: /mnt/NAS_pgaiger size: 5.41 TiB used: 1.37 TiB (25.3%) fs: nfs remote: 
Unmounted: ID-1: /dev/sdb1 size: 3 GiB fs: iso9660 label: MANJARO_KDE_2021 uuid: 2021-01-03-09-07-36-00 
           ID-2: /dev/sdb2 size: 4 MiB fs: vfat label: MISO_EFI uuid: 7B2D-7571 


lsblk --fs 
├─sda1 vfat        FAT32                             BAB5-D2BA                                           
├─sda2 crypto_LUKS 1                                 e6c1a0ca-7782-4258-ac17-b511a26e93b8                
└─sda3 crypto_LUKS 1                                 2733080f-1055-4063-93b3-8005c435a509


sudo parted -l /dev/sda2
Model: ATA ST2000DX002-2DV1 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 1      2097kB  317MB   315MB   fat32              boot, esp
 2      317MB   1991GB  1991GB
 3      1991GB  2000GB  9449MB


sudo fdisk -l /dev/sda
Disk /dev/sda: 1.82 TiB, 2000398934016 bytes, 3907029168 sectors
Disk model: ST2000DX002-2DV1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: C4BEBA3D-28E1-2544-B2C3-782F3B9F365A

Device          Start        End    Sectors  Size Type
/dev/sda1        4096     618495     614400  300M EFI System
/dev/sda2      618496 3888569125 3887950630  1.8T Linux filesystem
/dev/sda3  3888569126 3907024064   18454939  8.8G Linux filesystem

Partition 3 does not start on physical sector boundary.

In the short term, I would like to copy the sda2 to a file as a backup. I tried using sudo dd if=/dev/sda2 of=/path/sda2.img. The result was a very small image file which could not possibly represent the whole drive.

I would appreciate any ideas or help anyone might have to get me back on track. Thanks.