Cannot boot into Manjaro after timeshift restore

I have a problem booting in manjaro after a Timeshift restore.
I removed important system files by accident and tried to fix it with a Timeshift backup.
Now my manjaro dosent show up in the grub booting screen.
Any ideas what I can do to fix this?
Thanks in advance!

boot into manjaro live usb, and check if you can chroot:
manjaro-chroot -a
(this command doesnt work with btrfs and encryption)

1 Like

Is this normal?

yes you are chrooted…
first rerun update:
pacman-mirrors --fasttrack 5 && pacman -Syyu
are there any errors? did it update anything?

1 Like

worked fine I think

run this:
pacman -Syyuu
to fix the is newer than community

then post output from:
mhwd-kernel -li

im seeing there something related to nvidia340xx … do you have that installed?

I dont know :confused: but if I could boot I would know or is there a other way to know if it is installed or not?

i see so post output from:
mhwd -l -li
pacman -Qs nvidia

but thats not related to why manjaro is not detected with grub… was just curious, since these old drivers are no longer supported…

looks ok…
reinstall this kernel:
mhwd-kernel -i linux515 --force
if there were no errors, reboot, and see if its detected in grub

It saying I cant reinstall my current Kernel and I should use pacman -Syu instead to update

ok, so run:
pacman -S linux515
if there were no errors, reboot, and see if its detected in grub
and also try to boot into manjaro from bios boot option

1 Like

You are a god damm legend!
Thank you so much for youre help!

so it was detected in grub, and you booted normally?
also were the other kernels detected? the 5.10 and the 6.0?
if not, reinstall them also…

Yeah it was detected an I was able to boot normal again.
The other Kernels were not shown.
So I do the same for them.

yes reinstall the 2 other kernels, and hopefully this were all the issues you had

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.