Cannot boot into live usb


#1

Hi all, Hope you are fine.

Im trying to install manjaro in my laptop ( Asus N552VW ) and I cannot boot with the USB

Im thinking that is related to the Nvidia Optimus technology (gtx 960m and Intel onboard)

I tried using nomodeset nouveau.modeset=0 i965.modeset=0 acpi_osi=! acpi_backlight=native idle=nomwait and so. I always end in the same blank screen where it fallback into:

loading keymap…done.
Mounting ‘/dev/disk/by-label/MJRO170’ to 'run/miso/bootmnt’
Waiting 30 seconds for device ‘/dev/disk/by-label/MJRO170’ …
No caching mode page found
Assuming drive cache: write through
ERROR: ‘/dev/disk/by-label/MJRO170’ device did not show up after 30 seconds…
Falling back to interactive prompt
You can try to fix the problem manually, log out when you are finished
sh: you can’t access tty: job control turned off
[rootfs ]#


Having trouble installing from live usb [SOLVED]
#2

Did you check the ISO checksum? I had similar situation before and problem was iso file checksum was wrong.


#3

i tried the iso installing it in a virtual box, and worked perfectly


#4

anybody??

help pls :frowning:


#5

Whats installed on it at the moment? Linux or Windows? Have you tried installing other distros? Which Manjaro are you trying to install? Have you tried the different install options, non-free etc?


#6

Hi @ant
I already have installed Ubuntu and windows.
I had Linux mint for a while.
For both Ubuntu and Linux mint I needed to add nomodeset to the boot params in order to get into the installation process.

I’m trying to install Manjaro 17 XFCE and yes I tried free and non-free. Unfortunately I don’t feel comfortable enough to make the installation from the command line.


#7

any idea anyone?


#8

This sounds like a problem reading the USB stick. Try another stick and/or USB port (in particular, a USB2 port if available, rather than USB3).


#9

hello, knotted10

if you boot with a usb3, you have a lot of chance to fail. USB2.0 is better.
Moreover i don’t know what is your software to create the usb, but if you have windows, LILIUSB is really good.

:slight_smile:


#10

Thank you guys very much, I’ll try your suggestions and let everyone knows.


#11

Hi everybody, I’m having the same problem. Unlike knotted10, I’m using Manjaro 17.0 KDE Plasma. I am using a USB2 jump drive & USB2 ports. I used Rufus to create the bootable USB drive, which is a very good tool (It’s not great that Rufus is unavailable on GNU/Linux, though). I will try it on a different USB stick just in case that is the problem. Thanks.


#12

The same error output as well? This is definitely a problem accessing the USB drive, sounds rather like a hardware problem than a problem with the image writing.


#13

Yes, the same error output. Could it still be a hardware problem even though I tested it on two very different computers?


#14

I’ve had the same problem - LiveUSB creators put Manjaro into their own directory, but the boot loader expects it to be in ‘MJRO170’.

NOTE: Whenever you see "can't cd to [directory]", run this command:
cmod o+x [directory]

So, when you’re in prompt [rootfs ]# do the following:

  1. cd dev/disk/by-label
  2. run ls command and search for the directory created by your LiveUSB creator (like ‘MYLINUXLIVE’)
  3. mv [the directory] MJRO170
  4. ls once again and check if the correct directory is present
  5. run exit and enjoy!

#15

I made a bootable USB on a different USB stick, & it produced the same error. So, it’s not a corrupted USB stick. I tend to think qw8 is correct. Previous versions of Manjaro did not create this problem, so this is a loss in quality for Manjaro. I’ll hold off on using Manjaro until this problem is fixed. There are plenty of other distros out there that don’t have this problem.


#16

That’s the problem that came from Arch Linux, I guess. No need to miss out on Manjaro just because of this, especially when it’s a one-time one-line fix.


#17

Changing the disk label to MJRO170 will do the trick.


#18

Thanks, Linuc_Tor. Changing the disk label was a relatively easy way to fix this problem. Now I’m trying out the newest release of Manjaro KDE Plasma.


closed #19

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.