Cannot boot from live USB

After having some issues with my previous OS, EndeavourOS, I decided to replace it with Manjaro. So I removed Endeavour with OS-Uninstaller which formatted the two partitions where Endeavour was installed. Then I downloaded the Manjaro image file to make a USB boot.
Note: I have a dualboot with Windows.

First, I got this error message when trying to run the open-source installation:

mount: /run/miso/sfs/rootfs: wrong fs type, bad option, bad superlock on /dev/loop3, missing codepage or helper program, or other error.
dmesg(1) may have more information after failed system call.
ERROR: Failed to mount '/dev/loop3'.
Failing back to interactive prompt
You can try to fix the problem manually, log out when you are finished
sh: can't access tty; job control turned off

I deleted the iso file, downloaded the same one, checked its hash, reinstalled Ventoy on my USB stick, and now the installation process just freezes with the HP icon and Manjaro icon.
What should I do to solve this issue?


Moreover, I had a similar issue when booting EndeavourOS from USB. I really think the problem is related to my computer.

use ventoy to flash the iso;
secure boot disbled in bios;
fast boot disabled in bios - you may not have this option;
fast startup disabled in windows;
AHCI enabled in bios - if you are on RAID, dont switch, otherwise you will not be able to boot into windows;
if you are in uefi mode, boot ventoy in uefi, if you are in legacy/bios boot it in legacy

  • already use Ventoy;
  • secure boot already disabled;
  • don’t have fast boot setting in BIOS;
  • fast startup disabled;
  • could not find AHCI setting in BIOS;
  • Ventoy already boots in UEFI mode.

I still have the same issue.

Then the USB stick is defective or

reformat he USB stick and try again.

USB stick formatted, I reinstalled Ventoy but still get the same issue.

Try another USB stick or follow this guide.

I could not follow your instructions since I use Windows.
Also, I just tried out Rufus but it still leads me to the same problem.

can you try booting into a non arch live session, for example linux mint?

Sure, it works well with Zorin OS Lite.

do you have nvidia?

No, my GPU is directly integrated with my CPU.

download the linux515 iso from here:

and try with it…