Cannot boot after last update

No, I am not running a virtual machine. Just dual-boot with Windows.

I will try with the testing branch.

just run this command:

sudo pacman-mirrors --api --set-branch testing && sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

Now this is weird. Changing to the testing branch does not update any packages. And neither does changing back to stable either (when running pacman -Syyuu). Maybe I did something wrong?

check status:
pacman-mirrors --get-branch

returns testing (and I am quite certain I did not set this branch earlier)

post output from chroot:
pacman -Qs linux515
compare it to my version on testing:
local/linux515 5.15.76-1

edit: it looks like you have the same kernels on stable as i on testing, just checked

Ah okay, just saw your edit. If I did not do anything wrong, it seems like there is no package deviation for all of my packages between stable and testing - is this a possibility?

yes thats the case… we are now using the same packages even though you are on stable and im on testing…
checked on unstable branch and the same kernels there too - thats asuming its a kernel issue…
we can try downgrading kernel to the previous version, post output from chroot:
ls -hl /var/cache/pacman/pkg | grep linux5

Unfortunately, I do not have older versions of the packages, I cleaned up this folder not so long ago.

# ls -hl /var/cache/pacman/pkg | grep linux5
-rw-r--r-- 1 root root  76M Oct 29 11:48 linux510-5.10.151-1-x86_64.pkg.tar.zst
-rw-r--r-- 1 root root  310 Oct 29 11:48 linux510-5.10.151-1-x86_64.pkg.tar.zst.sig
-rw-r--r-- 1 root root 101M Oct 29 20:13 linux515-5.15.76-1-x86_64.pkg.tar.zst
-rw-r--r-- 1 root root  438 Oct 29 20:13 linux515-5.15.76-1-x86_64.pkg.tar.zst.sig
-rw-r--r-- 1 root root 177M Oct 24 22:15 linux519-5.19.17-1-x86_64.pkg.tar.zst
-rw-r--r-- 1 root root  438 Oct 24 22:15 linux519-5.19.17-1-x86_64.pkg.tar.zst.sig

Is it possible to manually install an older version of the a kernel?

found it here:
download the:
if you are using also headers download them too…

hopefully you are not using nvidia?

you can just do this:

pacman -U

and for headers if you are having them:

pacman -U

checking here:
the unstable has a newer kernel actually, so i would first try the unstable branch, than messing with downgrade…

Thank you for all your help. Still unsuccessful unfortunately.

I thought at the beginning that it might be associated with the UEFI boot, but I assume if I had done this wrong (i.e. forgot to mount the /mnt/boot/efi/ partition, grub would have thrown an error earlier.

and what did you tried? downgrading the kernel? or switching to unstable?

I tried both switching to unstable and downgrading the kernel, all yielding the same result as before and leading to an emergency shell.

i see…
porvide output from chroot:
cat /etc/mkinitcpio.conf

# cat /etc/mkinitcpio.conf 
# vim:set ft=sh
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)

# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries

# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.

# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS=(base udev autodetect modconf block filesystems keyboard fsck)

# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.

# Additional options for the compressor

# Decompress kernel modules during initramfs creation.
# Enable to speedup boot process, disable to save RAM
# during early userspace. Switch (yes/no).

looks different than mine, there are some hooks missing, were you doing changes to it?

not intentionally, maybe I ran mkinitcpio -P too often…

that mkinitcpio -P command just updates it, it doesnt change anything by itself…
so lets add the hooks that i have + the encrypt hook, we have nothing to lose:
nano /etc/mkinitcpio.conf
and edit the hooks section to look like this:

HOOKS=(base udev autodetect modconf block keyboard keymap consolefont encrypt filesystems fsck)

save it with: ctrl+x
run this:
mkinitcpio -P
exit chroot and reboot

yay :blush: fixing the hooks lets me boot again :slight_smile: thank you so so much for all your time and effort

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.