Cannot begin installation process, Calamares will not launch

Hello, first post here and first attempt at Linux. I searched around the forum for a solution but could not find it. I would like to dual boot Manjaro and Windows 10. I started following a guide for this. I disabled CSM, Secure Boot (selected Other OS), made sure I was using AHCI. I downloaded the latest Manjaro KDE and copied the iso to a USB drive using Rufus on Windows. I tried the regular version first then tried the minimal version after noticing a problem. Both ended up with the same result.

When I boot from that drive (for any of the two versions), Manjaro doesn’t fully load (I cannot see the taskbar for example). If I choose proprietary drivers before boot, nothing at all loads, not even a mouse. If I choose open-source, I can get a bit farther. I can launch the terminal using F12 for example. I do get the screen to launch the installation process but nothing happens when I click the button to do so. If I open Dolphin, I can see all my drives in the Devices section, including the partion I was planning to use to install Linux on. I can see that in the Removable Devices section there are two entries named MANJARO_KDEM_2111. The first instance contains 3 folders (boot, efi and manjaro). There’s also 2 files (boot.catalog and efi.img). If I try to click on the second instance with that name, I get this error message:

An error occurred while accessing ‘MANJARO_KDEM_2111’, the system responded: The requested operation has failed: Error mounting /dev/sde1 at /run/media/manjaro/MANJARO_KDEM_2111: /dev/sde1 already mounted or mount point busy

So that’s as far as I can go with my very limited knowledge of Linux. Where do I start to troubleshoot this? What could make the boot process fail like this? I’m running on recent hardware (Asus Tuf 570, Ryzen 5900x, GTX1070, multiple SATA / NVMe SSDs).

Welcome here, @tempo :wave:

Better use Etcher or Ventoy. Also check the checksums.

Make sure Fast startup is switched-off in Windoze.

I would recommend to follow this guide for dual boot:

Hi @Wollie, that’s the guide I was following. I disabled Fast startup too and completed all the steps required prior to install. All was well up to that part:

  • Reboot your computer to the live USB media.
  • Launch the graphical installer

I will give those apps a try to see if they help sort this out thanks.

I used Etcher to recreate the boot drive from the iso. I also used a different USB drive just in case the other one was corrupted. But I got identical results. Manjaro still doesn’t boot properly and I cannot launch the installer.

There must be logs somewhere or a way to have Manjaro boot in a more verbose way so that I can troubleshoot this problem. Any command line that could be of help that I can run to try and identify the source of this failure?