Cannot autostart kitty with latest KDE minimal

I used to be be able to autostart kitty (console) with KDE, by using this command in the Autostart setting:

kstart5 --maximize --desktop 1 --windowclass kitty kitty

I just installed KDE minimal from KDE 20.2-rc4 ISO using Architect on a laptop. Now kitty is not started any more when log in. But I can manually start kitty and works normally. So just the autostart feature is broken.

Any idea?

May just be starting too fast … try putting a ‘sleep 2 &’ or similar in front.

That worked. You are amazing! Thanks.


Although adding sleep can autostart kitty and Visual Studio Code (which was not able to autostart before), new problems occur.

I set up 3 programs for autostart:

sleep 0.1 & kstart5 --maximize --desktop 1 --windowclass kitty kitty
kstart5 --maximize --desktop 4 --windowclass gitahead gitahead
sleep 0.2 & kstart5 --maximize --desktop 5 --windowclass code code

If log in from boot or reboot, everything is fine.
If log out and log in again, after typing password, the screen is hanging on the progress bar at about 80% for even a few minutes! And all 3 programs appear on desktop 1, not on designated 4 and 5.

Add one more detail. When logout and login, kitty and gitahead are not in full screen mode.

oh. heh.
I accidentally suggested using 1 &.
You must use 2 … like && … otherwise they arent running one after the other, but simultaneously.

I changed to “sleep 0.2 &&”. But still the same problems when logout and login: hang on progress, stack on desktop 1, and not full screen (desktop).

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.