Cannot access wireless with new Pine64 Pro

Hi All, I just received my Pine64 laptop. Nice machine! Unfortunately, I have not been able to get internet access working. Network Management repeatedly attempts to configure the wireless connection, but reports, “Connection failed”, followed by “Wireless Interface (wlan0) IP configuration was unavailable”.

I double checked that I set the wifi password correctly in System Settings -> Connections -> WiFi Security. I am accessing the same wifi access point successfully from a Windows laptop, which tells me I have the wifi access point name and password correct.

My wireless router is set up to provide dynamic IP addresses. Does the Pine64 need a static IP address to connect to the net, or should dynamic IP addresses work OK?

Thanks for any advice.

Sorry, tried to include output of ‘inxi -F’ in my post, but I get an error: Sorry, can’t include links in a post. (I don’t see a link, but OK…)

Sorry again. Partial output of inxi -F says about network:

Network: Message: No ARM data found for this feature.
IF-ID-1: wlan0 state: down mac: 10:2c:6b:1b:a5:dc

state:down does not sound promising…

Make sure your WiFi is enabled.

https://wiki.pine64.org/index.php/Pinebook_Pro#Privacy_Switches

Thanks for your reply. I am still not connecting to the wireless hub. I used the Pine64 key + F11 to toggle wireless privacy off (as shown by num light blinking 3 times.) Rebooted: now the error reported by Net. Mgmt. is “Authorization supplicant timed out”. Used P64 + F11 to toggle wireless privacy back on (num light blinks 2 times.) Rebooted: error is back to “wlan0 IP configuration was unavailable”.

Any other ideas would be appreciated.

Try disabling 802.11r Fast Transition in your wireless router. This worked for me.