Cannot access synology drives by dolphin

On my computer I have installed Manjaro Linux with KDE Plasma. Unfortunately, I cannot access the Synology drives here. Under Windows, access to the drives works without any problems.

Also, under Linux I can mount the drives with sshfs without any problems:
e.g. with
sudo mount -t nfs

If I now want to access it with Dolphin, the whole thing looks like this:
Under “Network Devices → Shared Order (SMB)”, “nashome” is still listed correctly. “nashome” is the name of my Synology in the network.

But if I then navigate to “nashome”, the error “The file or folder smb://nashome.local/ does not exist” is displayed.

On my old Linux machine (with Xfce and not KDE as the interface) access via the file browser also worked without problems.

Here also smb://nashome.local/ is given as address. I have a feeling that username and password might be the problem here. Because that’s what I had to enter on my old computer when I first accessed it. As far as I can remember, I didn’t (couldn’t) do that on the new computer. But I don’t know where I could enter the username and password here.

This is a zeroconf address - and most likely why it is faliling.

The avahi zeroconf services are not default enabled so another option is to enable those

systemctl enable --now avahi-daemon

And perhaps the avahi-dnsconfd service

systemctl enable --now avahi-dnsconfd
1 Like

@linux-aarhus Thanks for you help. I enabled both services avahi-daemon and avahi-dnsconfd.
I also tried the steps below “Samba Client” from your url.

Unfortunately, this did not solve my problem.

Use the ip in your connection smb://ip/sharehame

1 Like

This didnt work either.

However, I found this thread here, where you were also contributing:

I entered some random username and pw to the network settings for windows shares. After that, I opened dolphin and navigated to the synology drive and I could finally enter the credentials. After that, the access to my synology drives via dolphin worked finally, but only for a short time!

However, after restarting dolphin again, the access doesnt work anymore (I am not asked for username and password anymore). It doesnt even work, if I again change the credentials in the network settings. It only worked for a short time…

I definitely think, the problem is the missing prompt for username and password. It never pops up in dolphin for me…

1 Like

When you connect and you are queried to store the credentials - those are stored on the system.

Depending on how your system is configured it may be gnome keyring, gvfs or kwallet.

Perhaps you have multiple credentials stored for the same resource and the system is just picking the wrong one?

I never really liked dolphin - so I use gvfs and pcmanfm-qt

1 Like

I have finally found a workaround, that works permanently for me. When entering my username before the nashome.local in the location window, I can access that share via dolphin:



You know that nfs and smb are two different protocols?

gvfs has always - in my experience - worked better than kio

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.