Cannot access some websites after system update

I just updated my system for the first time in a few months, and now I cannot connect to some websites over my normal wifi network. I believe that it’s only IP4 addresses that I can’t connect to—for example, I can connect to google . com but not duckduckgo . com or github . com.

I think it has to do with my default gateway, but I am new to networking issues.

$nmcli device show wlp2s0
GENERAL.DEVICE:                         wlp2s0
GENERAL.TYPE:                           wifi
GENERAL.HWADDR:                         54:13:79:94:0D:21
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.CONNECTION:                     95
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/8
IP4.GATEWAY:                            --
IP6.ADDRESS[1]:                         2604:3d08:9576:a9f0::56f/128
IP6.ADDRESS[2]:                         fe80::b13d:c188:4718:37ca/64
IP6.GATEWAY:                            fe80::fc77:7bff:fec7:6641
IP6.ROUTE[1]:                           dst = fe80::/64, nh = ::, mt = 1024
IP6.ROUTE[2]:                           dst = 2604:3d08:9576:a9f0::56f/128, nh = ::, mt = 600
IP6.ROUTE[3]:                           dst = ::/0, nh = fe80::fc77:7bff:fec7:6641, mt = 600
IP6.DNS[1]:                             2604:3d08:9576:a9f0:fc77:7bff:fec7:6641
IP6.DNS[2]:                             2001:4e8:0:4009::15
IP6.DNS[3]:                             2001:4e8:0:4007::1a
IP6.SEARCHES[1]:                        ht.home

I have no IP4.GATEWAY, and ip route has no output.
I can connect to my phone’s hotspot and access all websites fine, and I can use the wifi network without issue on a mac device.

I would appreciate any guidance!

My knowledge is limited too, but have you made sure that IP4 is enabled for this device?
(System Settings->Connections-> device name - “IP4” tab - Method: Automatic)

Check your /etc/hosts file for anything that shouldn’t be there.

cat /etc/hosts

Security note: Do not post output from this command.

For some reason your system is configure to use IPv6.

This is likely caused by disabling IPv4 in Network Manager.

4 Likes

According to the displayed log all the connections are made only via IPV6 .
No IPV4 addresses active .
So if the site has IPV6 addresses it will reply correctly.

Check the networkmanager if IPV4 is formally disabled …
If it is Active and IPV4 interface ( wlp2s0) is expecting an address from a DHCP server then check the WIFI network source.

Perhaps the DHCP server is unable to provide an new IPV4 address …

Thanks everyone! Not sure how my IP4 settings were changed (or why it only affected one network) but toggling the settings fixed it.

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.