Can’t start session after battery drain off

Hi everybody!
I have Manjaro59 installed. After my battery drain off I can’t open any session.

I can access the grub menu and either I tried different kennels(linux45.x).
I’ve also tried to boot in run level 3 but I still get the same message below.

Thanks in advance for any help…

Hello @onzo :wink:

It seems the file system is damaged and therefore it can’t read the superblock. So the normal repair at boot did not work.

You will need boot a manjaro boot disk and repair it:

list all backup superblocks:

sudo dumpe2fs /dev/sda5 | grep -i superblock

and then

sudo fsck -b <superblock> /dev/sda5

like this:

sudo fsck -b 32768 -y /dev/sda5

You will need to test every superblock until it works.

If it worked, it is also useful to detect badblocks and tell ext4 to skip them:

sudo fsck -vcck /dev/sda5

Good luck :wink:


Hello thank so much for your quick reply.

I’m getting a command not found for all the commands

Did you boot the manjaro install disk?

Let me repeat:

That is necessary, because /dev/sda5 seems to be a system partition.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.