Can‘t boot anything anymore

Okay guys, while I entered my bios something weird happened. Suddenly my windows bootloader was showing up again in my bootorder and also my SSD (that might actually be a HDD lmao) showed up again and when I exited it automatically booted windows. So it might (at least temporarily) work again. What are my best options to use the chance of it working to fix things again?
(Also didn't find anything resembling a test to check for failures in my BIOS)

Edit: I am a bit afraid of rebooting my pc to try to get into Linux since it might just die again so I'd like to somehow make sure my windows works properly again

rip off the band-aid, you have to reboot sometime. if you dont windows will whether you want it to or not :laughing:

then go back into bios again, make sure secure boot and fast boot are disabled, then see if you able to change the boot order to manjaro as first and windows second and dont forget to save before rebooting

Well the problem is I never had a Manjaro bootloader, idk how exactly this works what I was using since I didn't set it up myself but it basically let me chose what I wanna boot when I turn on my computer, I think we modified the windows bootloader but like I said, idk. While we are at it, how do I set something (atleast similar to this) up, because I really like chosing what to boot and not having to cahnge things in my bios.

Edit: looking at my post I think it needs a bit mroe clarification: there was indeed a Manjaro efi file that booted that let me chose between windows and manjaro, just it never showed up in my bios and also cahnging order in the bios didn't do anything either afaik.

yes you did, but when manjaro got installed it also installed the grub bootloader which is what your referring to

grub. when microshyte windoze updated it decided that it's bootloader should be #1 and not #2 (as if :roll_eyes:)

thats why your grub bootloader got pushed out of the primary position by windoze fat arse :wink:
i just went through this a week or 2 ago with my sons laptop which is dual boot windows/manjaro

but since you now know your windows bootloader is working fine and the drive is not trash you can do as i suggested by going into bios and set the first boot option to manjaro instead of windows.

OR do as i suggested in the 3rd post of this thread and restore the grub bootloader
https://wiki.manjaro.org/index.php?title=Restore_the_GRUB_Bootloader#Restore_GRUB

1 Like

Okay last time I tried this both of the grub bootloaders in there only got me into the grub command line, will try out both and report if any of those did the right thing.

Sadly still both grub versions only throw me into the command line but the manjaro usb now detects my efi files again and I was able to boot my manjaro grub that actually let‘s me decide between windows and linux, how do I set things up now? Because it really isn‘t in my bios....

post the output of sudo parted -l

Model:  USB DISK 2.0 (scsi)
Disk /dev/sda: 16,0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2096MB  2100MB  4194kB  primary               esp


Model: Unknown (unknown)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  106MB  105MB   fat32        EFI system partition          boot, esp
 2      106MB   123MB  16,8MB               Microsoft reserved partition  msftres
 3      123MB   201GB  201GB   ntfs         Basic data partition          msftdata
 5      201GB   255GB  53,7GB  ext4
 4      255GB   256GB  1074MB  ntfs         Basic data partition          hidden, diag

ok, now run these

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
sudo update-grub

then post output of efibootmgr

BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0005,0003,0001,0000,2001,0002,2002,2003
Boot0000* Windows Boot Manager
Boot0001* Windows Boot Manager
Boot0002* y
Boot0003* coregrub
Boot0004* USB HDD: USB DISK 2.0
Boot0005* manjaro
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network
1 Like

manjaro is shown as first so you should be good, reboot and grub should come up and you can select windows or manjaro

Sadly no, it didn‘t change anything, I still get thrown into the grub command line and now moving windows to the top in the bios does nothing and I still land in the grub command line. As you can see manjaro doesn‘t show up in the bios and both grub version are probably still the old ones since they only throw me into the command line. Still need the usb to get into linux.
(Pic of bios in a sec, uploadspeed is dying rn...)

can you returns

sudo efibootmgr -v

BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0001,0000,2001,0003,0002,2002,2003
Boot0000* Windows Boot Manager  HD(1,GPT,32b0fe21-82bf-45ee-8915-5791062c604d,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* Windows Boot Manager  HD(1,GPT,32b0fe21-82bf-45ee-8915-5791062c604d,0x800,0x32000)/File(\EFI\arch_grub\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.
e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0002* y     PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/NVMe(0x1,00-00-00-00-00-00-00-00)/HD(1,GPT,32b0fe21-82bf-45ee-8915-5791062c604d,0x800,0x32000)/File(\grub\x86_64-efi\grub.efi)A01 ..
Boot0003* coregrub      PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/NVMe(0x1,00-00-00-00-00-00-00-00)/HD(1,GPT,32b0fe21-82bf-45ee-8915-5791062c604d,0x800,0x32000)/File(\grub\x86_64-efi\core.efi)A01 ..
Boot0004* USB HDD: USB DISK 2.0 PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/USB(1,0)/HD(1,MBR,0x0,0x3e78a0,0x2000)RC
Boot0005* manjaro       HD(1,GPT,32b0fe21-82bf-45ee-8915-5791062c604d,0x800,0x32000)/File(\EFI\manjaro\grubx64.efi)
Boot2001* EFI USB Device        RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network   RC

how did arch grub get on there. Boot0001 says "windows boot manager" but it points to \EFI\arch_grub\grubx64.efi which is marked as the first in order bootloader even after installing grub from manjaro.

maybe @stephane knows more, possibly delete that and the "coregrub" entry which again, how did that get there?

Uhmmmm, this is on me, as I mentioned in my first post in the past I solved things with a bcdedit command changing the bootmgr path so I wanted to do that one this time aswell but I didn't know what to set it to, was trying some weird things (searching in the grub command line for different bootloaders and discovered an arch bootloader and since manjaro is build on arch I thought that was what I was searching for). I wanted to reset things after realizing that it didn't do anything (I think I didn't do anything but maybe this broke things?) but I didn't find a way to reset it, the reset command I found did nothing.

for removing entry

sudo efibootmgr -b 0002 -B 

its new this kind of overlay on boot from windows

and then set boot order?

sudo efibootmgr --bootorder 0005,0000

Got thrown into windows after reboot

Forum kindly sponsored by Bytemark