Can‘t boot anything anymore

Hello guys,
honestly idk if this is the right place to ask this since at this point it might be a hardware problem but idk where else to go and I hope u guys can atleast redirect me.

But let‘s start:
I am using Manjaro for uni and Windows to play some games with friends. My friend installed the whole partition thing for me so I do not understand too much about the settings etc. Some days ago there was this new update for windows that made me boot directly into windows and didn‘t let me chose like before.
I had this problem before and a bcdedit command solved this. So I tried finding this one again, but this time I either couldn‘t find it since no commands did what I wanted or it simply didn‘t work.
Sadly I also couldn‘t get the help of my friend who installed everything for me so I was on my own.
Getting a bit desperate I went into the bios and changed the boot order. This never had any effect before but this time it surprisingly had. There was an unconfiguarted grub version on my laptop and I could get that one to start on boot. Sadly exactly setting it to do what I want was not really easy for me and I think this is where I ■■■■■■ up.
After trying some commands online trying to set a bootpath I somehow managed to break something. Before if I changed the bootorder I was able to get directly into windows on boot but after this even windows went into grub. Still I could get into windows by typing exit and then chosing the second of two windows boots (the first send me back to grub).
Here I thought everything was normal but when I went into sleep mode on windows and tried to get back into it some time later my keyboard didn‘t work. I simply rebooted my pc and suddenly was greeted by a insert boot medium text. This was resolvable with a windows bootstick letting me recover to where I was before (grub always starts on boot). So I thought everything was fine. Then I had to do some stuff on linux so I got a manjaro installation stick where I was actually able to find my efi file that gets me to my bootwindow where I can chose between manjaro and windows. Here I realized I always set things in grub to the wrong file since I didn‘t try this one, sadly I had to do some work and wanted to check that later. In Manjaro everything worked completly fine until I went into sleep mode. When trying to come back I was able to log back in but then several files told me they didn‘t exist anymore. Also I couldn‘t shut down anymore. I shut it down with the power button and when trying to boot again I was greeted by the text insert boot medium again, but this time nothing seems to work. My windows usb can‘t find windows on my laptop and manjaro can‘t detect any efi files either. Grub leaves the impression that my ssd is dead and windows only shows my usb under diskpart. The only thing that kinda gives me hope is that in the picture of cmd below it shows aviailable space that should be my ssd, but honestly I don‘t really understand what it says.

I would at a guess say windows has wiped your manjaro boot loader

some windows updates, including the latest one i can confirm make windows bootloader the first boot option so grub no longer comes up but it is still there.

@Lequitas
get the windows booter working properly first. if your windows is also no longer booting and you cant get to the windows repair tool usb to fix the bootloader (for windows) then create a windows rescue usb which they have for download on the microshyte website somewhere.

once windows is booting fine, boot up a manjaro usb, create one if you need to. when you get to the grub "Welcome to manjaro" screen you should see at the bottom "detect efi bootloaders" or something similar and you can boot manjaro from there.

once you booted into manjaro, follow the directions here to reinstall the grub bootloader (it's simple). just be sure to follow the right directions. if your using a UEFI/GPT setup, follow the UEFI instructions only. if your using a BIOS/MBR setup, follow the BIOS instructions only.

if your not sure, open a terminal and enter sudo parted -l and if it shows the drive manjaro is installed on is GPT then its UEFI, if its MBR it's bios.

also, you need only follow steps 4 and 5 of the uefi instructions, ignore the others

I am sorry that I am already failing at the first step, but can you explain further/link me what exactly I should use to get windows to work again? I can‘t find anything besides the media creation tool and this can only create one type of usb, an installation usb. This is the one I tried to use on my pc but it couldn‘t do anything.

Edit: to clarify a bit further, it doesn‘t find any windows installation it can boot/repair

if you have a USB install manjaro ,
boot on USB ,
open a terminal and reports

fdisk -l 
inxi -Fxxxza --no-host
[manjaro@manjaro ~]$ sudo fdisk -l
Disk /dev/loop0: 18.1 MiB, 18948096 bytes, 37008 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop1: 274.6 MiB, 287969280 bytes, 562440 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop2: 1.1 GiB, 1229180928 bytes, 2400744 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop3: 475.5 MiB, 498573312 bytes, 973776 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 15 GiB, 16039018496 bytes, 31326208 sectors
Disk model: USB DISK 2.0    
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot   Start     End Sectors Size Id Type
/dev/sda1  *         64 4094111 4094048   2G  0 Empty
/dev/sda2       4094112 4102303    8192   4M ef EFI (FAT-12/16/32)
[manjaro@manjaro ~]$ inxi -Fxxxza --no-host
System:    Kernel: 4.19.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.15.2 tk: Qt 5.12.1 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Swift SF514-51 v: V1.15 serial: <filter> 
           Mobo: Acer model: MiniOne_SK v: V1.15 serial: <filter> UEFI: Insyde v: 1.15 date: 03/16/2018 
Battery:   ID-1: BAT1 charge: 24.9 Wh condition: 50.5/54.2 Wh (93%) volts: 11.2/11.6 model: PANASONIC 004C354F35315041 
           type: Li-ion serial: <filter> status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 8E (142) 
           stepping: 9 microcode: 8E L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21704 
           Speed: 1000 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 1000 2: 1000 3: 1002 4: 1000 
           Vulnerabilities: Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:5916 
           Display: x11 server: X.Org 1.20.4 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 18.3.4 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:9d71 
           Sound Server: ALSA v: k4.19.28-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Lite-On driver: ath10k_pci v: kernel 
           port: 3040 bus ID: 02:00.0 chip ID: 168c:003e 
           IF: wlp2s0 state: down mac: <filter> 
Drives:    Local Storage: total: 14.94 GiB used: 83.7 MiB (0.5%) 
           ID-1: /dev/sda type: USB model: USB DISK 2.0 size: 14.94 GiB block size: physical: 512 B logical: 512 B 
           serial: <filter> rev: PMAP scheme: MBR 
Partition: ID-1: / raw size: N/A size: 5.74 GiB used: 83.7 MiB (1.4%) fs: overlay source: ERR-102 
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 179 Uptime: 4m Memory: 7.66 GiB used: 590.7 MiB (7.5%) Init: systemd v: 241 Compilers: gcc: 8.2.1 
           Shell: bash v: 5.0.0 running in: konsole inxi: 3.0.32

Edit: Should I rather try making a screenshot? Seems a bit messy...

@Lequitas, could you fix your post, please?
Makes it easier to read if you use the </>. Just highlight the text and hit the </> button. Thanks.

Ah, thanks, didnt know how to do this

Perfect, thank you. :grin:

Also, to answer your question about the screenshot. I assume it was because you didn't know the </> button. But, it's preferred to have text pasted if at all possible. That way it can be copy and searched for easily.
Screenshots only if you truly borked your computer and can't get the text.

outlook is not so good :frowning_face:

sda is the only drive listed. is there only 1 drive in this system? if so, a reinstall of windows first and then manjaro second (in that order)

the other thing is that the drive is "dos" but theres an EFI partition on it and sda1 is marked as the boot partition and it's empty

nevermind, thats the USB im reading :man_facepalming:

@Lequitas use the manjaro usb to boot your already installed manjaro

or from the live environment your in now, open a terminal and enter

sudo manjaro-chroot -a

then post these:

sudo parted -l
lsblk
efibootmgr
tree /mnt/boot/efi

Sadly the Manjaro USB cannot detect any efi bootloaders anymore...
Also this doesn seem so good:

[manjaro@manjaro ~]$ sudo manjaro-chroot -a
==> ERROR: You can't mount 0!

enter 1 even though it's not an option

I am not sure I understand what exactly you mean by enter 1, like this?:

[manjaro@manjaro ~]$ sudo manjaro-chroot 1
==> ERROR: Can't create chroot on non-directory 1

No, just enter manjaro-chroot -a
Then when it gives you a choice, even though 1 isn't a choice. Enter it anyway.

1 Like

I don't get a choice tho? This is how it looks after the command:

[manjaro@manjaro ~]$ manjaro-chroot -a
==> ERROR: You can't mount 0!
[manjaro@manjaro ~]$

Or am I misunderstanding something?

no, it just doesnt see your manjaro installation.

also sudo parted -l should of also shown your hard drive regardless and it didnt so something is wrong.

go into your bios or system diagnostics and test everything.

First: is there a difference between system diagnostics and bios?
Second: What exactly am I supposed to do in the BIOS? It has very limited options (on my laptop atleast) and I don't quite see what would help in this situation.

yes, bios has bios options and diagnotics tests system hardware for failures.

im not sure on your exact model, for me im able to hit F12 and the boot selection menu comes up and i have a diagnostics option. i think i can also get to this from bios itself. it all depends on your system.

get to system diagnostics any way you can and run a full test to check for failures

I think I found the manual but not totally certain.

It's on c|net of all places. :nauseated_face:

When you boot. hit F2 That's supposedly the BIOS Utility. Whatever Acer means by that. :rofl:

1 Like

found the same from the acer website manual for SF514-51 .

but it only explains how to get into bios using F2 and nothing about a diagnostic tool so i would guess you can access it from within bios itself, somewhere ? :man_shrugging:

if you cant figure it out, follow these instructions, if it fails then there is something more serious wrong like the SSD gone bad

of course if the drive is no good, neither will the system image stored on it be.

in the future, never ever ever try to fix linux from windows. windows cant fix windows, nevermind other OS's