Can not install Manjaro 18.0.4 stable or 18.1.0-rc5

I'm very long time Debian based Linux user, I just decided to give Manjaro Gnome a try in VMWare and it worked well and looked nice so I decided to switch my main OS to Manjaro.

Unfortunately it just doesn't install. In the very same machine I have installed Mint, Ubuntu, Debian, all flavors and variants with no issues, but Manjaro just doesn't start the installer...

I have 2x2080TI + 2990wx + 128GB RAM in case that matters.

When I start the installer with non-free it gets stuck at "Session 1 for user Manjaro" and installer never starts.

When I start the installer with free it gets stuck at "TLP System Startup/Shutdown"

I played around boot flags like nouveau, i915, radeon etc. Flipped them to 1 and 0s and no combination worked.

I tried Manjaro 18.0.4 stable and 18.1.0-rc5 stable. Same result. In rc5 actually even the text is completely blurry, I just see things going up and down which are installer printing status updates on console, but can't read the text. In regular 18.0.4 I can actually see the text but doesn't start the installer.

Also I almost read every single thread in this forum related to Installer doesn't work, Installer stuck at TLP System Startup/Shutdown", so I don't think referencing other threads will help, but I'm open to all suggestions. Thanks in advance

Does the live version do well? Are things working there?

In the live version, open a terminal and type
inxi -Fxxz
Copy paste the output here using the button </> above.

1 Like

I mean, I don't see "Install Manjaro" option, I thought that's the way things are, no? Like Linux Mint installer? When I boot from USB, I see the option that says "Boot Manjaro" and I assume thats the "live version"? Am I missing something here?

Yes, you see Boot Manjaro. It will start the live version which you can use to test the software on your hardware to see if everything is working.
On the desktop there will an icon to install Manjaro should you wish to do so, but you have to boot Manjaro first.

Yeah, that's the thing, it just doesn't boot, it never gets past that. I never see Live Manjaro, never had chance to start the actual installer. Thats the actual problem

Use that choice: Boot Manjaro to boot the live version. Inside the live version, on your desktop, there will be an icon to install Manjaro to hard-disk.

There is no choice Live Manjaro, just Boot Manjaro. Use that one. Please, use that one.

On this screen change the drivers to "driver=nonfree"

have you try only one video card 2080ti in No Free drivers ?

having 2 or more videos Nvidia dot not works in most cases with No-Free Drivers

@DeMus : I already do that, it just doesn't boot. I can't see Desktop, I can't anything. It just doesn't boot at all as I've been saying.

@dalto : Yes, I tried free and non-free as I said in original question. I even played with other boot parameters as I explained in original question. None works

Can you take a clear pic of the whole screen with your phone or something when it's stuck on that?
Often times TLP is just the last thing to hang and it sits there but the error is higher up.
Might give a clue. :woman_shrugging:

No error above it for free, now it just shows completely blurry screen, no text readable. The "non-free" boot gets stuck at different stage:

What you mean? Its booting from Manjaro USB and its whatever is in the ISO image, I'm not overriding anything

Ignore me (I misread).

If you reach the installer grub, after you chose nonfree, before you pres enter to boot, edit the entry by pressing e and replace quiet with nomodeset then press F10 to save and continue booting. If you still have the screen as in the last picture, switch TTY by Ctrl+Alt+F5 for instance. If you can see the login just type manjaro for user and password and then try to run startx and see if that leads you to desktop and be able to make the install.
For me, the 17.1.10-stable ISO was always the best i used
-just a hint-

Thanks, I tried that. I replaced quiet with nomodeset, it got stuck at same place. Then pressed CTRL + ALT + F5 and logged into tty5, did startx but it didn't start and I got Xorg errors. Clearly its NVIDIA driver issue.

Now we have two options as far as I know.

  1. Get it to work without NVIDIA drivers
  2. Install NVIDIA drivers? and then install? If I install NVIDIA drivers manually and then reboot, would it survive the reboot? I don't think so.

So basically no one can install Manjaro with 2x NVIDIA 2080Ti s? Is that what it is?

I don't really want to install a much older version and then manually upgrade the OS within

Is there a bug tracker for Manjaro? Any way to get devs to notice this thread?

Any updates? Should I just skip Manjaro all together?

Since it's a rolling distro, why would that be such an issue?

Ok, I'll bite. So:

a) Which version I should download that you think it will work with 2x 2080Ti s?
b) How do I upgrade from a much older distro to most recent 18 r5 version post-install?

Good question?

  • 18.x is kernel 4.19
  • 18.1 is kernel 5.2
  • 17.x is kernel 4.14

Small deviations may exist.

TTY -> login -> sudo pacman-mirrors -f && sudo pacman -Syyu

1 Like