Can no longer select multiple options at boot

I dualboot windows, but windows and manjaro are on separate drives so everything was very simple, and manjaro was able to automatically set up everything upon first install.

How it was before is that my bios first booted manjaro’s drive, and a grub menu would appear allowing you to boot into manjaro, boot UEFI settings (bios), and boot windows. This was great for me and worked well.

However my windows install died at some point, and I grub-mkconfig 'd when it was dead.

This removed the grub menu from appearing entirely. At first I had no issue, but I fixed my windows drive, and when I went to grub-mkconfig, the menu no longer appeared, it still just directly boots into manjaro.

How do I get the grub menu to reappear at boot?

So the os-prober doesn’t detect Windows? Keep sure Windows Bootloader is installed in UEFI Mode aswell…

efibootmgr -v

Could it be that Windows has been shut down in hibernation mode? Because if it has, Grub update can´t detect it. Windows 10 has the default to hibernate even when you click Shut down.

It seems I’ve fixed it; I had been running grub-mkconfig instead of update-grub.
grub-mkconfig detected windows, however it did not add the boot menu back.

Well, that or I fixed my windows install in the meantime; it was only fully updated and on the correct edition earlier today. It also was only activated earlier today.

(however I do think it was because I used grub-mkconfig instead of update-grub)

Thanks for reminding me to disable hibernation mode and quick boot though!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.