Can no longer change backgrounds

Hi, I use Manjaro cinnamon DE on a desktop. Recently I could not install the latest recent major update. the error message was

could not satisfy dependencies:

  • unable to satisfy dependency ‘’ required by libphonenumber
  • unable to satisfy dependency ‘’ required by libphonenumber

I searched this forum and came across a post. unfortunately i do not remember it’s title and I could not find it again, anyway the solution was to run “pacman Syyuu” the post then broke out into an argument between using 1 u or 2 u That post (or maybe another one) also suggested “pacman-mirrors --geoip” I run that last one and then the update worked. But after the update, the UI of ‘Pamac 11.0.1-2’ was way brighter than before and was inconsistent with the general UI (the layout also changed but that may have been intended) I then checked the ‘appearances’ and in ‘Backgrounds’ the folders ‘Cinnamon’ and ‘Gnome’ are there but they are both empty?? however when I check in the file manager <usr/share/backgrounds/cinnamon> all the jpg files are there?? I don’t know if those 2 issues are related or not, it’s possible that the missing backgrounds issue was there before the upgrade (it’s been a long time since I changed the background). There is another issue that definitely happen after the upgrade - a card game ‘PySol’ does not open anymore. any suggestions would be welcome.
PS: I tried to use the 3 back ticks as per the instructions to highlight the code, but when I did it highlights the whole post and puts it on 1 line? what am I doing wrong?

yes its empty another bug, if you set the slideshow to work it does so it does actually know the pictures it has you just can’t see them.

# Sample

Maybe :grey_question:

  • Must be in column 1
  • A block requires a begin and end


Ok so the images not showing up in the “Background” folder, the inconsistent of “pamac 11.0.1-2” UI are due to some bug in the latest upgrade? Are they likely to be fixed in a future upgrade? or do I need to apply a workaround?

PS: Edited 18/07/2023 to have only one issue per post

I sorted one of my issues - the UI inconsistencies between pamac 11.0.1-2 and other apps. I use the Cinnamon DE edition, but In the ‘Stable Update’ 2023-07-10 the fix for the Xfce DE was to install pamac-gtk3 That worked for me - so works for Cinnamon DE.
Alas my Background folder is still empty…
As per forum rules as having only 1 issue per post, I will start a separate post for the PySol issue leaving just the empty background folder issue in this post

Any news here? When this bug is fixed? I tried to install Linux Mint Backgrounds 21.2 Victoria, I have the exact same issue.

I’m waiting on an update as well… being just background settings, I assume it’s in the ‘Not urgent’ category!? I haven’t changed my backgrounds for some time and don’t intend too. I stumbled on that bug following a UI inconsistency which prompted me to check all the ‘Appearance’ settings - I since found a fix for that one. There are other bugs that were introduced by the latest major update, so looking forward to an update to fix the bugs…

There was a decent size update today that fixed the PySol card game - Yeee It’s now working again…
Unfortunately the empty Background folder issue was not resolved by this latest update… does anybody know what the issue is and if there is a solution coming?

I have the same problem with the blank background dialog. It does not contain wallpaper previews. In a VM I installed and updated Manjaro with the latest Cinnamon image. There I did not have the problem. So I don’t suspect a problem with any package, but a configuration problem. However, I can not exclude that a package is responsible, because in the VM I had installed significantly fewer packages.

The issue has been fixed and now we just have to wait for the fix to be pushed out. Fix 11746

In the meantime, you can change the backgrounds using Nemo file manager, just open Nemo and navigate to /`usr/share/backgrounds/, select the folder of images you are interested in, right click on the image you would like to use on the Desktop and “Set as Wallpaper”

That great! I followed the link you provided to the fix and looks like it’s just a case of changing ANTIALIAS to LANCZOS in the listed files? I found and opened the 4 files (with a text editor) and found the line/s with the ‘ANTIALIAS’ - if that’s all that has to be changed - I can probably do that myself instead of waiting for a fix to trickle down to the repos - unless I am missing something??

That is up to you…
Personally, changing the wallpaper is not something I do very often and using Nemo to change is a simple workaround until the fix trickles down.

You have the right to fork, hack and crash :slight_smile:

Me too I don’t intend on changing my backgrounds, so yes I probably just wait for the next update to fix it. There are only 2 reasons why I was going to do the edit myself.

  1. To learn more about the inner workings of Linux. But on reflection, changing 1 word in 4 files without knowing/understanding what those files do, is not going to advance my knowledge of Linux OS.
  2. I came across this ‘ANTIALIAS’ in another issue I had with the card game ‘Pysol’ that stopped working after an update (see terminal output below) It has since been fixed and is now working perfectly.
[jp@jpmanjarohome ~]$ pysol
Traceback (most recent call last):
  File "/usr/bin/pysol", line 36, in <module>
    from pysollib.main import main  # noqa: E402,I202
  File "/usr/lib/python3.11/site-packages/pysollib/", line 30, in <module>
    from import Application
  File "/usr/lib/python3.11/site-packages/pysollib/", line 32, in <module>
    from pysollib.actions import PysolMenubar
  File "/usr/lib/python3.11/site-packages/pysollib/", line 28, in <module>
    from import help_about, help_html
  File "/usr/lib/python3.11/site-packages/pysollib/", line 29, in <module>
    from pysollib.pysoltk import HTMLViewer
  File "/usr/lib/python3.11/site-packages/pysollib/", line 28, in <module>
    from pysollib.ui.tktile.tkutil import *  # noqa: F401,F403
  File "/usr/lib/python3.11/site-packages/pysollib/ui/tktile/", line 250, in <module>
    class PIL_Image(ImageTk.PhotoImage):
  File "/usr/lib/python3.11/site-packages/pysollib/ui/tktile/", line 291, in PIL_Image
    def resize(self, xf, yf, resample=Image.ANTIALIAS):
AttributeError: module 'PIL.Image' has no attribute 'ANTIALIAS'
[jp@jpmanjarohome ~]$

So maybe this ‘ANTIALIAS’ is causing issues with other apps?

Update on the background issue.
I don’t think the the Fix11746 is the solution!?
Because on my laptop (Lenovo X230t) with the same version of Manjaro Cinnamon edition (fully up-to-date) and with the same appearance settings and the same apps installed as my desktop computer, the ‘Background’ images are in their folders and selectable!? The ‘ANTIALIAS’ is in the files as per the fix11746? The only difference I can see, is that the laptop uses Kernel 5.10.189-1 while the desktop uses Kernel 5.15.125-1
I hope the developers trying to fix the issue will see my post

Yes, some backgrounds are still visible, not every system looses all, New install will not work, existing installs is a hit and miss. The fix is coming.

It’s been about 6 weeks since the last post and 2 major updates, but this error still exist - is the fix still coming? or has it been but I missed the instructions?? Thanks

It’s in unstable nemo has been updated

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.