Can no longer boot after system update. (2019-11-14)

I tried danman's solution of upgrading to 440 nvidia drivers.
But for me Booting still yields a black screen with a curser.
If i change to another login prompt,type startx and than look into the log files
It says that there is a segmentation fault happening in the driver

Segmentation fault at address 0x2a9

Does anyone know why this happens? What can i do?

Post logs.
How to change video drivers or configuration and troubleshoot

Do you mean you get to your GUI session?

Do you mean you get to your GUI session?

No i dont get a Gui Session

I also just realised that the logs i was seeing were from a previous start of X.
So i Just cleared the Xorg log files and restarted the system again.
Then directly after the restart the logs at ~/.local/share/xorg/Xorg.0.log and /var/log/Xorg.0.log are empty?? shouldn't there be at least something

Edit:
Running startx produces this log file
https://pastebin.com/60kM4y2p
located at: ~/.local/share/xorg/Xorg.0.log

Please read the linked tutorial (my previous post) to see where files are and how to troubleshoot, get log files etc.

Running startx produces this log file
https://pastebin.com/60kM4y2p
located at: ~/.local/share/xorg/Xorg.0.log

Running
systemctl start lightdm just gives me a black screen with a flashing cursor, just like when i boot normaly

What's the journal reporting? Post (pastebin) please...

systemctl status lightdm
journalctl -b -p3 --no-hostname --no-pager

First off, thanks for helping me and your quick replies


systemctl status lightdm

https://pastebin.com/pYu5PFap

journalctl -b -p3 --no-hostname --no-pager

https://pastebin.com/wkAKTCUa

Now i am not quite sure if i am using lightdm at all it should be gdm if i am on gnome right?

There is a problem with nvidia driver.
Try another version of nvidia driver. (418 etc)
If you have kernel 4.19, use it to boot. If not, try installing it.
Also try fallback kernels (not sure it will help in this case, though).

Did not work here. :confused:

Try to update first with an up-to-date mirror.

To change nvidia driver version, first uninstall nvidia-utils with pacman and then use mhwd. But, as said, first try a fresh mirror update.

I have a prime setup. I used mhwd and now the System wont even boot.


I'm not sure if I should reinstall or try to fix using chroot. Terrible Update so far.

It cant find my card. I have a Nvidia prime setup with an Intel discrete card this might be Part of the problem. Im open to sugestions as this install is 2 years old and with some important customizations.

So it seemed to be a problem with mhwd doing something incorrectly while installing the the driver.
What i did now is changing the xorg config to use nouveu driver, restarting the system and than uninstalling and installing the nvidia driver 440xx. With the next boot everything just worked Oo

Can you provide a link for it? I could not fix my System so far.

It seems you have installed nvidia-440 driver. If you have kernel 4.19, try booting that one. Else, install it, as it's currently the best option for the nvidia issues.

More info is needed, in order to give a better answer, sorry...
How to change video drivers or configuration and troubleshoot
How to provide information about your issues

I`m using 4.8.84-1.

inxi -Fxxxza --no-host
System:    Kernel: 4.19.84-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID=24ac56d2-c1dc-4919-b6a4-5e39433604ca rw quiet
           resume=UUID=a467c59b-9313-4563-a7cf-b3d880abd712
           Console: tty 0 dm: SDDM Distro: Manjaro Linux
Machine:   Type: Laptop System: Dell product: Inspiron 15 7000 Gaming v: N/A serial: <filter> Chassis: type: 10
           serial: <filter>
           Mobo: Dell model: 0P84C9 v: A01 serial: <filter> UEFI: Dell v: 1.8.1 date: 08/15/2018
Battery:   ID-1: BAT0 charge: 62.9 Wh condition: 62.9/74.0 Wh (85%) volts: 12.9/11.4 model: SMP DELL 71JF452
           type: Li-poly serial: <filter> status: Full
CPU:       Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake family: 6
           model-id: 9E (158) stepping: 9 microcode: C6 L2 cache: 6144 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44944
           Speed: 1201 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 1201 2: 1200 3: 1200 4: 1200 5: 1200 6: 1200
           7: 1200 8: 1201
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:591b
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell driver: nouveau v: kernel
           bus ID: 01:00.0 chip ID: 10de:1c8c
           Display: server: X.org 1.20.5 driver: modesetting FAILED: nvidia tty: 120x29
           Message: Advanced graphics data unavailable in console. Try -G --display
Audio:     Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3
           chip ID: 8086:a171
           Sound Server: ALSA v: k4.19.84-1-MANJARO
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8168
           v: 8.047.04-NAPI port: d000 bus ID: 02:00.0 chip ID: 10ec:8168
           IF: enp2s0 state: down mac: <filter>
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell driver: ath10k_pci
           v: kernel port: d000 bus ID: 03:00.0 chip ID: 168c:003e
           IF: wlp3s0 state: up mac: <filter>
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-4:2 chip ID: 0cf3:e007
           IF-ID-1: docker0 state: down mac: <filter>
Drives:    Local Storage: total: 1.14 TiB used: 150.99 GiB (12.9%)
           ID-1: /dev/sda vendor: LITE-ON model: CV3-8D256-11 SATA 256GB size: 238.47 GiB block size:
           physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 10D scheme: GPT
           ID-2: /dev/sdb vendor: Western Digital model: WD10JPVX-75JC3T0 size: 931.51 GiB block size:
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A03 scheme: GPT
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: f060 bus ID: 00:17.0
           chip ID: 8086.282a rev: 31
Partition: ID-1: / raw size: 111.28 GiB size: 109.03 GiB (97.98%) used: 56.84 GiB (52.1%) fs: ext4 dev: /dev/sda5
           ID-2: /var raw size: 52.97 GiB size: 51.89 GiB (97.96%) used: 47.91 GiB (92.3%) fs: ext4 dev: /dev/sdb2
           ID-3: swap-1 size: 1000.0 MiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default)
           cache pressure: 100 (default) dev: /dev/sda6
Sensors:   System Temperatures: cpu: 40.0 C mobo: 34.0 C sodimm: 35.0 C
           Fan Speeds (RPM): cpu: 0
Use of uninitialized value $val2 in string eq at /usr/bin/inxi line 5787.
Use of uninitialized value $val2 in split at /usr/bin/inxi line 5792.
Use of uninitialized value $val2 in concatenation (.) or string at /usr/bin/inxi line 5794.
Use of uninitialized value $val2 in concatenation (.) or string at /usr/bin/inxi line 5795.
Use of uninitialized value $val2 in concatenation (.) or string at /usr/bin/inxi line 5796.
           GPU: device: temp: N/A device: nouveau temp: 35 C
Info:      Processes: 172 Uptime: 12m Memory: 15.53 GiB used: 340.7 MiB (2.1%) Init: systemd v: 242 Compilers:
           gcc: 9.2.0 alt: 7/8 clang: 9.0.0 Shell: bash v: 5.0.11 running in: tty 0 (SSH) inxi: 3.0.36

Also:

sudo dmesg | grep nvidia
[sudo] senha para vfbsilva:
[    4.634094] nvidia: module license 'NVIDIA' taints kernel.
[    4.643962] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
[    4.644171] nvidia 0000:01:00.0: enabling device (0004 -> 0007)
[    4.644252] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=none
[    5.043845] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  440.31  Sun Oct 27 02:09:30 UTC 2019
[    5.049605] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[    5.394638] nvidia 0000:01:00.0: optimus capabilities: enabled, status dynamic power, hda bios codec supported
[    6.027368] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 0
[   10.802776] [drm] [nvidia-drm] [GPU ID 0x00000100] Unloading driver
[   10.855085] nvidia-modeset: Unloading
[   10.870732] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   11.425516] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   11.480101] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   11.781924] nvidia: unknown parameter 'nvidia-modeset' ignored
[   11.781928] nvidia: unknown parameter 'nvidia-drm' ignored
[   11.781931] nvidia: unknown parameter 'nvidia-uvm' ignored
[   11.783625] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   11.785045] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   11.984304] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   11.984821] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   12.829722] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   12.830339] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   13.004084] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   13.004533] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   13.181632] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   13.182394] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   13.355643] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   13.356227] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   14.416394] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   14.417578] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   14.688792] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   14.689560] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   14.969764] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   14.970554] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   15.140171] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   15.140715] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   16.107405] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   16.108315] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   16.383137] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   16.383774] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   16.663578] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   16.664213] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   16.876261] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   16.876859] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   18.120382] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   18.121160] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   18.281946] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   18.282676] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   18.483957] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   18.484597] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   18.656028] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   18.656520] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   19.513421] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   19.514158] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   19.706890] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   19.707841] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   19.990396] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   19.991447] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241
[   20.238169] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
               NVRM: nouveau, rivafb, nvidiafb or rivatv
[   20.239086] nvidia-nvlink: Unregistered the Nvlink Core, major device number 241

Xorg log

I feel you are currently unsure about what is being suggested and you ignored the fact I have a prime setup which might differ in how to be handled.

I have the same problem, 430xx doesnt work because of the update and 435x and 440x yield a blackscreen with the cursor. I got a 1050ti

Not to my knowledge... :laughing:. Thanks for you boosting my self-confidence!!

My 1st approach had to be to exclude the common issues introduced with the latest Stable Update.
I suggest you start a new topic to handle your Prime setup better.
A best guessed temp workaround would be to rename/disable your xorg conf file, so you get GUI on Intel (from TTY). Maybe your sddm Xsetup script needs to be disabled as well (if needed).

More info needed (in your new topic)

inxi -SMGxxaz 
mhwd -li
pacman -Qs "nvidia\|optimus"
for p in /sys/class/drm/*/status; do con=${p%/status}; echo -n "${con#*/card?-}: "; cat $p; done
for Xconf in $(ls /etc/X11/xorg.conf.d/*.conf); do echo -e "\n" $Xconf ; cat $Xconf ; done
for Xconf in $(ls /etc/modules-load.d/*.conf); do echo -e "\n" $Xconf ; cat $Xconf ; done
for Xconf in $(ls /etc/modprobe.d/*.conf); do echo -e "\n" $Xconf ; cat $Xconf ; done
journalctl -b -p3 --no-pager --no-hostname
for Xlog in $(ls /var/log/Xorg.?.log); do echo -e "\n" $Xlog ; grep -E "(EE)|(WW)|failed|Time" $Xlog ; done
ls /etc/sddm.conf.d/*.conf
cat /etc/sddm.conf |  awk -F "=" '/Xsetup/{print $2}' | xargs cat

Try nvidia 440 or 418 with kernel 4.19.
Also try the fallback kernel images at boot (hopefully helpful...).

I tried the 440 with the same blackscreen as the user above, and I am on kernel 4.19 already./
I did try 4.14 and the fallback kernel images but none of them work.

1 Like

new topic

1 Like

Forum kindly sponsored by