Can login to system after sleep only after running TTY

Hello. I used Manjaro for a couple of month but since yesterday I have a problem. I usually send OS to sleep instead of turning machine off, and now after waking up I I see a blank screen for several seconds and after that monitor turns off. Only one way to see logon screen is go to TTY (ctrl+alt+F2) and exit (ctrl+alt+f1). After that system shows the logon screen. Is it any way to fix it?
I tried to reinstall kernel and video driver (video-linux) but nothing changes.
My specs are Ryzen 3 1200, AMD RX580. Manjaro 20.1 with latest updates, kernel 5.8.11-1.
Thank you in advance.

I was having some strange problems with suspend as well using different kernels. 5.4 kernel is working well for me.

I remember having that issue a long time ago. It just went away. I never tried to debug. it. Recently, another user was having the same problem and then it went away after an update… I really don’t know why that happens sometimes.

The next time it happens, after you login to your system, try looking at the logs for any errors:

journalctl -b0
1 Like