[Call for Testers] Manjaro 22.1.0 Talos

Well. RC2 are broken in this regard due to this issue: [util-yaml] fix services.conf (7cabd74e) · Commits · Tools / development-tools / manjaro-tools · GitLab. However timers are now enabled right, but not services. Will try to fix that in RC3

If it helps I can test it on a VM. Let me know.

RC3 is now online and already tested by me. But go ahead @damiank

1 Like

I’ve found links to RC2 in this thread, but no to RC3, where are you uploading them @philm ?

Experience so far with rc2: installing gnome-full without office results and sticking to defaults results in a TTY login screen, the gdm service is not enabled, enabling the service restores the normal login screen. When no gdm would start I check for gdm-plymouth however that package is not available? There are more services not started by default, such as NetworkManager.

Edit: some journal errorss that I can trace back to missing files/packages

WARNING: Could not parse desktop file manjaro-app-folder-settings.desktop or it references a not found TryExec binary


WARNING: Could not parse desktop file manjaro-starter.desktop or it references a not found TryExec binary



A post was merged into an existing topic: [Stable Update] 2023-04-06 - Kernels, Systemd, Nextcloud 26, Linux-Firmware, LibreOffice 7.5.2

With RC3 we enabled timers to be active, however due to a typo no systemd services got activated. That is fixed in RC3. [util-yaml] fix services.conf (7cabd74e) · Commits · Tools / development-tools / manjaro-tools · GitLab


Experience with rc3: all services start normal, no failed or not starting services, the usual smooth experience :+1:
Missing files in ~ are still there:

$ pamac search --files manjaro-app-folder-settings.desktop
/etc/skel/.config/autostart/manjaro-app-folder-settings.desktop is owned by manjaro-gnome-settings

$ pamac info manjaro-gnome-settings
Install Reason        : Explicitly installed

Is this package missing something?

Works good here yet.
Nvidia 760 card.

Good Work

Greate. Haven’t tested 4. But I reinstalled with rc3 and it worked

Great that the installer RAM usage has been fixed. It’s just incomprehensible how someone thought 900 megs for some RAW pictures was OK.

1 Like

:rotating_light: Be careful, Gnome 43.5 kills the whole desktop and redirects to the login page, IF clicking “X” button to clear any keywords in the search bar.

See video how to reproduce the problem step by step in my VM:

(The video expires in 1 day)

Process 1013 (gnome-shell) of user 1000 dumped core.

Stack trace of thread 1013:
#0  0x00007f57d21ad1f0 clutter_actor_event (libmutter-clutter-11.so.0 + 0x441f0)
#1  0x00007f57d21bfecb n/a (libmutter-clutter-11.so.0 + 0x56ecb)
#2  0x00007f57d2201c26 _clutter_process_event (libmutter-clutter-11.so.0 + 0x98c26)
#3  0x00007f57d2221748 _clutter_stage_queue_event (libmutter-clutter-11.so.0 + 0xb8748)
#4  0x00007f57d1e677fa n/a (libmutter-11.so.0 + 0x677fa)
#5  0x00007f57d2cd9afb g_main_context_dispatch (libglib-2.0.so.0 + 0x5aafb)
#6  0x00007f57d2d365d9 n/a (libglib-2.0.so.0 + 0xb75d9)
#7  0x00007f57d2cd90cf g_main_loop_run (libglib-2.0.so.0 + 0x5a0cf)
#8  0x00007f57d1ed0a6b meta_context_run_main_loop (libmutter-11.so.0 + 0xd0a6b)
#9  0x000055884a58e48d n/a (gnome-shell + 0x248d)
#10 0x00007f57d1c3c790 n/a (libc.so.6 + 0x23790)
#11 0x00007f57d1c3c84a __libc_start_main (libc.so.6 + 0x2384a)
#12 0x000055884a58e715 n/a (gnome-shell + 0x2715)

Stack trace of thread 1027:
#0  0x00007f57d1c9b766 n/a (libc.so.6 + 0x82766)
#1  0x00007f57d1c9df90 pthread_cond_wait (libc.so.6 + 0x84f90)
#2  0x00007f57ba50c4ee n/a (virtio_gpu_dri.so + 0x10c4ee)
#3  0x00007f57baaef3ac n/a (virtio_gpu_dri.so + 0x6ef3ac)
#4  0x00007f57ba50c41c n/a (virtio_gpu_dri.so + 0x10c41c)
#5  0x00007f57d1c9ebb5 n/a (libc.so.6 + 0x85bb5)
#6  0x00007f57d1d20d90 n/a (libc.so.6 + 0x107d90)

Someone can reproduce the problem from other Arch based distros, e.g. EOS

Well, currently 44.x series is being established. We will see …

Installed RC4 KDE Minimal on a VM, looks good to me. Should i check for something in particular? I’m new on this.

Trying to download the RC4 Minimal Torrent, no luck.KTorrent reports Stalled.

I try RC 4 full. It worked greate for me.
Thanks for good work. I use the gnome version :slight_smile:

After 3 days Minimal has Started.


Well that didn’t last long, and RC4 Full is stalled as well.

At the same time other torrents are working fine.

Installed Plasma 5 Full RC 4 (2.1.0-rc4-230414-linux61) on my Librem 15v4 with 4k screen. Installation went well with LUKS and swap file.

Only issue so far is after setting scaling in Plasma, Pamac didn’t scale, had it install xsettingsd as per Gtk app scaling.

Everything else seems fine so far.

Today I’ve built my own GNOME Minimal ISO and get surprised by the fact that, even selecting the stable branch, I get Talos 22.1.0 installed in my system. Not sure if it was intended, but let me report that everything is running as expected.

Yes, we tagged the stable branch already for Talos days ago. Sometimes it takes longer to get a working ISO out. Also when I tag the stable branch with RC1 … and so on people get confused and wonder why the stable branch has now a version which is normally known for developers.

Manjaro is in the end a rolling release and the version numbers only matter for the install medias, not the OS itself.

1 Like