Call For Testers (18.07)



I am now starting to generate images at a much higher pace than before, so I can now create images fairly easy. So these test images, from today, is because I am testing a new method of creating images.

So I am now looking for testers for the following devices:

  • Raspberry Pi 2 & 3
  • Odroid-C1
  • Odroid-C2
  • Odroid-XU4

Test images are available to be downloaded on my Nextcloud (does not have the best connection). They are all zipped.
So far only “minimal” images are available for testing.

Current test images:
Raspberry PI 2/3 18.07-rc2
Odroid-C1 18.07-rc2
Odroid-C2 18.07-rc2
Odroid-XU4 18.07-rc2

So please test the images and reply back in this thread with the following information:

  • What image did you test?
  • What device did you test on?
  • Does it boot to a CLI login prompt?
  • Can you login with both root and manjaro users?
  • Can you install/update packages?
  • Does the resize-sd script work? If not, what if you remove yes from line 39?

I will update this thread and the folder, when new images are available for testing.

Known Issues:

  • Odroid images does not boot to a CLI when connected to a monitor, but SSH access is available.
  • resize-sd script does not work in rc2 images.

New to the forum, introduce yourself

What image did you test?
What device did you test on?
Raspberry PI 3 B+
Does it boot to a CLI login prompt?
Can you login with both root and manjaro users?
Can you install/update packages?
No, Ethernet not working


I have no problem with the Nextcloud.

  • What image did you test?
    (I thought it is the latest (oc2) vs (oc1) but now I see it is older on Nextcloud.)
    Used dd if=Manjaro-ARM-minimal-oc2-18.05.img of=/dev/sdb bs=4M

  • What device did you test on?

  • Does it boot to a CLI login prompt?
    On later inspection of the SD card, I notice only one partition - the root partition.
    The boot partition is missing - is this intentional?
    Should I have used:
    dd if=Manjaro-ARM-minimal-oc2-18.05.img of=/dev/sdb2 bs=4M
    in order to preserve the boot partition of the previous install?

Edit: Does oc1/2 stand for Odriod C1/C2 ?? :sob:


Yeah xD
For rpi should be the


This will not work. You should use the rpi2 image for it.


Can you check if networkmanager is installed and if NetworkManager.service is running?


Sorry, I can kick myself for being so stupid.


It looks like networkmanager is not installed.

I created a new /etc/netctl/profile with nano

Then netctl start profile

I was able to pacman -Syu and update.

Now that networking is up I did attempt to install networkmanager and received a message that some packages should be upgraded first - manjaro-arm-keyring-20180509-1. I gave permition but received an error and was asked to run pacman-key --init followed by a bunch of other packages including networkmanager.

pacman-key --init seemed to pass, but now when I try to install networkmanager I get a message about the signature from “manjaro-ARM Build Server” being an unknown trust and /var/cache/pacman/pkg/manjaro-arm-keyring-20180509-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)). I’ve tried ignoring it and deleting it but can’t get past this point as installation always fails.


Does it mention what key is troublesome?

Did you also try running sudo pacman-key --populate manjaro-arm?


After a pacman -Syu I get a message for conflicting packages that lists “manjaro-arm-keyring-20180513-1”. Allowing install I get "error: manjaro-arm-keyring: signature from “Manjaro-ARM Build Server” is unknown trust. It also says “:: File /var/cache/pacman/pkg/manjaro-arm-keyring-20180513-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).” Attempting to delete gives "error: failed to commit transaction (invalid or corrupted package (PGP signature)).

The installer then goes into “::Starting full system upgrade”.

I had not previously attempted to run pacman-key --populate manjaro-arm, so I just did that. It locally signed a total of 8 keys, but it failed on the 3rd key DC3BF5444BD19FD6AA4CFBA46875B841CC37B7EC with the message “could not be locally signed”.


Yeah, It’s @dodgejcr’s key. No idea why it won’t sign it. I had a version where it was taken out, but since it does not really error and continues, I thought I should leave it in for troubleshooting.

The pacman-key --populate manjaro-arm command should have been run during image creation, but I guess it doesn’t really. :frowning:


I just re-read my previous post and realized I edited out a bit and I just wanted to be clear, the full system upgrade fails due to invalid signature as well. I’m fairly new to Manjaro, so please treat me like a clueless fool in the Linux world. I could be missing something completely obvious (to an average *nix user).


Let me see if I can remember all this.

Can you run sudo pacman-key --populate manjaro-arm?
Can you run sudo pacman -S manjaro-system?


the first command failed with the same messages as previous - unable to locally sign. The 2nd command however…

under the step “reinstalling manjaro-system” there were 2 errors.
dirmngr[407]: error opening ‘/root/.gnupg/dirmngr_ldapservers.conf’: No such file or directory
dirmngr[407.0]: failed to open cache dir file ‘/root/.gnupg/crls.d/DIR.txt’: No such file or directory

There was a message of 1 permanently loaded certificate.

Under the step “Get Manjaro ARM Build Server’s signature…”
gpg: key 70FBB189B338D5DF: 2 signatures not checked due to missing keys
gpg: key 70FBB189B338D5DF: “Manjaro-ARM Build Server” not changed
then a message of total processed 1, unchanged 1

Under step “Updating trust database”
gpg: next trustdb check due at 2018-06-01
then it locally signed key B338D5DF
then another message about next trustdb check.


This should have made it work now. That’s the build servers key.


@Strit Sorry boss. pacman -Syu is still giving me an error for an unknown trust. I did attempt to delete and redownload the packages to no avail. Not sure if any logs would be of use in the matter. I saw the /var/log/pacman.log does record some of this, but the fail messages aren’t being logged there.


@Strit I just found that you have SSH installed. Because I have networking up I can open up the port for you to SSH in and see for yourself. I just did a reflash to the original base image and re-enabled networking as I detailed previously so it’s ready to go.


No need for SSH, I believe you. :slight_smile:

I will try building a new package today, and sign it with my own key and upload it. The new package should then be available tomorrow. I’m at work now, so can’t really do anything here. :slight_smile:

EDIT: Got the updated package in the repo, and it installed/updated fine when I did a sudo pacman -Syyu on my test device. Still one “could not locally sign” message, but the package installed fine.


Just uploading an 18.06-rc2 for the Raspberry Pi’s now.

What image did you test?

What device did you test on?
Raspberry Pi 3 Model B

Does it boot to a CLI login prompt?

Can you login with both root and manjaro users?

Can you install/update packages?
Yes. Installed both wget (arch package) and inxi (manjaro package). Networking worked OOTB.

PS: Also the resize-sd script is now working.


What image did you test?

What device did you test on?
Raspberry Pi 3 Model B

Does it boot to a CLI login prompt?

Can you login with both root and manjaro users?

Can you install/update packages?
Yes - inxi (manjaro package).
No - wget (arch package).
error: wget: signature from “Arch Linux ARM Build System” is unknown trust.
I tried all the commands from posts above without success:

sudo pacman -S manjaro-system
sudo pacman-key --populate manjaro-arm 
sudo pacman-key --init

Thus also a No to update the system - same error.

On my first attempt to update, there was also a warning about the locale being empty. I see that /etc/locale.conf had an entry:
Should the format not be?
In any case, I changed it to LANG=en_ZA.UTF-8 and have not seen the warning since. (First edited locale.gen end ran locale-gen though.)

If I do systemctl status I see that both NetworkManager and systemd-networkd are running.
Which is doing the networking?
Should NetworkManager be installed on a minimal system?
(I would prefer not as I later use connman and then need to get rid of NetworkManager and its other associated services (but that is just me). )

I have not tried it because I used gparted on my workstation to maximize the partition - just after the image was transferred and before the SD was put into the RPi3B. This also seems to work.