Calibre: `Qt_5.15' not found, problems with python

I updated my system yesterday where calibre was upgraded to 5.0.1, I can see it changed python version from 2.x -> 3.x. However, something seems to be very broken!

Opening calibre from the terminal gives me this error:

[~] calibre
Traceback (most recent call last):
  File "/usr/bin/calibre", line 20, in <module>
    sys.exit(calibre())
  File "/usr/lib/calibre/calibre/gui_launch.py", line 73, in calibre
    main(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 529, in main
    app, opts, args = init_qt(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 114, in init_qt
    app = Application(args, override_program_name=override, windows_app_uid=MAIN_APP_UID)
  File "/usr/lib/calibre/calibre/gui2/__init__.py", line 885, in __init__
    raise RuntimeError('Failed to load the progress_indicator C extension, with error: {}'.format(pi_err))
RuntimeError: Failed to load the progress_indicator C extension, with error: /home/daniel/.local/lib/python3.8/site-packages/PyQt5/Qt/lib/libQt5Core.so.5: version `Qt_5.15' not found (required by /usr/lib/calibre/calibre/plugins/progress_indicator.so)

I then tried to search fro Qt5 but it looks like it could be a deeper problem, anyone who could help me out here?


[~] pip3 search qt5
Traceback (most recent call last):
  File "/usr/bin/pip3", line 33, in <module>
    sys.exit(load_entry_point('pip==20.1.1', 'console_scripts', 'pip3')())
  File "/usr/lib/python3.8/site-packages/pip/_internal/cli/main.py", line 73, in main
    command = create_command(cmd_name, isolated=("--isolated" in cmd_args))
  File "/usr/lib/python3.8/site-packages/pip/_internal/commands/__init__.py", line 104, in create_command
    module = importlib.import_module(module_path)
  File "/usr/lib/python3.8/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1014, in _gcd_import
  File "<frozen importlib._bootstrap>", line 991, in _find_and_load
  File "<frozen importlib._bootstrap>", line 975, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 671, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 783, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/usr/lib/python3.8/site-packages/pip/_internal/commands/search.py", line 18, in <module>
    from pip._internal.cli.req_command import SessionCommandMixin
  File "/usr/lib/python3.8/site-packages/pip/_internal/cli/req_command.py", line 16, in <module>
    from pip._internal.index.package_finder import PackageFinder
  File "/usr/lib/python3.8/site-packages/pip/_internal/index/package_finder.py", line 21, in <module>
    from pip._internal.index.collector import parse_links
  File "/usr/lib/python3.8/site-packages/pip/_internal/index/collector.py", line 16, in <module>
    from pip._vendor.requests.exceptions import HTTPError, RetryError, SSLError
ImportError: cannot import name 'RetryError' from 'requests.exceptions' (/home/daniel/.local/lib/python3.8/site-packages/requests/exceptions.py)

python lib installed by pacman (python-pyqt5, qt5-base,…) and not pip !
system use: /usr/lib/python3.8/site-packages/PyQt5 not file in home :wink:
you not use system python but a home version :thinking: loadded in a python venv ?

I had pyenv installed but I think I removed that

[~] python --version
Python 3.8.5
[~] which python
/usr/bin/python

forums . fedoraforum . org / showthread.php?323439-Calibre-doesn-t-start

" According to the authors website:

“Please do not use your distribution provided calibre package, as those are often buggy/outdated. Instead use the Binary install described below.”

So I uninstalled and reinstalled it using the authors procedure. Note that reinstalling Caliber via Fedora’s standard installation tools doesn’t work! "

So this worked for calibre! However this did not solve the pip issue, and I do now it is abd pratice to use pip.

we are in rolling :wink: your unstable version have 2 days !
i am not in instable but same version in my archlinux work well - it’s your python config

and I’m 100% sure of that! And I would really like to fix that, but I’m not sure where to begin.