Calamares not viewing disk as efi

I’m trying to install off of a live USB. I have a clean drive freshly formated w/ GPT. I believe Calamares is not detecting efi as I have the “Boot loader location” option at the bottom. Also the default erase disk does not create a efi partition.

I’ve tried manually partitioning but It keeps crashing when it tries to install the bootloader.

I tried to upload a screenshot of it but can’t upload links.
For more details, GPT does appear next to the drive in the installer

efibootmgr does not work at all for me. It just says efi variables are not set.

I wouldn’t be surprised if I broke some part of it as I’v been having issues setting up dual booting.

That means your system is booted in BIOS/GPT - which will work - but mandates a 1M unformatted partition flagged as Bios Boot (0xEF02) (Just learned that Calamares presents this as bios-grub - but it’s just the same)


If you want to dual boot, know that you need to have same method of installation (BIOS/MBR or EFI) for your Manjaro and other OS, if you want GRUB to detect and add the startup menu entry for the other OS (or else you would need to manually trigger a boot for one of the systems from within the BIOS menu or the BOOT menu if your motherboard has one).

1 Like

see this

recheck all options in your EFI

1 Like

your live USB should be made to work in EFI mode and not BIOS. easiest way around this is to create a ventoy disk in GPT mode using ; -i -g  /dev/sdX

and copy the manajaro iso into the data partion of the USB drive and reboot into it and choose manjaro in the list.

I don’t think you make a USB specific to EFI/MBR. The way you boot the USB though changes things.

from my understanding its both.

a MBR formatted bootable USB stick booted through EFI USB boot process would not make (atleast installer) work in EFI mode

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.