Calamares keeps crashing with my partition settings.

I am trying to install Manjaro 18.0.4 with a specific storage configuration: an encrypted btrfs root partition and a plaintext ext4 boot partition on an SSD (sda) and encrypted btrfs home and swap partitions on a mechanical hard drive (sdb). I also have a small third partition on the SSD with the bios-grub flag enabled which is where I assume the bios/efi boot data will be. I've tried both GPT and MBR partitions. I am using the manual partitioning feature on the

With these settings, the installation process manages to start and apply the changes to the disks, but at some point afterward the installer just goes back to the splash screen. At one point I got an error saying the grub installer exited with an error code but I can't reliably replicate this.

I am installing onto a virtualbox image at the moment to test the install process but I have it configured to have as similar a storage configuration to my target bare metal system as possible. I suspect the same problem will happen on bare metal.

What could be causing this, and how do I fix it so the installation can proceed?

Update: I managed to find a configuration that works for me, thanks to a commenter on Reddit. Here is what I did, though your mileage may vary.

  • Use MBR for both drives.

  • On the SSD, have one large encrypted ext4 partition (btrfs didn't work) with the mount point at /, and a second plaintext ext4 partition around 1 GB with no mount point and the flags boot and esp enabled.

  • On the hard drive, have one encrypted ext4 partition for /home and optionally one encrypted linuxswap partition with no mount point and the flag swap enabled.

This was the only thing that worked for me. I did some tests with slightly different configurations and everything else seemed to either crash the installer or fail to decrypt properly once installed. I'm really not sure why this works (maybe someone can comment on that), but seems to work without any problems with the exception that there is no boot screen. All the encrypted partitions show up as "luks" under lsblk, so I'm assuming encryption is taking place (please correct me if I'm wrong or could be wrong).

That is awesome! my reddit handle is actually theimpolitegentleman haha. given there is only me and OP responses on the reddit thread I assume that it is more than likely You anyway

My reddit ios app does a awful job of delivering notification time and time again, sorry for not getting to the thread again timely. That and going a bit into overtime with the crown this evening :hugs:

Cheers man and good luck

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.