Calamares install fails

calamares
network
network-manager
bug

#1

Few days ago I successfully installed Manjaro xfce but successfully ruined it. And decided to install Manjaro i3, checksum was right and there wasn’t any problems at start. But when installation went to mhwdcfg stage it freezes. Waited for 30min to if it would continue but it wont. As I have said it disconnects me from internet during “manjaro pci 0280 or 0200” and installs wrong network drivers. But this time it wont finish installation but stuck to 77%-78%.

Possible fixes for this:

  • Create “advanced mode” so user can select what mhwd drivers is installed
  • Create a checker for internet connection (if internet connection fails when mhwd network driver is installed it automatically removes that and goes backward previous state)
  • If installation is stuck in some point for set amount time it will skip it (This is pretty bad but in normal situation it should not take over 5min in any stage).

And yeah I know how to fix this if installation finishes.


[Unstable Update] 2018-05-18 - Kernels, Mesa, Xorg-server, Video drivers, Libinput, Gstreamer
Hardware configure bug
Trouble Installing, Stalls at 29%
#2

Please execute Calamares in Debug-Mode ( sudo -E calamares -d ), so we can check it. Also consider to use install medias with Calamares v3.0 series.


Installation stuck at "Configure the hardware"
My install is not starting
#3

Well can’t copy whole terminal info but last 4 lines are

12:15:29 [0]: Starting job "mhwdcfg"
12:15:29 [0]: Running "chroot" ("/tmp/calamares-root-0m96rjsa", "mhwd", "-a", "pci", "nonfree", "0200", "--pmconfig", "/opt/pacman-mhwd.conf")
12:15:31 [0]: Finished. Exit code:0
12:15:31 [0]: Running "chroot" ("/tmp/calamares-root-0m96rjsa", "mhwd", "-a", "pci", "nonfree", "0280", "--pmconfig", "/opt/pacman-mhwd.conf")

When I boot to livecd I have to choose nonfree because I have nvidia gtx 1080 and it wont boot on free.

At that point it disables Internet (installs wrong drivers) and wont go forward.
After that nothing, it freezes and wont move forward.

EDIT:
And looks like even clock freezes when install wrong drivers.


#4

I need the exact version of the used calamares.


#5

This is Calamares version: 2.4.3


#6

Found temporal fix for Calamares 2.4.3

I went to /usr/lib/calamares/modules/mhwdcfg/main.py and removed mhwd net related part at lines 84=>. And then I tried to install and it went without any problems.

Now booted on fresh install and no problems.

One more possible fix for calamares is not to install network drivers if network is working (or install same as live).


A start job is running for LiveMedia MHWD Script
Broadcom wifi fails to install
#7

I tried the solution from #6 (at least I think so) but, no dice. If possible, can you share the lines you removed? I would really love to get this working on my laptop.


#8

I had the same problem with the latest i3 ISO (17.0), with Calamares 3.1.0, on a Dell Latitude E6400 with a Broadcom BCM43228 wireless chip. Removing the net config lines from /usr/lib/calamares/modules/mhwdcfg/main.py worked; thanks a lot, amatrelan!

jaypeesmith, the lines I removed were

for id in self.identifier['net']:
                self.configure(b, id)

near the bottom of the file, in the run(self) method of the MhwdController class.


Installation stuck at "Configure the hardware"
Wird die Installation durchlaufen? Manjaro Linux 18.0-alpha-2 Illyria
#9

Many thanks, Jerrror! I’m going to try this later. I’m keeping my fingers crossed.


#10

Ah sorry didn’t specify better what lines. But Jerror show right ones.


#11

Hi, I just got the same trouble to install the kde version in my old Dell Inspiron and everything went ok.

However, when I tried the cinnamon version, the error continues (calamares freezes on the mhwdcfg - 75%). And, even if I edit the “main.py” file, the installation didn’t complete… I tried the calamares debug way and other stuff, but nothing works. KDE and CINNAMON works nicely with my pendrive boot device… Any suggestions about this??

Sorry for my bad english. I’m new at the language and at manjaro


#12

Seems there is a problem with automatic network driver installation here, not really the installer, @philm?


#13

I can confirm that the main.py workaround did not work for me in the Gnome edition, either. I did this on an MSI Gaming laptop (model GS63VR-6F) and it freezes on the “running mhwdcfg operation” step, every time.


#14

calmares refuses to load properly on this computer it starts then shuts down both xfce and kde yet on my asus all in one it works fine dvd works ok on this computer I have no idea whats going on
regards Ron


#15

Hi guys,

Just reporting: the same problem (calamares freezing at 75% - mhwdcfg) ocurred when I tried XFCE manjaro 17.0.1 version today. I tried CINNAMON, KDE, GNOME and XFCE with the latest versions (17.0.1) and no one could be installed.

As I said, I figured out the KDE installation (17.0) just following the amatrelan and Jerros tips, but the system crashed after an update… I have to say that the KDE got some problems to reboot and shutdown (but this also ocurred with other linux distros).

Another interesting thing: the pen drive boot ou DVD ISO never starts twice: alwayswhen I tried to start the system in a second time from the same pen drive or ISO DVD, the proccess stops after a while (infinite Starting Network Manager MHWD)

Well, this is what happens when I try manjaro OS on my old dell.

Best regards and thank you all for the support


#16

I got it to install today it crashed a couple of times then it installed no problem,all I did was update my bios again rebooted and started install heres my sudo -E calamares -d
manjaro@manjaro ~]$ sudo -E calamares -d
12:44:06 [1]: Calamares version: 3.1.0
Translation: Calamares: Using system locale: "en_US"
Translation: Qt: Using default locale, system locale one not found: "en_US"
12:44:06 [1]: Default font =====
Pixel size: -1
Point size: 10
Point sizeF: 10
Font family: "Noto Sans"
Metric height: 18
12:44:06 [1]: Font height: 18
12:44:06 [1]: Available languages: (“ar”, “ast”, “bg”, “ca”, “cs_CZ”, “da”, “de”, “el”, “en”, “en_GB”, “es_MX”, “es”, “eu”, “fr”, “hr”, “hu”, “id”, “is”, “it_IT”, “ja”, “lt”, “nl”, “pl”, “pt_BR”, “pt_PT”, “ro”, “ru”, “sk”, “sv”, “th”, “tr_TR”, “zh_CN”, “zh_TW”)
12:44:06 [1]: CalamaresApplication thread: 0x8c79d0
12:44:06 [1]: Using log file: "/home/manjaro/.cache/Calamares/Calamares/Calamares.log"
12:44:06 [1]: Using Calamares settings file at "/etc/calamares/settings.conf"
12:44:06 [1]: Using Calamares branding file at "/usr/share/calamares/branding/manjaro/branding.desc"
12:44:06 [1]: WARNING: the selected branding component does not ship translations.
12:44:06 [1]: Loaded branding component "manjaro"
12:44:06 [1]: STARTUP: initQmlPath, initSettings, initBranding done
12:44:06 [1]: STARTUP: initModuleManager: module init started
12:44:06 [1]: STARTUP: initModuleManager: all modules init done
12:44:06 [1]: STARTUP: initJobQueue done
12:44:06 [1]: Proposed window size: 1080 648
12:44:06 [1]: STARTUP: CalamaresWindow created; loadModules started
12:44:06 [1]: Initial locale "en_US"
12:44:06 [8]: Translation: Calamares: Using system locale: "en_US"
12:44:06 [8]: Translation: Qt: Using default locale, system locale one not found: “en_US"
12:44:06 [1]: ViewModule “welcome@welcome” loading complete.
12:44:06 [1]: WARNING: cannot acquire a list of available locales. The locale and localecfg modules will be broken as long as this system does not provide * a /usr/share/i18n/SUPPORTED file OR * a well-formed /etc/locale.gen OR * a complete pre-compiled locale-gen database which allows complete locale -a output.
12:44:06 [1]: ViewModule “locale@locale” loading complete.
12:44:06 [1]: ViewModule “keyboard@keyboard” loading complete.
12:44:06 [8]: Loaded backend plugin: “pmlibpartedbackendplugin"
12:44:06 [1]: ViewModule “partition@partition” loading complete.
12:44:06 [1]: ViewModule “users@users” loading complete.
12:44:06 [1]: ViewModule “summary@summary” loading complete.
12:44:06 [1]: Module “partition@partition” already loaded.
12:44:06 [1]: QML import paths: (”/usr/share/calamares/qml”, “/usr/bin”, “qrc:/qt-project.org/imports”, “/usr/lib/qt/qml”)
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: Module “locale@locale” already loaded.
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: Module “keyboard@keyboard” already loaded.
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: Module “users@users” already loaded.
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [0]: void Calamares::Module::loadConfigurationFile(const QString&) bad module configuration format "/usr/share/calamares/modules/umount.conf"
12:44:06 [1]: LAST VS IS EVS!
12:44:06 [1]: ViewModule “finished@finished” loading complete.
12:44:06 [1]: STARTUP: loadModules for all modules done
12:44:06 [1]: STARTUP: Window now visible and ProgressTreeView populated
12:44:06 [1]: Need at least storage bytes: 8482560409
12:44:07 [1]: Need at least ram bytes: 1073741824
12:44:07 [1]: enoughStorage, enoughRam, hasPower, hasInternet, isRoot: true true true true true
No layout variant specified on the command line
Trailing -variant option ignored
12:44:07 [1]: xkbmap selection changed to: “us” - ""
Segmentation fault
see what you guys can make of this
regards Ron
this was from same usb stick that kept crashing


#17

looks like manjaro architect is the way to go will test it later
yes used it to install works well
thanks Ron


#18

For me it wasn’t the net configuration in the mwhdcfg but the two video lines. I have an Alienware 13 R3 with Intel integrated and gtx 1060. Optimus of course.


#19

Helli there,
I also had to delete the lines in the main.py to move further. Now i am stuck at 93% in the state „misc postinstall confogurations“. The currently running task is:“ pacman-key —populate archlinux manjaro“. Nothing does happen.

See also the screen:

Help would be appriciated.

Btw. The manjaro archtect iso did work perfectly.


#20

Reported on GitHub.