Calamares error due to office choice... Manjaro-openbox issue


There is no errors when testing local and the office choice is not included.

The minimal ISO works as expected

There has been no errors aka installing office locally - so I am so confused.

Despite previous test in which I had no errors - I have been able to verify partly.

ADDED 2019-08-10T06:54:00Z
But only on the full ISO which will have to be caused by something else. Maybe the time inbetween because I only build the full ISO when I am satisfied with the minimal.

I have no idea what caused this - and I don't understand - I will investigate.

The error is caused when building the full ISO.

The tools used to build the ISO will include a non functional line in the calamares configuration cause Calamares to error out.

As shown by @philm editing the configuration on the ISO before launching Calamares installer will prevent the error.

Use sed

sudo sed -i '/officechooser/d' /etc/calamares/settings.conf

Or manually remove the line containg the text officechooser and save the file

sudo nao /etc/calamares/settings.conf

Press F2YEnter

New ISOs have been build and uploaded

Yes, it's a weird error. I can provide more info and screenshots if you want in a few days...

My guess: some unwanted update (config file?) sneeked into the ISO

Try updating calamares-git in the live session. This should fix the problem.
I'm afraid this release accidentally caught a bad commit in calamares development.

Alternatively installing regular calamares package instead should also work.

I have been checking with the team.

It seems to be an oversight from me building against stable when the stable calamares did not match.

I know this seems like a looked for answer - I don't know.

It will be fixed however - thank you for making me aware of it - it shouldn't have made it to stable.


Thanks a lot for the very quick response. Need to go now, will try in a few days. Thanx again!

The issue is with using manjaro-tools-git and not shipping packages as design on our development version.

Needs to be reverted locally when building the ISO.

I got the same problem.
I didn't understand if currently there something that can be done to proceed.

Thank you

We have to fix the ISO images. They shouldn't been released without testing them first ...


The thing is - the installer was thorough tested it worked.

When it works - building a full profile should work exactly as minimal - as the full iso is only adding packages - no extra installer experience.

The full ISO was the only suffering this error.

While I have taken it on me - the issue is lying in the tools - which changes behavior add other actions - than what is defined with the >extra tag - added.

The tools focus on the main editions KDE, XFCE, Gnome. Community editions should check with core-team what might had changed. Normally when keeping the Office suites as designed in, nothing would be broken. Anyway, we will try to make it more optional so also community editions can opt-out office suites if they want to.

Thank you :slight_smile:

To fix your current ISOs you should go to the x86_64/livefs/etc/calamares/settings.conf file and remove the officechooser entry when you had removed the office packages from iso-profiles/shared/Packages-Mhwd. This was also mentioned in all commits I did.

Currently full profiles ship freeoffice and libreoffice-still by default. To opt that out, you might need to revert at least that commit in tools. When you still have all build files on your PC a simply buildiso -p profilename -c would recreated that overlay and therefore fix your ISOs.

1 Like

Is this triggered by the buildiso -for the extra="true" in profile?

Because I have narrowed down the inclusion must have been triggered by that since the minimal ISO did not suffer.

We are currently in development phase. Yes, currently we trigger the installation via extra. So all full ISOs which are build via manjaro-tools-git enable the option in calamares-git based on our current iso-profiles-git. It works when you keep the default settings and notice the Warnings all over the commits we did so far. It was communicated thru all channels, that we have the OfficeChooser activated as a dependency for now and may work it out this weekend. Also it is clear to install each ISO before uploading at least on VM to spot those issues. Since now the ISO is out in the open, we may need to fix them fast.

I have an idea


# officechooser="true|false"
# if true use a list of officepackages adding to mhwd
# officepkgs=('freeoffice' 'libreoffice-still' 'libreoffice-fresh')
#officepkgs=('freeoffice' 'libreoffice-still')

Users who had downloaded the full ISO can start it like this:

sudo sed -i '/officechooser/d' /etc/calamares/settings.conf
sudo -E calamares -d

No, currently it is hardcoded and can't be used to add other packages than freeoffice and libreoffice-still. We might fix this in a later state.

1 Like

The solution offered by @philm worked perfectly -- much appreciated. I came here looking for a solution to this problem and I found one. What a rare treat.

1 Like

buenas noches chicos...

philm el comando que pusiste aqui no me funciono:

sudo sed -i '/officechooser/d' /etc/calamares/settings.conf
sudo -E calamares -d

pero este si:

sudo nano /etc/calamares/settings.conf

Eliminar >>> officechooser <<< CONTROL+O CONTROL+X

Os deseo un buen dia

pd: tambien me gusta openbox

Yes - It is also possible to edit manullay.

Forum kindly sponsored by Bytemark