Caffeine activates seemingly at random and cannot be disabled

I love the caffeine-ng app in GNOME, but recently it’s been activating seemingly at random. When I click “Disable Caffeine” it reactivates after a second or two. I’ve tried removing all processes from the “Automatic Activation” list in caffeine’s preferences, but the problem still persists. Any assistance would be appreciated.

1 Like

What’s the output of pamac list | grep caffeine?

:thinking:

1 Like

Thanks for the assist! The output of pamac list | grep caffeine is as follows:

caffeine-ng                               3.5.1-1                     community  447.0 kB

This is good. You have the community version:

Does this also happen if you create a new user and log in there? (E.G. professed2)

  • If no: give me a shout

  • If yes, try the following:

    pamac --orphans --no-save remove caffeine-ng
    pamac install cafeine-ng
    

:crossed_fingers:

When I create a new user and log in with that account, caffeine behaves as expected. So the problem appears specific to my current log-in.

1 Like

That said, logging out and logging back into my primary user account seems to have temporarily fixed the problem. This isn’t the first time it’s gone away, only to recur at some point. Which is annoying in itself. This feels like a car problem that goes away whenever you happen to bring it by the mechanic.

1 Like

Ack! Caffeine tripped on again. Still not sure what’s going on. Maybe it’s responding to some background process? But not sure how to figure out what it would be.

So??? Did you:

yet :question:

:grin:

I’m more familiar with pacman, so I ran pacman -Rs caffeine-ng and then reinstalled, but unfortunately that didn’t solve the problem.

Just to be sure, I tried again with the commands you suggested (had to rearrange the first, as remove has to come prior to the options for the command to run). Still no luck. Caffeine still activates on unbidden and reactivates soon after being disabled manually.

Thanks again for your help!

The commands I gave delete the config files too and your pacman command did not, so can you give the full list of all commands you ran because now I’m not certain that you did…

:man_shrugging:

… but pacman (deinstalling caffeine) will still not touch any existing user config
… perhaps this should be cleared explicitely as well
but I don’t know where that data is or if it can be deleted from within a session

I ran the commands you suggested…

pamac remove --orphans --no-save caffeine-ng
pamac install cafeine-ng

Still no luck. I also tried deleting the directory, ~/.config/caffeine and that didn’t work either.

1 Like

Seems like it’s related to this issue: https://github.com/caffeine-ng/caffeine-ng/issues/39

Running caffeine in terminal, I see:
INFO:caffeine.core:Audio playback detected (gst-launch-1.0, gst-launch-1.0). Inhibiting.

So, in my case, it’s probably caused by gst-launch-1.0.

2 Likes

Pretty sure you’re right! I’ve tried it a few times since seeing your message and each time I launch caffeine from the terminal, I get a similar “Inhibiting” message related to audio playback. But it’s not always the same app causing it — so far the messages have pertained to Brave, Firefox, and Teams. This despite these apps not actively playing audio at the time.

Edit: I should add that even though they’re not actually playing audio, they clearly are using the system’s audio settings — probably a holdover from when a video was actually played or a videoconference was actually happening. Going to the audio preferences panel in GNOME shows volume levels for the apps in question. So it looks as though the apps’ use of audio resources isn’t tied off when it should be.