Bumblebee Troubleshooting|20181229

bumblebee
kernel
laptop
nvidia
xorg
#1

Bumblebee Troubleshooting

Fix boot Manjaro on Laptop with Skylake CPU.

Follow this paste: https://gist.github.com/mauri870/5a54e415140875b9150ca31c491811f6 for DETAILS.

Edit /etc/default/grub and add to GRUB_CMDLINE_LINUX line:

acpi_osi=! acpi_osi="Windows 2009"

Save changes in file and run:

sudo update-grub

Reference:

Enable NVIDIA card after waking from suspend The bumblebee daemon may fail to activate the graphics card after suspending. A possible fix involves setting bbswitch as the default method for power management. Set PMMethod=bbswitch via command:
sudo sed -i "s/PMMethod=auto/PMMethod=bbswitch/" "/etc/bumblebee/bumblebee.conf"

Reboot.

Reference:

Fix OpenGL glxinfo tool Error: couldn't find RGB GLX visual or fbconfig Intel Xorg file /etc/X11/mhwd.d/intel.conf required additional code Section "OutputClass"
Section "OutputClass"
    Identifier "intel"
    ModulePath "/usr/lib/xorg/modules/extensions"
EndSection

Reboot.

Reference:

NVIDIA card does not launch at all Since lastest rebuild bumbebee package REQUIRED manually add user to bumblebee group via command:
sudo gpasswd -a $USER bumblebee

LOGOUT and LOGIN.

Reference:

https://forum.manjaro.org/t/60499

6 Likes
Tutorials Table Of Contents
ACPI error on boot - Nvidia/Intel hybrid BumbleBee
Black screen after installing video-nvidia-390xx
[TOC] Nvidia GPU related Tutorials
ACPI error on boot - Nvidia/Intel hybrid BumbleBee
[SOLVED] Bumblebee Issues with bbswitch
Bumblebee error - Could not enable discrete graphics card
Manjaro stuck after Grub
Nvidia drivers not working in fresh install
X1 extreme i5, so far I could not get bumblebee to work
Hardware Detection Issue
BBSwitch Non-functional on Dell Inspiron G5
Primusrun Games lag on Gnome + Bumblebee
Freeze after boot / system settings
Nvidia M150 Issues On Xiaomi Mi Notebook Pro
KDE interface really slow
Black Screen Cursor after install nvidia-390xx Cant probe gpu for any information without freeze(Optimus Laptop)
Nvidia GPU driver (bumblebee) doesn't install correctly
Did anyone installed drivers for Nvidia GTX1070?
Manjaro XFCE keeps getting stuck
No possibility to get Nvidia GT 610M working
#2

Also chime in here if acpi_osi=! acpi_osi="Windows 2009" is a useable default:

1 Like