Bumblebee Kurulumu


#1

Bumblebee kurulumu bir türlü beceremedim. Her kurup da yeniden başlattığımda açılırken sistem siyah ekranda kalıyor? Nasıl bir kurulum yolu izlersem bu sorunla karşılaşmam? (Şu anda sıfırdan kurulum yaptım hiç bir driver da kurmadan bekliyorum)


#2

Arch tabanlı dağıtımlarda bumblebee kurulum işlerini yaptıktan sonra diğer dağıtımlardaki gibi nvidia yapılandırmalarını içeren xorg.conf dosyası oluşturma yoluna gidiyor kullanıcılar. nvidia-xconfig uygulamasını kullanarak. Sistem de öntanımlı olarak nvidia ile açılmıyor tabi.

Aşağıdaki parametreler ile kurulum işlemlerini yapabilirsiniz.

sudo mhwd -i pci video-hybrid-intel-nvidia-bumblebee
sudo systemctl enable bumblebeed.service
sudo systemctl start bumblebeed.service
sudo gpasswd -a $USER bumblebee
reboot

bumblebee durumunu kontrol etmek için:

sudo systemctl status bumblebeed.service

Test etmek için:
optirun glxspheres64

Siz ya da başka bir kullanıcı sorun yaşarsa buraya geri bildirim yapabilirsiniz. Ya da yerel manjaro destek forumumuza yazabilirsiniz.


#3

Şu komutu çalıştırdığımda:

sudo systemctl status bumblebeed.service

Şu çıktıyı veriyor:

● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
   Active: active (running) since Mon 2018-10-08 12:02:00 +04; 11min ago
 Main PID: 475 (bumblebeed)
    Tasks: 1 (limit: 4633)
   Memory: 24.4M
   CGroup: /system.slice/bumblebeed.service
           └─475 /usr/bin/bumblebeed --use-syslog

Okt 08 12:02:00 nagual-pc systemd[1]: Started Bumblebee C Daemon.
Okt 08 12:02:01 nagual-pc bumblebeed[475]: /usr/bin/bumblebeed 3.2.1-2017-02-27-Format:%h$ started
Okt 08 12:05:10 nagual-pc bumblebeed[475]: Could not load GPU driver

Şu komut ise:

 optirun glxspheres64

Şu çıktıyı veriyor:

[  890.575321] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[  890.575369] [ERROR]Aborting because fallback start is disabled.

Sanırım bir şeyler eksik…


#4

4.19 çekirdeğini kullanmak sorunumu çözmüştü deneyebilirsin. Bumblebee de ısrarcı değilsen prime kurulumu anlatılan bi tutorial mevcut detaylı bir şekilde


#5

Ben genelde manjaro settings ile kuruyorum bumblebee’yi bende de kurduktan sonra siyah ekran veriyordu, sonradan öğrendim ki yeni sistemlerde gruba acpi_osi=! ve acpi_osi=“Windows 2009” kodlarını yazarak sorunu çözdüm. Linkte sizin bilgisayarınıza göre grub komutunu bulup editleyin.


#6

Yukarıdaki komutları sırasıyla uyguladım ve siyah ekrana düştüm.
Bu problemin çözümü için aşağıdaki komutları kullanabilirsiniz.
CTRL+ALT+F3
Terminale ulaştıktan sonra
$ sudo systemctl disable bumblebeed.service
Şu komut ile bumblebeed.service durumunu kontrol edelim.
$ sudo systemctl status bumblebeed.service
$ sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee