Bumblebee error - Could not enable discrete graphics card

inxi -Fx results

System:
Host: admin-pc Kernel: 4.19.0-3-MANJARO x86_64 bits: 64 compiler: gcc
v: 8.2.1 Desktop: KDE Plasma 5.14.2 Distro: Manjaro Linux
Machine:
Type: Laptop System: Dell product: Inspiron 7577 v: N/A
serial:
Mobo: Dell model: 0J8HMF v: A00 serial: UEFI: Dell
v: 1.2.0 date: 10/25/2017
Battery:
ID-1: BAT0 charge: 17.3 Wh condition: 47.1/56.0 Wh (84%)
model: LGC-LGC3.553 DELL 99NF279 status: Discharging
CPU:
Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP
arch: Kaby Lake rev: 9 L2 cache: 6144 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44944
Speed: 1100 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 1100
2: 1100 3: 1100 4: 1101 5: 1100 6: 1100 7: 1100 8: 1100
Graphics:
Device-1: Intel vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: N/A
bus ID: 01:00.0
Display: x11 server: X.Org 1.20.3 driver: intel
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
v: 4.5 Mesa 18.2.3 direct render: Yes
Audio:
Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel
v: kernel bus ID: 00:1f.3
Sound Server: ALSA v: k4.19.0-3-MANJARO
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Dell driver: r8168 v: 8.045.08-NAPI port: d000 bus ID: 3b:00.0
IF: enp59s0 state: down mac: a4:4c:c8:74:47:ab
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel
port: d000 bus ID: 3c:00.0
IF: wlp60s0 state: up mac: 28:c6:3f:f2:d0:af
Drives:
Local Storage: total: 1.14 TiB used: 8.74 GiB (0.7%)
ID-1: /dev/nvme0n1 vendor: Samsung model: PM961 NVMe 256GB
size: 238.47 GiB
ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172
size: 931.51 GiB
Partition:
ID-1: / size: 58.81 GiB used: 8.25 GiB (14.0%) fs: ext4 dev: /dev/dm-0
ID-2: /home size: 39.12 GiB used: 493.4 MiB (1.2%) fs: ext4
dev: /dev/dm-2
ID-3: swap-1 size: 17.10 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1
Sensors:
System Temperatures: cpu: 47.0 C mobo: 38.0 C sodimm: 37.0 C
Fan Speeds (RPM): cpu: 0
Info:
Processes: 230 Uptime: 13m Memory: 15.53 GiB used: 1.42 GiB (9.1%)
Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.27

the error I get when running any optirun command

[ 968.826246] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card
[ 968.826305] [ERROR]Aborting because fallback start is disabled.

systemctl status bumblebeed results

● bumblebeed.service - Bumblebee C Daemon
Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vend>
Active: active (running) since Mon 2018-10-29 05:55:22 EDT; 16min ago
Main PID: 563 (bumblebeed)
Tasks: 1 (limit: 4915)
Memory: 1.6M
CGroup: /system.slice/bumblebeed.service
└─563 /usr/bin/bumblebeed --use-syslog
Oct 29 05:55:22 admin-pc systemd[1]: Started Bumblebee C Daemon.
Oct 29 05:55:22 admin-pc bumblebeed[563]: /usr/bin/bumblebeed 3.2.1-2017-02->
Oct 29 05:55:44 admin-pc bumblebeed[563]: Could not enable discrete graphics>
Oct 29 05:56:51 admin-pc bumblebeed[563]: Could not enable discrete graphics>
Oct 29 06:11:14 admin-pc bumblebeed[563]: Could not enable discrete graphics>

What is mhwd -li showing?

>> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI


Warning: No installed USB configs!

You might want to check this, step by step and report back if is still not working

primusrun had the same error

primus: fatal: Bumblebee daemon reported: error: Could not enable discrete graphics card

and according to bbswitch, I am running the intel gpu

0000:01:00.0 OFF

the optirun commands had the same error

$ optirun --status
Bumblebee status: Error (3.2.1-2017-02-27-Format:%h$): Could not enable discrete graphics card

$ optirun -b none nvidia-settings -c :8
[21372.694353] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card

[21372.694424] [ERROR]Aborting because fallback start is disabled.

Did you checked this posts?

I added acpi_rev_override=1 and acpi_osi=! acpi_osi=“Windows 2009” to grub along with blacklist nouveau in /etc/modprobe.d/blacklist.conf

Now I have another error

$ optirun -b none nvidia-settings -c :8
[ 364.040104] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please

[ 364.040141] [ERROR]Aborting because fallback start is disabled.

$ systemctl status bumblebeed
● bumblebeed.service - Bumblebee C Daemon
Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vend>
Active: active (running) since Mon 2018-10-29 12:43:56 EDT; 7min ago
Main PID: 561 (bumblebeed)
Tasks: 1 (limit: 4915)
Memory: 22.3M
CGroup: /system.slice/bumblebeed.service
└─561 /usr/bin/bumblebeed --use-syslog

Oct 29 12:49:43 admin-pc bumblebeed[561]: [XORG] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
Oct 29 12:49:43 admin-pc bumblebeed[561]: [XORG] (EE) NVIDIA(0): Failing initialization of X screen 0
Oct 29 12:49:43 admin-pc bumblebeed[561]: [XORG] (EE) Screen(s) found, but none have a usable configuration.
Oct 29 12:49:43 admin-pc bumblebeed[561]: [XORG] (EE)
Oct 29 12:49:43 admin-pc bumblebeed[561]: [XORG] (EE) no screens found(EE)
Oct 29 12:49:43 admin-pc bumblebeed[561]: [XORG] (EE)
Oct 29 12:49:43 admin-pc bumblebeed[561]: [XORG] (EE) Please also check the log file at “/var/log/Xorg.8.log” for additional information.
Oct 29 12:49:43 admin-pc bumblebeed[561]: [XORG] (EE)
Oct 29 12:49:43 admin-pc bumblebeed[561]: [XORG] (EE) Server terminated with error (1). Closing log file.
Oct 29 12:49:43 admin-pc bumblebeed[561]: X did not start properly

/var/log/Xorg.8.log

[ 359.396]
X.Org X Server 1.20.3
X Protocol Version 11, Revision 0
[ 359.396] Build Operating System: Linux Arch Linux
[ 359.396] Current Operating System: Linux admin-pc 4.19.0-3-MANJARO #1 SMP PREEMPT Sat Oct 27 22:40:22 UTC 2018 x86_64
[ 359.396] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID=f89766f9-0bf4-43d8-830a-7bb4164ad304 rw quiet cryptdevice=UUID=faf17555-5053-42ab-8969-ba90863ae870:luks-faf17555-5053-42ab-8969-ba90863ae870 root=/dev/mapper/luks-faf17555-5053-42ab-8969-ba90863ae870 resume=/dev/mapper/luks-faf17555-5053-42ab-8969-ba90863ae870 acpi_rev_override=1 acpi_osi=! “acpi_osi=Windows 2009”
[ 359.396] Build Date: 25 October 2018 04:42:32PM
[ 359.396]
[ 359.396] Current version of pixman: 0.34.0
[ 359.396] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 359.396] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 359.396] (==) Log file: “/var/log/Xorg.8.log”, Time: Mon Oct 29 12:49:39 2018
[ 359.397] (++) Using config file: “/etc/bumblebee/xorg.conf.nvidia”
[ 359.397] (++) Using config directory: “/etc/bumblebee/xorg.conf.d”
[ 359.397] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
[ 359.397] (==) ServerLayout “Layout0”
[ 359.397] (==) No screen section available. Using defaults.
[ 359.397] (
) |–>Screen “Default Screen Section” (0)
[ 359.397] () | |–>Monitor “”
[ 359.397] (==) No device specified for screen “Default Screen Section”.
Using the first device section listed.
[ 359.397] (
) | |–>Device “Device1”
[ 359.397] (==) No monitor specified for screen “Default Screen Section”.
Using a default monitor configuration.
[ 359.397] () Option “AutoAddDevices” “false”
[ 359.397] (
) Not automatically adding devices
[ 359.397] (==) Automatically enabling devices
[ 359.397] (==) Automatically adding GPU devices
[ 359.397] (==) Automatically binding GPU devices
[ 359.397] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 359.397] (WW) The directory “/usr/share/fonts/OTF” does not exist.
[ 359.397] Entry deleted from font path.
[ 359.397] (WW) The directory “/usr/share/fonts/Type1” does not exist.
[ 359.397] Entry deleted from font path.
[ 359.397] (WW) fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi". [ 359.397] Entry deleted from font path. [ 359.397] (Run 'mkfontdir' on "/usr/share/fonts/100dpi"). [ 359.397] (WW)fonts.dir’ not found (or not valid) in “/usr/share/fonts/75dpi”.
[ 359.397] Entry deleted from font path.
[ 359.397] (Run ‘mkfontdir’ on “/usr/share/fonts/75dpi”).
[ 359.397] (==) FontPath set to:
/usr/share/fonts/misc,
/usr/share/fonts/TTF
[ 359.397] (++) ModulePath set to “/usr/lib/nvidia/xorg,/usr/lib/xorg/modules”
[ 359.397] (==) |–>Input Device “”
[ 359.397] (==) |–>Input Device “”
[ 359.397] (==) The core pointer device wasn’t specified explicitly in the layout.
Using the default mouse configuration.
[ 359.397] (==) The core keyboard device wasn’t specified explicitly in the layout.
Using the default keyboard configuration.
[ 359.397] (II) Module ABI versions:
[ 359.397] X.Org ANSI C Emulation: 0.4
[ 359.397] X.Org Video Driver: 24.0
[ 359.397] X.Org XInput driver : 24.1
[ 359.397] X.Org Server Extension : 10.0
[ 359.398] (–) using VT number 1

[ 359.398] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[ 359.399] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 359.399] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
[ 359.401] (–) PCI:*(1@0:0:0) 10de:1c20:1028:0802 rev 161, Mem @ 0xdc000000/16777216, 0xb0000000/268435456, 0xc0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x???/524288
[ 359.401] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 359.401] (II) LoadModule: “glx”
[ 359.401] (II) Loading /usr/lib/nvidia/xorg/libglx.so
[ 359.405] (II) Module glx: vendor=“NVIDIA Corporation”
[ 359.405] compiled for 4.0.2, module version = 1.0.0
[ 359.405] Module class: X.Org Server Extension
[ 359.405] (II) NVIDIA GLX Module 410.73 Sat Oct 20 22:16:49 CDT 2018
[ 359.405] (II) LoadModule: “nvidia”
[ 359.405] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 359.406] (II) Module nvidia: vendor=“NVIDIA Corporation”
[ 359.406] compiled for 4.0.2, module version = 1.0.0
[ 359.406] Module class: X.Org Video Driver
[ 359.406] (II) LoadModule: “mouse”
[ 359.406] (II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
[ 359.406] (II) Module mouse: vendor=“X.Org Foundation”
[ 359.406] compiled for 1.20.0, module version = 1.9.3
[ 359.406] Module class: X.Org XInput Driver
[ 359.406] ABI class: X.Org XInput driver, version 24.1
[ 359.406] (II) LoadModule: “kbd”
[ 359.406] (II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
[ 359.406] (II) Module kbd: vendor=“X.Org Foundation”
[ 359.406] compiled for 1.19.0, module version = 1.9.0
[ 359.406] Module class: X.Org XInput Driver
[ 359.406] ABI class: X.Org XInput driver, version 24.1
[ 359.406] (II) NVIDIA dlloader X Driver 410.73 Sat Oct 20 22:19:41 CDT 2018
[ 359.406] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 359.406] (II) Loading sub module “fb”
[ 359.406] (II) LoadModule: “fb”
[ 359.406] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 359.406] (II) Module fb: vendor=“X.Org Foundation”
[ 359.406] compiled for 1.20.3, module version = 1.0.0
[ 359.406] ABI class: X.Org ANSI C Emulation, version 0.4
[ 359.406] (II) Loading sub module “wfb”
[ 359.406] (II) LoadModule: “wfb”
[ 359.406] (II) Loading /usr/lib/xorg/modules/libwfb.so
[ 359.407] (II) Module wfb: vendor=“X.Org Foundation”
[ 359.407] compiled for 1.20.3, module version = 1.0.0
[ 359.407] ABI class: X.Org ANSI C Emulation, version 0.4
[ 359.407] (II) Loading sub module “ramdac”
[ 359.407] (II) LoadModule: “ramdac”
[ 359.407] (II) Module “ramdac” already built-in
[ 359.407] (II) NVIDIA(0): Creating default Display subsection in Screen section
“Default Screen Section” for depth/fbbpp 24/32
[ 359.407] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[ 359.407] (==) NVIDIA(0): RGB weight 888
[ 359.407] (==) NVIDIA(0): Default visual is TrueColor
[ 359.407] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 359.407] () NVIDIA(0): Option “UseEDID” “false”
[ 359.407] (
) NVIDIA(0): Option “ConnectedMonitor” “DFP”
[ 359.407] () NVIDIA(0): Enabling 2D acceleration
[ 359.407] (
) NVIDIA(0): ConnectedMonitor string: “DFP”
[ 359.407] (**) NVIDIA(0): Ignoring EDIDs
[ 364.038] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please
[ 364.038] (EE) NVIDIA(GPU-0): check your system’s kernel log for additional error
[ 364.038] (EE) NVIDIA(GPU-0): messages and refer to Chapter 8: Common Problems in the
[ 364.038] (EE) NVIDIA(GPU-0): README for additional information.
[ 364.038] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[ 364.038] (EE) NVIDIA(0): Failing initialization of X screen 0
[ 364.038] (II) UnloadModule: “nvidia”
[ 364.038] (II) UnloadSubModule: “wfb”
[ 364.038] (II) UnloadSubModule: “fb”
[ 364.038] (EE) Screen(s) found, but none have a usable configuration.
[ 364.038] (EE)
Fatal server error:
[ 364.038] (EE) no screens found(EE)
[ 364.038] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 364.038] (EE) Please also check the log file at “/var/log/Xorg.8.log” for additional information.
[ 364.038] (EE)
[ 364.038] (EE) Server terminated with error (1). Closing log file.

Can i see the output of:
cat -e /etc/X11/xorg.conf.d/*.*

$ cat -e /etc/X11/xorg.conf.d/*.* 
# Read and parsed by systemd-localed. It's probably wise not to edit this file$
# manually too freely.$
Section "InputClass"$
        Identifier "system-keyboard"$
        MatchIsKeyboard "on"$
        Option "XkbLayout" "us"$
        Option "XkbModel" "pc105"$
EndSection$
##$
## Generated by mhwd - Manjaro Hardware Detection$
##$
 $
 $
Section "Device"$
    Identifier  "Device0"$
    Driver      "intel"$
    BusID       "PCI:0:2:0"$
    Option      "AccelMethod" "sna"$
        Option      "DRI"    "true"$
EndSection$
 $
 $
Section "DRI"$
        Group  "video"$
        Mode   0666$
EndSection$
 $
 $
Section "Extensions"$
    Option "Composite" "Enable"$
    Option "RENDER"    "Enable"$
EndSection$
 $
 $
Section "InputClass"$
    Identifier          "Keyboard Defaults"$
    MatchIsKeyboard        "yes"$
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"$
EndSection$
 $

Please make sure you copy and paste the exact command i gave you. It seems you missed the *.* at the end …
Also … can you use ``` above and bellow the text?
It will make it look like this:

Section "OutputClass"
    Identifier "intel"
    ModulePath "/usr/lib/xorg/modules/extensions"
EndSection

Also let’s see what you have in:
cat -e /etc/bumblebee/*.*

Or you can see this post also, where there is a fix even tho is for GTX 1050

Please use proper formatting to make it readable

1 Like

I did do the command, I just used improper formatting as petsam said.

Too many dollars!!
You may be rich, though you don’t need to show off all the time! :rofl:

1 Like

Reading about bumblebee made my head spin … it seems that for each newer GPU combination, the tweaks have to be made manually … Sadly i don’t have any dual GPU system to test and play, so i can only read and give hints. This is another hint and it seems is the same model as yours.

:smiley: i think that was my mistake when i put -e in the command i gave :rofl:

1 Like

Reading about bumblebee made my head spin

Tell me about it…

I may just revert the changes, uninstall the proprietary driver, and reinstall the free driver…

There was a similar upstream issue reported in Arch for your laptop (Dell Inspiron 7577) and bumblebee is working for them.

https://bbs.archlinux.org/viewtopic.php?id=237423

So bumblebee works on your hardware, just have to work out why it fails on your system.

When you installed bumblebee did you remove the free driver first, nvidia may be clashing with nouveau if not.

If you actually want to use the nvidia gpu for anything meaningful then the free driver is next to useless performance wise.

Have you followed this method?
https://wiki.archlinux.org/index.php/Bumblebee#.5BERROR.5DCannot_access_secondary_GPU:_No_devices_detected

I found this, I have the same problem and the same outputs, more late I will try this https://github.com/Bumblebee-Project/Bumblebee/issues/997

Hi,

Try to do next:

  1. Add nouveau.modeset=0 to kernel boot params
  2. Reinstall bumblebee drivers

Anyway this steps has been nice for me:

I have reinstalled Linux on my laptop a lot times and the above options always works for me with KDE and Gnome.
Eventually I tired and now I have both systems:
Windows for games
Linux for work
Believe, it's better than try to play in Linux currently now :slight_smile:

I don't know why, but I'm feeling that Linux will be nice for gaming too after 2-4 years
Currently now Wine able to work with Proton as a proxy for DirectX with Nvidia drivers only (without Intel or hybryd).
And as I know even Microsoft supports Wine, there just one issue - Bumblebee not working with Proton as you expecting or not working definitely.

Yes, and another stuff:
If you unable to run some apps with bumblebee -b none nvidia-settings -c :8, then try to use primusrun.

Good luck!

I think I ran into the same issue with my new Dell XPS 15 7590 laptop containing an NVIDIA GeForce GTX 1650 (I believe).

[ +47.089718] bbswitch: enabling discrete graphics
[  +0.019426] pci 0000:01:00.0: Refused to change power state, currently in D3
[  +0.060558] pci 0000:01:00.0: Refused to change power state, currently in D3
[Jan10 07:26] IPMI message handler: version 39.2
[  +0.006056] ipmi device interface
[  +0.132843] nvidia: module license 'NVIDIA' taints kernel.
[  +0.000007] Disabling lock debugging due to kernel taint
[  +0.017442] nvidia-nvlink: Nvlink Core is being initialized, major device number 237
[  +0.000343] NVRM: The NVIDIA GPU 0000:01:00.0
              NVRM: (PCI ID: 10de:1f91) installed in this system has
              NVRM: fallen off the bus and is not responding to commands.
[  +0.000008] nvidia: probe of 0000:01:00.0 failed with error -1
[  +0.000011] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  +0.000000] NVRM: None of the NVIDIA graphics adapters were initialized!
[  +0.031278] nvidia-nvlink: Unregistered the Nvlink Core, major device number 237

UPDATE: The nouveau.modeset=0 kernel parameter didn't change the issue for me.
I'll try this guide next.

Forum kindly sponsored by