Builtin webcam not working

I have Thinkpad X260 and I am running Manjaro KDE. After the recent stable-update, the builtin webcam stopped working.

For instance, when I open google meet or zoom, even in the settings page (of each application) and in the actual calls, the webcam does not work, That is, no image is seen. (When I activate a video-call or goto the settings (of zoom or google-meet) and click on camera, the yellow-led beside the webcam light-ups, but immediately goes off.)

Can anyone please help me in resolving this? I need this to work to take classes.

Below is hardware configuration of the builtin webcam (got through hwinfo)

36: USB 00.1: 0000 Unclassified device
  [Created at usb.122]
  Unique ID: QR8P.kAMoKBekwz0
  Parent ID: k4bc.2DFUsyrieMD
  SysFS ID: /devices/pci0000:00/0000:00:14.0/usb1/1-8/1-8:1.1
  SysFS BusID: 1-8:1.1
  Hardware Class: unknown
  Model: "Chicony Electronics Integrated Camera"
  Hotplug: USB
  Vendor: usb 0x04f2 "Chicony Electronics Co., Ltd"
  Device: usb 0xb52c "Integrated Camera"
  Revision: "0.29"
  Serial ID: "0001"
  Driver: "uvcvideo"
  Driver Modules: "uvcvideo"
  Speed: 480 Mbps
  Module Alias: "usb:v04F2pB52Cd0029dcEFdsc02dp01ic0Eisc02ip00in01"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #39 (Hub)

Please see this and report back your findings:

Have you tried reloading of the uvcvideo module ?

From terminal:
sudo rmmod uvcvideo && sudo modprobe uvcvideo

@bogdancovaciu — tried reloading the module through the commands you suggested. But did not help. (I did not restart the system; just ran the command you gave and tried.)

Thanks for providing suggestions. Is there anything else I can try?

Yes, you can try to use ‘vlc’ or another player, as explained in the wiki from the link i shared, and you can report back any findings. If you get stuck, you can ask us here what to do next.

@bogdancovaciu — Thanks for suggesting. I did try with other applications; same result — webcam not working.

Also, in the link you shared, apart from these, there is few options to get the info of the webcam. Apart from these two, there is no other debugging options or suggestions.

Given this, is there anything else that I can try? I can shift to the older lts-kernel (currently I am using 5.4.)

But what is the output of
v4l2-ctl --list-devices
We have to make sure is video1 or video0 or something else.


Este texto estará oculto

Hello! I have the same problem and the same result of the commands suggested above.
The output of v4l2-ctl --list-devices is “Cannot open device /dev/video0, exiting.”
if i run $ dmesg | tail:
[ 5552.705977] uvcvideo: Found UVC 1.00 device USB2.0 VGA UVC WebCam (13d3:5a01)
[ 5552.710448] uvcvideo 1-4:1.0: Entity type for entity Extension 4 was not initialized!
[ 5552.710455] uvcvideo 1-4:1.0: Entity type for entity Processing 2 was not initialized!
[ 5552.710460] uvcvideo 1-4:1.0: Entity type for entity Camera 1 was not initialized!
[ 5552.710727] input: USB2.0 VGA UVC WebCam: USB2.0 V as /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.0/input/input22


@bogdancovaciu — I had mentioned this in the other thread.

So, below is the output for the command

[werunom@thinkpad ~]$ v4l2-ctl --list-devices
Droidcam (platform:v4l2loopback_dc-000):

Integrated Camera: Integrated C (usb-0000:00:14.0-8):

(As a temporary workaround, I installed droidcam. that is why you see that also in the output.)

Anyways, looks like this problem is not related to an isolated problem. Given that 3 people have it, looks like the recent update broke something :frowning:

Hello. thanks for answering. I think I have found a possible solution.
After doing a lot of googling I discovered that the problem with my integrated webcam is that it has poor compatibility with the uvcvideo driver.
However, a few days ago I decided to enter a new udev rule, based on this wiki https://wiki.archlinux.org/index.php/Udev#udev_rule_example.

First i need to find out my device attributes, executing::

$ udevadm info -a -n [device name]

In my case the [device name] is /dev/video0. It is important to find the IDs of the device, 'ATTRS {idVendor} == “0000”, ATTRS {idProduct} == “0000”

My rule “/etc/udev/rules.d/83-webcam.rules” is:

KERNEL == “1-4”, SUBSYSTEM == “video4linux”, SUBSYSTEMS == “usb”, ATTRS {idVendor} == “13d3”, ATTRS {idProduct} == “5a01”, SYMLINK + = “webcam”, OWNER = “neurus”, GROUP = “video”, MODE = “0660”

I cannot guarantee that it is the solution. For now it worked.
Sorry for my English, I used google translator.

I have an update — found last night that the webcam is working fine. I think the latest stable update fixed the issue.

@Neurus — thanks for pointing your suggestion.

Apart from that, what also helped me was Droidcam. This app helps in using your smartphone camera. This can be very helpful in case suddenly the laptop webcam does not function.

(I am closing this thread now.)

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.