Built-in microphone has sound/recording quality

Built-in mic picks up noise from laptop and I believe it also picks up echos.
Recording from external mic sound fine. And built-in mic also sounds fine when using windows.

Sound devices:

**** List of CAPTURE Hardware Devices ****
card 2: Generic_1 [HD-Audio Generic], device 0: ALC285 Analog [ALC285 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 3: Device [USB PnP Audio Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Full system Information:

 inxi --full --verbosity=7 --filter --no-host                                                                                                                                        ✔ 
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LANG = "en_IN"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System:
  Kernel: 5.15.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: ROG Strix G713QM_G713QM v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: G713QM v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: G713QM.314 date: 09/03/2021
Battery:
  ID-1: BAT0 charge: 55.9 Wh (62.0%) condition: 90.2/90.0 Wh (100.2%)
    volts: 15.8 min: 15.9 model: AS3GWAF3KC GA50358 type: Li-ion
    serial: <filter> status: N/A
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 2S
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: Discharging
Memory:
  RAM: total: 15.12 GiB used: 2.87 GiB (19.0%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: 8-core model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64
    type: MT MCP smt: enabled arch: Zen 3 rev: 0 cache: L1: 512 KiB L2: 4 MiB
    L3: 16 MiB
  Speed (MHz): avg: 1227 high: 1397 min/max: 1200/4462 boost: enabled
    cores: 1: 1397 2: 1397 3: 1197 4: 1197 5: 1266 6: 1183 7: 1297 8: 1274
    9: 1268 10: 1135 11: 1179 12: 1135 13: 1135 14: 1191 15: 1197 16: 1197
    bogomips: 102240
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists erms extapic
    extd_apicid f16c flushbyasid fma fpu fsgsbase fsrm fxsr fxsr_opt ht
    hw_pstate ibpb ibrs ibs invpcid irperf lahf_lm lbrv lm mba mca mce
    misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt
    nrip_save nx ospke osvw overflow_recov pae pat pausefilter pclmulqdq
    pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pku pni
    popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep
    sha_ni skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3
    stibp succor svm svm_lock syscall tce topoext tsc tsc_scale umip
    v_spec_ctrl v_vmsave_vmload vaes vgif vmcb_clean vme vmmcall vpclmulqdq
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
Graphics:
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK
    driver: nvidia v: 495.44 bus-ID: 01:00.0 chip-ID: 10de:2520 class-ID: 0300
  Device-2: AMD Cezanne vendor: ASUSTeK driver: amdgpu v: kernel
    bus-ID: 05:00.0 chip-ID: 1002:1638 class-ID: 0300
  Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
    loaded: modesetting,nvidia resolution: 1920x1200~60Hz s-dpi: 96
  OpenGL: renderer: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2
    v: 4.6.0 NVIDIA 495.44 direct render: Yes
Audio:
  Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 05:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-3: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
    vendor: ASUSTeK driver: N/A bus-ID: 05:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-4: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Device-5: JMTek LLC. USB PnP Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-2.3:6 chip-ID: 0c76:1620
    class-ID: 0300
  Sound Server-1: ALSA v: k5.15.7-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: no
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel port: e000 bus-ID: 02:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 03:00.0
    chip-ID: 8086:2723 class-ID: 0280
  IF: wlp3s0 state: down mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-4:5 chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 5.89 TiB used: 1.48 TiB (25.2%)
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM512GD3JX013N
    size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 41000C20 temp: 31.9 C scheme: GPT
  ID-2: /dev/sda type: USB vendor: Western Digital
    model: WD My Passport 2627 size: 3.64 TiB type: N/A serial: <filter>
    rev: 4008 scheme: GPT
  ID-3: /dev/sdb type: USB vendor: Western Digital
    model: WDS480G2G0A-00JH30 size: 447.14 GiB type: SSD serial: <filter>
    scheme: GPT
  ID-4: /dev/sdc type: USB vendor: Lenovo model: USB Hard Drive
    size: 931.51 GiB type: N/A serial: <filter> rev: 3U scheme: GPT
  ID-5: /dev/sdd type: USB vendor: Western Digital
    model: WDS480G2G0A-00JH30 size: 447.13 GiB type: SSD serial: <filter>
    scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / size: 422.37 GiB used: 73.28 GiB (17.3%) fs: ext4 dev: /dev/sdd2
    label: N/A uuid: 581c79c3-b5ca-4ee2-9d67-c226c64d502f
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
    dev: /dev/sdd1 label: NO_LABEL uuid: 75B0-09E2
  ID-3: /media/aurora/fastlinuxmedia size: 48.61 GiB used: 40.5 GiB (83.3%)
    fs: ext4 dev: /dev/sdb2 label: linuxdata
    uuid: 3d658ccb-7e50-40f4-82dc-e0c74b3a2143
  ID-4: /media/aurora/fastmedia size: 397.24 GiB used: 270.82 GiB (68.2%)
    fs: ntfs dev: /dev/sdb1 label: fastDATA_1 uuid: 42D6C57FD6C57427
  ID-5: /media/aurora/media size: 2.66 TiB used: 1.1 TiB (41.4%) fs: ntfs
    dev: /dev/sda1 label: Data4TB uuid: 3CBAA0BDBAA07554
  ID-6: /media/aurora/network size: 991.12 GiB used: 784.41 GiB (79.1%)
    fs: cifs dev: /dev/networkStorage
  ID-7: /media/aurora/slowlinuxmedia size: 47.06 GiB used: 5.01 GiB (10.6%)
    fs: ext4 dev: /dev/sda2 label: slowDatalinux
    uuid: a7749fa2-dbf5-4cdd-bfa3-6c32a947f6f3
Swap:
  ID-1: swap-1 type: partition size: 16.64 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sdd3 label: N/A
    uuid: ae036e38-c2e4-4d71-ac66-4cfc9e1b4d52
Unmounted:
  ID-1: /dev/nvme0n1p1 size: 260 MiB fs: vfat label: SYSTEM uuid: C839-BD33
  ID-2: /dev/nvme0n1p2 size: 16 MiB fs: <superuser required> label: N/A
    uuid: N/A
  ID-3: /dev/nvme0n1p3 size: 456.24 GiB fs: ntfs label: OS
    uuid: 48103B67103B5B60
  ID-4: /dev/nvme0n1p4 size: 750 MiB fs: ntfs label: RECOVERY
    uuid: FCE20CA0E20C616E
  ID-5: /dev/nvme0n1p5 size: 19.5 GiB fs: ntfs label: RESTORE
    uuid: C8D2C855D2C84A00
  ID-6: /dev/nvme0n1p6 size: 200 MiB fs: vfat label: MYASUS uuid: F0C8-80F8
  ID-7: /dev/sdc1 size: 931.51 GiB fs: ext4 label: N/A
    uuid: f8be4f07-2be3-446f-be1d-0ba2be4b50f8
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: ASUSTek N-KEY Device type: Keyboard
    driver: asus,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 0b05:1866 class-ID: 0301
  Hub-2: 2-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-1:2 info: Western Digital My Passport 2627 type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 3.1 speed: 5 Gb/s power: 896mA
    chip-ID: 1058:2627 class-ID: 0806 serial: <filter>
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 3-1:2 info: Genesys Logic Hub ports: 4 rev: 2.1 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0610 class-ID: 0900
  Hub-5: 3-1.2:4 info: Terminus Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 1a40:0101 class-ID: 0900
  Device-1: 3-1.2.1:7 info: Logitech Unifying Receiver
    type: Keyboard,Mouse,HID driver: logitech-djreceiver,usbhid interfaces: 3
    rev: 2.0 speed: 12 Mb/s power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Device-2: 3-1.2.2:9 info: SINO WEALTH Gaming KB type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s
    power: 500mA chip-ID: 258a:002a class-ID: 0300
  Hub-6: 3-2:3 info: VIA Labs VL813 Hub ports: 4 rev: 2.1 speed: 480 Mb/s
    chip-ID: 2109:2813 class-ID: 0900
  Device-1: 3-2.3:6 info: JMTek LLC. USB PnP Audio Device type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 1.1
    speed: 12 Mb/s power: 100mA chip-ID: 0c76:1620 class-ID: 0300
  Device-2: 3-2.4:8 info: HP LaserJet M1005 MFP type: Printer driver: usblp
    interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 98mA chip-ID: 03f0:3b17
    class-ID: 0701 serial: <filter>
  Device-3: 3-4:5 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029
    class-ID: e001
  Hub-7: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-8: 4-1:2 info: Genesys Logic Hub ports: 4 rev: 3.1 speed: 5 Gb/s
    chip-ID: 05e3:0612 class-ID: 0900
  Device-1: 4-1.1:4 info: Lenovo Portable HDD type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s power: 8mA
    chip-ID: 17ef:455a class-ID: 0806 serial: <filter>
  Device-2: 4-1.3:5 info: ASMedia ASM1051E SATA 6Gb/s bridge ASM1053E SATA
    6Gb/s bridge ASM1153 SATA 3Gb/s bridge ASM1153E SATA 6Gb/s bridge
    type: Mass Storage driver: uas interfaces: 1 rev: 3.0 speed: 5 Gb/s
    chip-ID: 174c:55aa class-ID: 0806 serial: <filter>
  Device-3: 4-1.4:6 info: ASMedia ASM1051E SATA 6Gb/s bridge ASM1053E SATA
    6Gb/s bridge ASM1153 SATA 3Gb/s bridge ASM1153E SATA 6Gb/s bridge
    type: Mass Storage driver: uas interfaces: 1 rev: 3.0 speed: 5 Gb/s
    chip-ID: 174c:55aa class-ID: 0806 serial: <filter>
  Hub-9: 4-2:3 info: VIA Labs VL813 Hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 2109:0813 class-ID: 0900
Sensors:
  System Temperatures: cpu: 44.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
  GPU: device: nvidia screen: :0.0 temp: 39 C device: amdgpu temp: 44.0 C
Info:
  Processes: 390 Uptime: 39m wakeups: 7 Init: systemd v: 249 Compilers:
  gcc: 11.1.0 alt: 10 clang: 13.0.0 Packages: 1789 pacman: 1784 flatpak: 5
  Shell: Zsh v: 5.8 running-in: konsole inxi: 3.3.11

I tried changing sampling rate in /etc/pulse/daemon.conf and setting echo/noise cancellation in /etc/pulse/default.pa. Sampling did nothing and the echo cancellation was not applies to the built-in mic, but rather the external mic.

Thanks for the help!

AMD Ryzen systems have an Audio Co-Processor to support the internal digital microphone array
System data is showing the ACP device but it does not have the correct driver snd_pci_acp3x or snd_pci_acp5x

Device-3: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
    vendor: ASUSTeK driver: N/A bus-ID: 05:00.5 chip-ID: 1022:15e2

I suspect system is only detecting one internal microphone as an analog device and may need a kernel patch to get ACP driver loaded correctly

I suggest you update system BIOS
G713QM - Support

Then get ALSA data to check audio devices and drivers

sudo alsa-info.sh --upload

I am sorry I am not sure what this is. Do you mean I ask the people at ALSA-project to help me out with this?

The suggested command runs a script to gather diagnostic data about ALSA

ALSA Information Script v 0.5.1
--------------------------------

This script visits the following commands/files to collect diagnostic
information about your ALSA installation and sound related hardware

  dmesg
  lspci
  aplay
  amixer
  alsactl
  rpm, dpkg
  /proc/asound/
  /sys/class/sound/
  ~/.asoundrc (etc.)

The --upload option uploads the data to alsa-project. The option can be omitted and data uploaded to a pastebin site or similar. Too much data to post on here direct

I uploaded the Data, but nothing has happened so far. Unless you meant that paste the link here to the data here?

Here it it.
https://alsa-project.org/db/?f=f6699756ca5480e4e5ee65801a43f4cab68efcf7