Bugs After Update


Like two weeks ago or so I installed like 233 or 237 updates.
I first posted about the first issue in a facebook group for Manjaro and Arch linux, no help there yet. One response for a fix, not sure I will understand how to do it though.

An issue that started occurring after the updates is that my mouse will work after I restart but soon afterwards it will stop working, so I have to restart my laptop constantly. I’ve noticed in my messenger app, it will click by itself, and so will highlight my text or click somewhere in the middle of what I’ve already typed, so I will look up and it will look like gibberish because it’s mixing my text input up, having issues with the mouse makes this hard to remedy by cutting and pasting. I have tried putting a new battery into my laser mouse and I’ve tried using my other mouse. It happens in the browser and off but for some reason, certain usage cases seem to make it stop working faster. Like it seems to crash faster on facebook, while I’ve yet to experience a problem on just eBay. I thought it could be being caused by a damaged touch pad. I accidentally leaned on the right side of it and now it’s pushed it.
I’ve tried installing other mouse drivers.

My computer also freezes.

My sound doesn’t work in my Chromium and Brave browsers.
YouTube says:
Audio renderer error. Please restart your computer.
Of course I did multiple times.

Please help me fix these issues.
When I reformat my computer, it takes me weeks around the clock to set it back up,
Because I reinstall all my programs, set the options, and tweak everything to perfection.

In order for others here to attempt to help you with your issues, please read:

Wow, don’t you use Timeshift to snapshot your system?
After a fresh USB install, for example, I first open my Timeshift folder, then import my last .bashrc and .zshrc and then open a terminal already set up… then I copy my .easystroke folder and install easystroke so I can drive my desktop with mouse gestures…

Importing your already perfect options shouldn’t take more than a few hours.

Will you try creating a new user (with a new, clean profile) and see if the issue persists in that environment?

Bluetooth mouse?
Restarting the bluetooth.service should suffice instead of a reboot each time

See whether you have tlp installed - I think it is standard.
Disable it or set it so that the bluetooth adapter is exempt from power saving

Also, removing the device and re-adding it sometimes helps.

No Idea about your sound issue.
Can you be sure it wasn’t something you did?
Are you able to re-trace your steps?
Probably not if it took you weeks to set this thing up.
If you did things on the command line, then your shell history will be of help.

To be able to quickly reinstall all you need is a list of the installed software packages.
Can be easily created with one or two pacman commands.
Then back up your home folder including the hidden files
and also the system /etc directory
Timeshift was already mentioned - there are many more options.

Then you have everything to be up and running again in an hour should your system be irrecoverable - which is rarely the case.

You don’t mention anything useful - no system information - no nothing.

Have you used AUR packages to tweak your system?

The lack of information makes it next to impossible to provide anything useful.

what is the output of

pacman -Qm

Yes, but I ran -Suu, a command to run if extra repos cause package breaks
and it says “there’s nothing to do.”

breeze-adapta-cursor-theme-git r32.1d24541-1
breeze-blurred-git 1:42.716ed7c-1
chromium-snapshot-bin 90.0.4403.0.r848081-1
chromium-widevine 1:4.10.1679.0-1
delft-icon-theme 1.14-1
electronmail-bin 4.10.1-1
esniper 2.35.0-0
esniper-web r24.a0c7707-1
ex-impression-icon-theme-git r46.899ff7b8-1
gnome-shell-extension-nightshellswitcher 24.r0.geed5897-1
gpointing-device-settings 1.5.1-5
gtk-youtube-viewer-git 3.8.1.r1.g3807c3e-1
hydroxide 0.2.17-1
lila-hd r356.c98c28b-1
mhwd-nvidia-340xx 340.108-1
minitube-bin 3.7-1
netflix-qdesktop 0.91-1
networkmanager-wireguard-git r87.0e1124d-1
numix-circle-arc-icons-git 20.1-1
numix-circle-icon-theme-git 20.09.19.r0.g8b749c0-1
numix-icon-theme-git 20.06.07.r8.g91e4a9747-1
obsidian-icon-theme 4.15-1
pcloud-drive 1.9.0-1
popcorntime-bin 0.4.4-2
protonmail-desktop 1.0.6-2
python-backports-abc 0.5-00
python-sentry_sdk 0.19.5-1
python-shreddit-git r377.b0c9ea2-1
python-yappi 1.3.2-1
qtws-base 0.92-1
revolt-git r178.0aca6c8-1
signal-desktop-beta-bin 1.40.0beta.7-1
silos 0.1.55-1
tor-browser 10.0.10-1
torguard 4.4.1-1
tribler 7.8.0-1
wallpaper-reddit-git r191.1110bdb-1
whirlpool-gui-bin 0.10.2-1
xdg-su 1.2.3-2
youtube 1.0.4-1

@Nachlese I’m haing trouble finding and getting the restart bluetooth services command to work.
I tried “sudo /etc/init.d/bluetooth restart”

Ben, thank you, I will use that. :grinning:

That won’t work. I wonder what you use as your source of information.
Try the Arch wiki - and/or the Manjaro wiki.

Manjaro uses systemd.
systemctl status bluetooth.service
and see what you get

1 Like

I get:

● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Sat 2021-02-20 05:44:28 EST; 1h 37min ago
       Docs: man:bluetoothd(8)
   Main PID: 767 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 13699)
     Memory: 2.6M
     CGroup: /system.slice/bluetooth.service
             └─767 /usr/lib/bluetooth/bluetoothd

Feb 20 05:44:28 l-r bluetoothd[767]: src/main.c:parse_controller_config() Key file does not have key “LEMinConnectionInterval” in group “Controller”
Feb 20 05:44:28 l-r bluetoothd[767]: src/main.c:parse_controller_config() Key file does not have key “LEMaxConnectionInterval” in group “Controller”
Feb 20 05:44:28 l-r bluetoothd[767]: src/main.c:parse_controller_config() Key file does not have key “LEConnectionLatency” in group “Controller”
Feb 20 05:44:28 l-r bluetoothd[767]: src/main.c:parse_controller_config() Key file does not have key “LEConnectionSupervisionTimeout” in group “Controller”
Feb 20 05:44:28 l-r bluetoothd[767]: src/main.c:parse_controller_config() Key file does not have key “LEAutoconnecttimeout” in group “Controller”
Feb 20 05:44:28 l-r bluetoothd[767]: Starting SDP server
Feb 20 05:44:28 l-r bluetoothd[767]: Bluetooth management interface 1.18 initialized
Feb 20 05:44:32 l-r bluetoothd[767]: Endpoint registered: sender=:1.28 path=/MediaEndpoint/A2DPSink/sbc
Feb 20 05:44:32 l-r bluetoothd[767]: Endpoint registered: sender=:1.28 path=/MediaEndpoint/A2DPSource/sbc
Feb 20 05:44:35 l-r bluetoothd[767]: Failed to set mode: Blocked through rfkill (0x12)

Notice the last line?
In the upper right I leave bluetooth off until I wear my bluetooth wireless headphones.
leaving it off has never effected the mouse before.
I’ve disabled my touchpad and the issue persists.

This was intended as a question.
I just assumed that it is - but still don’t know.

in order to restart bluetooth (instead of rebooting the whole system)
systemctl restart bluetooth.service

Yes, it is. The issue with the “audio renderer” was due to using the snapshot version of chromium. Videos play fine on Brave; Gonna downgrade Chromium snapshot.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.