Bug with onboard WiFi beyond kernel 5.9

I have a laptop with onboard WiFi (Intel® Wi-Fi 6 AX 201).

If the link works, this is my computer - https://linux-hardware.org/?probe=a18b247e3d. It is a HP Spectre x360 - 13-aw0116na.

If I upgrade to any available kernel beyond 5.9 (e.g. 5.10 or 5.11) then I get problems with my WiFi. Such problems are poor transfer speeds, and intermittent “hanging” where it shows as connected but I can’t reach anything on either my LAN or the internet for about 10 seconds. If i downgrade back to kernel 5.9, it performs flawlessly again.

I appreciate that this is most likely a problem with the Linux kernel rather than Manjaro specifically, however, I wanted to ask if I should report it somewhere? I am not very knowledgeable on this front.

Thanks for any advice

1 Like

Kernel 5.9 is EOL so please install 5.4 LTS (Long Time Support) and see if that solves your problem for the moment until a bug gets filed with Intel.


1 Like

Yep - very good point - I should have realised that.

Done and seems to be working fine. I’ll happily stick to the LTS for now - thanks for the advice.

I had identical troubles on desktop with Intel Dual Band Wireless-AC 3168NGW. Network manager still maintained wifi log-on credentials, but it stopped seeing any signal past 5.8.

By accident, I found disabling the LAN in boot BIOS/UEFI would clear the wifi problem and connect on those later kernels. No idea how or why it is involved, but works.

I could be wrong, but that sounds like a slightly different problem. For me, the WiFi remains connected with good signal, and I do get intermittent access to the network, but it keeps stopping for around 10 seconds at time. Additionally, if I run a speed test, I can see that the overall transfer rate is rubbish (about 4mpbs when it should be more like 35 to 40 mbps) as well as the aforementioned 10 second “stops” where no traffic is getting through at all.

The network manager applet thing shows as connected the whole time, but occasionally I get the pop up saying “limited connectivity” (I guess as it suddenly realises it can’t reach the wider Internet).

Maybe that is the same as your problem, or a variation on the same thing . I’m not sure.

I’ll try disabling my LAN. Thanks for the tip. See if it makes any difference.

1 Like

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.